FAQ
Hi

Could someone please let me know if newer puppet node version 2.7.xx would
work with old puppet master running version 2.6 ?

--
Regards,
Balasubramaniam Natarajan
www.blog.etutorshop.com

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Bernd Adamowicz at Nov 29, 2012 at 3:37 pm
    No. Never have a higher version of Puppet on your agents than on your master.

    Bernd

    From: puppet-users@googlegroups.com On Behalf Of Balasubramaniam Natarajan
    Sent: Donnerstag, 29. November 2012 16:28
    To: puppet-users@googlegroups.com
    Subject: [Puppet Users] Is new puppet node compatible with old puppetmaster ?

    Hi

    Could someone please let me know if newer puppet node version 2.7.xx would work with old puppet master running version 2.6 ?

    --
    Regards,
    Balasubramaniam Natarajan
    www.blog.etutorshop.com<http://www.blog.etutorshop.com>
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com .
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com .
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Walter Heck at Dec 3, 2012 at 1:06 am
    Actually, isn't it the other way around? Newer agents will be able to apply
    catalogs from older masters. Older agents won't (necessarily) be able to
    interpret catalogs from newer masters, right?

    Walter
    On Thu, Nov 29, 2012 at 5:37 PM, Bernd Adamowicz wrote:

    No. Never have a higher version of Puppet on your agents than on your
    master.****

    ** **

    Bernd****

    ** **

    *From:* puppet-users@googlegroups.com [mailto:
    puppet-users@googlegroups.com] *On Behalf Of *Balasubramaniam Natarajan
    *Sent:* Donnerstag, 29. November 2012 16:28
    *To:* puppet-users@googlegroups.com
    *Subject:* [Puppet Users] Is new puppet node compatible with old
    puppetmaster ?****

    ** **

    Hi

    Could someone please let me know if newer puppet node version 2.7.xx would
    work with old puppet master running version 2.6 ?

    --
    Regards,
    Balasubramaniam Natarajan
    www.blog.etutorshop.com****

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.****

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.


    --
    Walter Heck

    --
    Check out my startup: Puppet training and consulting @
    http://www.olindata.com
    Follow @olindata on Twitter and/or 'Like' our Facebook page at
    http://www.facebook.com/olindata

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Kevin at Dec 3, 2012 at 1:04 am
    No newer masters support older methods for a catalog.

    Newer agents will use newer methods.

    master >= agent == fine
    master < agent == borked

    On Mon, Dec 3, 2012 at 12:00 PM, Walter Heck wrote:
    Actually, isn't it the other way around? Newer agents will be able to apply
    catalogs from older masters. Older agents won't (necessarily) be able to
    interpret catalogs from newer masters, right?

    Walter


    On Thu, Nov 29, 2012 at 5:37 PM, Bernd Adamowicz
    wrote:
    No. Never have a higher version of Puppet on your agents than on your
    master.



    Bernd



    From: puppet-users@googlegroups.com
    On Behalf Of Balasubramaniam Natarajan
    Sent: Donnerstag, 29. November 2012 16:28
    To: puppet-users@googlegroups.com
    Subject: [Puppet Users] Is new puppet node compatible with old
    puppetmaster ?



    Hi

    Could someone please let me know if newer puppet node version 2.7.xx would
    work with old puppet master running version 2.6 ?

    --
    Regards,
    Balasubramaniam Natarajan
    www.blog.etutorshop.com

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.



    --
    Walter Heck

    --
    Check out my startup: Puppet training and consulting @
    http://www.olindata.com
    Follow @olindata on Twitter and/or 'Like' our Facebook page at
    http://www.facebook.com/olindata

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Balasubramaniam Natarajan at Dec 3, 2012 at 10:54 am
    Thanks you people saved me lots of time :-)
    On Sun, Dec 2, 2012 at 8:04 PM, Kevin wrote:

    No newer masters support older methods for a catalog.

    Newer agents will use newer methods.

    master >= agent == fine
    master < agent == borked

    On Mon, Dec 3, 2012 at 12:00 PM, Walter Heck wrote:
    Actually, isn't it the other way around? Newer agents will be able to apply
    catalogs from older masters. Older agents won't (necessarily) be able to
    interpret catalogs from newer masters, right?

    Walter


    On Thu, Nov 29, 2012 at 5:37 PM, Bernd Adamowicz
    wrote:
    No. Never have a higher version of Puppet on your agents than on your
    master.



    Bernd



    From: puppet-users@googlegroups.com [mailto:
    puppet-users@googlegroups.com]
    On Behalf Of Balasubramaniam Natarajan
    Sent: Donnerstag, 29. November 2012 16:28
    To: puppet-users@googlegroups.com
    Subject: [Puppet Users] Is new puppet node compatible with old
    puppetmaster ?



    Hi

    Could someone please let me know if newer puppet node version 2.7.xx
    would
    work with old puppet master running version 2.6 ?

    --
    Regards,
    Balasubramaniam Natarajan
    www.blog.etutorshop.com

    --
    You received this message because you are subscribed to the Google
    Groups
    "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.

    --
    You received this message because you are subscribed to the Google
    Groups
    "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.



    --
    Walter Heck

    --
    Check out my startup: Puppet training and consulting @
    http://www.olindata.com
    Follow @olindata on Twitter and/or 'Like' our Facebook page at
    http://www.facebook.com/olindata

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.

    --
    Regards,
    Balasubramaniam Natarajan
    www.blog.etutorshop.com

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedNov 29, '12 at 3:27p
activeDec 3, '12 at 10:54a
posts5
users4
websitepuppetlabs.com

People

Translate

site design / logo © 2021 Grokbase