FAQ
Hi all,

my problem is described below

puppet agent do Exec :

exec {"create-${user}-${host}-${database}-user-mycnf":
creates => $outfile,
cwd => "/tmp",
command => "${outscript}",
provider => shell
}

of shell script $outscipt :
#!/bin/bash
mysql -e "grant all on mydb.* to 'myuser'@'%' identified by '$pw';"
touch $outfile

mysql uses password in /root/.my.cnf

it was failing for a long time.
Today I restarted agent (actually upgraded to 2.7.20)
after restart of agent Exec was run sucessfully

my.cnf was changed a long time ago ($outfile was removed in that time
also). I suppose Exec started to fail after changing mysql password.

Could puppet cache /root/.my.cnf and reread it only after reboot.
I see no other explanation. Is it bug?

thanks in advance
--
Best regards,
Vasil Mikhalenya

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Peter Meier at Nov 28, 2012 at 6:01 pm

    Could puppet cache /root/.my.cnf and reread it only after reboot.
    I see no other explanation. Is it bug?
    No, puppet does nothing like that. It's strange that it works *now* but
    I would say the problem is definitely somewhere else.

    ~pete

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedNov 28, '12 at 4:18p
activeNov 28, '12 at 6:01p
posts2
users2
websitepuppetlabs.com

2 users in discussion

Vasil Mikhalenya: 1 post Peter Meier: 1 post

People

Translate

site design / logo © 2022 Grokbase