FAQ
I'm testing a fedora 17 deployment and am using puppet 2.7.x and puppetlabs-lvm-0.1.1. I have a problem in that a filesystem in a logical volume is continually trying to get itself created even though it already exists and is mounted. It looks as if this might be because there is no longer a "--guess-fstype" option in the mount command which the lvm module attempts to use. I'm not sure how to solve this.

Chris Ritson (Computing Officer and School Safety Officer)

Room 707, Claremont Tower, EMAIL: c.r.ritson@ncl.ac.uk
School of Computing Science, PHONE: +44 191 222 8175
Newcastle University, FAX : +44 191 222 8232
Newcastle upon Tyne, UK NE1 7RU. WEB : http://www.cs.ncl.ac.uk/


--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Mathieu Bornoz at Feb 22, 2013 at 9:47 am
    Hi,

    I just came across this problem due to an upgrade of util-linux-ng on
    RHEL6 this morning :(

    I have not seen any github PR related to this problem on puppetlabs-lvm
    module so I will propose a patch (if it works) to replace "mount -f
    --guest-fstype /dev/..." by "file -sL /dev/..."

    Cheers,
    Mathieu
    On 11/21/2012 04:54 PM, C R Ritson wrote:
    I'm testing a fedora 17 deployment and am using puppet 2.7.x and puppetlabs-lvm-0.1.1. I have a problem in that a filesystem in a logical volume is continually trying to get itself created even though it already exists and is mounted. It looks as if this might be because there is no longer a "--guess-fstype" option in the mount command which the lvm module attempts to use. I'm not sure how to solve this.

    Chris Ritson (Computing Officer and School Safety Officer)

    Room 707, Claremont Tower, EMAIL: c.r.ritson@ncl.ac.uk
    School of Computing Science, PHONE: +44 191 222 8175
    Newcastle University, FAX : +44 191 222 8232
    Newcastle upon Tyne, UK NE1 7RU. WEB : http://www.cs.ncl.ac.uk/
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Steve foster at Feb 22, 2013 at 10:32 am
    Logged a bug:

    http://projects.puppetlabs.com/issues/19410
    On Friday, 22 February 2013 09:47:33 UTC, Mathieu Bornoz wrote:

    Hi,

    I just came across this problem due to an upgrade of util-linux-ng on
    RHEL6 this morning :(

    I have not seen any github PR related to this problem on puppetlabs-lvm
    module so I will propose a patch (if it works) to replace "mount -f
    --guest-fstype /dev/..." by "file -sL /dev/..."

    Cheers,
    Mathieu
    On 11/21/2012 04:54 PM, C R Ritson wrote:
    I'm testing a fedora 17 deployment and am using puppet 2.7.x and
    puppetlabs-lvm-0.1.1. I have a problem in that a filesystem in a logical
    volume is continually trying to get itself created even though it already
    exists and is mounted. It looks as if this might be because there is no
    longer a "--guess-fstype" option in the mount command which the lvm module
    attempts to use. I'm not sure how to solve this.
    Chris Ritson (Computing Officer and School Safety Officer)

    Room 707, Claremont Tower, EMAIL: C.R.R...@ncl.ac.uk<javascript:>
    School of Computing Science, PHONE: +44 191 222 8175
    Newcastle University, FAX : +44 191 222 8232
    Newcastle upon Tyne, UK NE1 7RU. WEB : http://www.cs.ncl.ac.uk/
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Chuck at Feb 25, 2013 at 4:36 pm
    Yep.. Red Hat was nice enough to take "--guest-fstype" out of RHEL 6.4.


    On Friday, February 22, 2013 4:25:04 AM UTC-6, steve foster wrote:

    Logged a bug:

    http://projects.puppetlabs.com/issues/19410
    On Friday, 22 February 2013 09:47:33 UTC, Mathieu Bornoz wrote:

    Hi,

    I just came across this problem due to an upgrade of util-linux-ng on
    RHEL6 this morning :(

    I have not seen any github PR related to this problem on puppetlabs-lvm
    module so I will propose a patch (if it works) to replace "mount -f
    --guest-fstype /dev/..." by "file -sL /dev/..."

    Cheers,
    Mathieu
    On 11/21/2012 04:54 PM, C R Ritson wrote:
    I'm testing a fedora 17 deployment and am using puppet 2.7.x and
    puppetlabs-lvm-0.1.1. I have a problem in that a filesystem in a logical
    volume is continually trying to get itself created even though it already
    exists and is mounted. It looks as if this might be because there is no
    longer a "--guess-fstype" option in the mount command which the lvm module
    attempts to use. I'm not sure how to solve this.
    Chris Ritson (Computing Officer and School Safety Officer)

    Room 707, Claremont Tower, EMAIL: C.R.R...@ncl.ac.uk
    School of Computing Science, PHONE: +44 191 222 8175
    Newcastle University, FAX : +44 191 222 8232
    Newcastle upon Tyne, UK NE1 7RU. WEB : http://www.cs.ncl.ac.uk/
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • John Warburton at Feb 26, 2013 at 10:29 pm

    On 26 February 2013 03:30, Chuck wrote:

    Yep.. Red Hat was nice enough to take "--guest-fstype" out of RHEL 6.4.
    On Friday, February 22, 2013 4:25:04 AM UTC-6, steve foster wrote:

    Logged a bug:

    http://projects.puppetlabs.**com/issues/19410<http://projects.puppetlabs.com/issues/19410>
    On Friday, 22 February 2013 09:47:33 UTC, Mathieu Bornoz wrote:

    Hi,
    I have tested Mathieu's patch per his pull
    request<https://github.com/puppetlabs/puppetlabs-lvm/pull/23>in the
    bug ticket and it works like a charm (RHEL 6.4, ext4 only). Thanks
    Mathieu!

    How do we get this into an official update of the lvm module on the forge?

    John

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedNov 21, '12 at 3:54p
activeFeb 26, '13 at 10:29p
posts5
users5
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase