FAQ
Hi All,

In foreman I checked hosts status and found one host was " out of sync ", I
logined the box and check the status of puppet, no obvious issues found (
puppet was running at that point time). Then I tried to restart puppet and
but failed (also no related log).

/etc/init.d/puppet restart
* Restarting puppet
agent
[fail]

I had to delete the puppet pid file, rm -f /var/run/puppet/agent.pid ,
then restarted puppet and it worked.

My OS is ubuntu 12.04 and the puppet version is " 2.7.11-1ubuntu2.1"

What is root case of this issue ? Thanks.

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/TLf7iXAJWg8J.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedNov 20, '12 at 4:23p
activeNov 20, '12 at 4:23p
posts1
users1
websitepuppetlabs.com

1 user in discussion

Gm: 1 post

People

Translate

site design / logo © 2022 Grokbase