FAQ
Hello all,

I am quite new to the puppet arena, but I am really impressed with puppet
as a tool and the possibilities it gives you with regards to managing many
systems.

I am running dashboard 1.2.14 and am trying to query via the rake API:
http://docs.puppetlabs.com/dashboard/manual/1.2/rake_api.html

when I do, I get the following error:

<snip>

# sudo -u puppet-dashboard rake -f /usr/share/puppet-dashboard/Rakefile
'node:list'
(in /var/log)
config.gem: Unpacked gem daemons-1.0.10 in vendor/gems has no specification
file. Run 'rake gems:refresh_specs' to fix this.
config.gem: Unpacked gem rack-1.1.2 in vendor/gems has no specification
file. Run 'rake gems:refresh_specs' to fix this.
config.gem: Unpacked gem rspec-1.3.2 in vendor/gems has no specification
file. Run 'rake gems:refresh_specs' to fix this.
config.gem: Unpacked gem rdoc-3.6.1 in vendor/gems has no specification
file. Run 'rake gems:refresh_specs' to fix this.
config.gem: Unpacked gem rspec-rails-1.3.4 in vendor/gems has no
specification file. Run 'rake gems:refresh_specs' to fix this.
config.gem: Unpacked gem thoughtbot-shoulda-2.10.2 in vendor/gems has no
specification file. Run 'rake gems:refresh_specs' to fix this.
config.gem: Unpacked gem mocha-0.9.7 in vendor/gems has no specification
file. Run 'rake gems:refresh_specs' to fix this.
config.gem: Unpacked gem will_paginate-2.3.15 in vendor/gems has no
specification file. Run 'rake gems:refresh_specs' to fix this.
config.gem: Unpacked gem json_pure-1.5.1 in vendor/gems has no
specification file. Run 'rake gems:refresh_specs' to fix this.
config.gem: Unpacked gem haml-3.1.2 in vendor/gems has no specification
file. Run 'rake gems:refresh_specs' to fix this.
config.gem: Unpacked gem sass-3.1.2 in vendor/gems has no specification
file. Run 'rake gems:refresh_specs' to fix this.
config.gem: Unpacked gem factory_girl-1.3.3 in vendor/gems has no
specification file. Run 'rake gems:refresh_specs' to fix this.
DEPRECATION WARNING: Rake tasks in vendor/plugins/delayed_job/tasks are
deprecated. Use lib/tasks instead. (called from
/usr/share/puppet-dashboard/vendor/rails/railties/lib/tasks/rails.rb:10)



</snip>



...I fail to find any info on this online ... has anyone else seen this?

Thanks,

//Jacob.

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/oM7WDU0rDlsJ.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Stefan Heijmans at Nov 19, 2012 at 6:37 pm
    Yes, I noticed it in 1.2.13 (
    https://groups.google.com/d/msg/puppet-users/-s07XIymxCo/Yp3DpRU4t6EJ) but
    not in 1.2.14.
    Fixed it by running the mentioned 'rake gems:refresh_specs'

    Stefan

    On Monday, November 19, 2012 10:11:35 AM UTC+1, Jacob wrote:

    Hello all,

    I am quite new to the puppet arena, but I am really impressed with puppet
    as a tool and the possibilities it gives you with regards to managing many
    systems.

    I am running dashboard 1.2.14 and am trying to query via the rake API:
    http://docs.puppetlabs.com/dashboard/manual/1.2/rake_api.html

    when I do, I get the following error:

    <snip>

    # sudo -u puppet-dashboard rake -f /usr/share/puppet-dashboard/Rakefile
    'node:list'
    (in /var/log)
    config.gem: Unpacked gem daemons-1.0.10 in vendor/gems has no
    specification file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem rack-1.1.2 in vendor/gems has no specification
    file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem rspec-1.3.2 in vendor/gems has no specification
    file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem rdoc-3.6.1 in vendor/gems has no specification
    file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem rspec-rails-1.3.4 in vendor/gems has no
    specification file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem thoughtbot-shoulda-2.10.2 in vendor/gems has no
    specification file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem mocha-0.9.7 in vendor/gems has no specification
    file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem will_paginate-2.3.15 in vendor/gems has no
    specification file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem json_pure-1.5.1 in vendor/gems has no
    specification file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem haml-3.1.2 in vendor/gems has no specification
    file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem sass-3.1.2 in vendor/gems has no specification
    file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem factory_girl-1.3.3 in vendor/gems has no
    specification file. Run 'rake gems:refresh_specs' to fix this.
    DEPRECATION WARNING: Rake tasks in vendor/plugins/delayed_job/tasks are
    deprecated. Use lib/tasks instead. (called from
    /usr/share/puppet-dashboard/vendor/rails/railties/lib/tasks/rails.rb:10)



    </snip>



    ...I fail to find any info on this online ... has anyone else seen this?

    Thanks,

    //Jacob.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/3I-0_vYZfBAJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Jacob at Nov 20, 2012 at 7:36 am
    Thanks :)

    Now I get

    <snip>

    # sudo -u puppet-dashboard rake -f /usr/share/puppet-dashboard/Rakefile
    'node:list'
    (in /usr/share/puppet-dashboard)
    DEPRECATION WARNING: Rake tasks in vendor/plugins/delayed_job/tasks are
    deprecated. Use lib/tasks instead. (called from
    /usr/share/puppet-dashboard/vendor/rails/railties/lib/tasks/rails.rb:10)

    </snip>



    Il giorno lunedì 19 novembre 2012 19:37:43 UTC+1, Stefan Heijmans ha
    scritto:
    Yes, I noticed it in 1.2.13 (
    https://groups.google.com/d/msg/puppet-users/-s07XIymxCo/Yp3DpRU4t6EJ)
    but not in 1.2.14.
    Fixed it by running the mentioned 'rake gems:refresh_specs'

    Stefan

    On Monday, November 19, 2012 10:11:35 AM UTC+1, Jacob wrote:

    Hello all,

    I am quite new to the puppet arena, but I am really impressed with puppet
    as a tool and the possibilities it gives you with regards to managing many
    systems.

    I am running dashboard 1.2.14 and am trying to query via the rake API:
    http://docs.puppetlabs.com/dashboard/manual/1.2/rake_api.html

    when I do, I get the following error:

    <snip>

    # sudo -u puppet-dashboard rake -f /usr/share/puppet-dashboard/Rakefile
    'node:list'
    (in /var/log)
    config.gem: Unpacked gem daemons-1.0.10 in vendor/gems has no
    specification file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem rack-1.1.2 in vendor/gems has no specification
    file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem rspec-1.3.2 in vendor/gems has no specification
    file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem rdoc-3.6.1 in vendor/gems has no specification
    file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem rspec-rails-1.3.4 in vendor/gems has no
    specification file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem thoughtbot-shoulda-2.10.2 in vendor/gems has no
    specification file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem mocha-0.9.7 in vendor/gems has no specification
    file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem will_paginate-2.3.15 in vendor/gems has no
    specification file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem json_pure-1.5.1 in vendor/gems has no
    specification file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem haml-3.1.2 in vendor/gems has no specification
    file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem sass-3.1.2 in vendor/gems has no specification
    file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem factory_girl-1.3.3 in vendor/gems has no
    specification file. Run 'rake gems:refresh_specs' to fix this.
    DEPRECATION WARNING: Rake tasks in vendor/plugins/delayed_job/tasks are
    deprecated. Use lib/tasks instead. (called from
    /usr/share/puppet-dashboard/vendor/rails/railties/lib/tasks/rails.rb:10)



    </snip>



    ...I fail to find any info on this online ... has anyone else seen this?

    Thanks,

    //Jacob.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/Q-XcVfScapMJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Bruno Léon at Nov 20, 2012 at 5:43 pm
    Does it fail or only warn ?
    I can only see dprecation warnings in your message.

    --
    Bruno

    On November 19, 2012 11:36:17 PM Jacob wrote:

    Thanks :)

    Now I get

    <snip>

    # sudo -u puppet-dashboard rake -f /usr/share/puppet-dashboard/Rakefile
    'node:list'
    (in /usr/share/puppet-dashboard)
    DEPRECATION WARNING: Rake tasks in vendor/plugins/delayed_job/tasks are
    deprecated. Use lib/tasks instead. (called from /usr/share/puppet-
    dashboard/vendor/rails/railties/lib/tasks/rails.rb:10)

    </snip>



    Il giorno lunedì 19 novembre 2012 19:37:43 UTC+1, Stefan Heijmans ha scritto:
    Yes, I noticed it in 1.2.13 (https://groups.google.com/d/msg/puppet-users/-
    s07XIymxCo/Yp3DpRU4t6EJ) but not in 1.2.14.
    Fixed it by running the mentioned 'rake gems:refresh_specs'


    Stefan


    On Monday, November 19, 2012 10:11:35 AM UTC+1, Jacob wrote:
    Hello all,

    I am quite new to the puppet arena, but I am really impressed with puppet as a
    tool and the possibilities it gives you with regards to managing many systems.

    I am running dashboard 1.2.14 and am trying to query via the rake API:
    http://docs.puppetlabs.com/dashboard/manual/1.2/rake_api.html

    when I do, I get the following error:

    <snip>

    # sudo -u puppet-dashboard rake -f /usr/share/puppet-dashboard/Rakefile
    'node:list'
    (in /var/log)
    config.gem: Unpacked gem daemons-1.0.10 in vendor/gems has no specification file.
    Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem rack-1.1.2 in vendor/gems has no specification file. Run
    'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem rspec-1.3.2 in vendor/gems has no specification file.
    Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem rdoc-3.6.1 in vendor/gems has no specification file. Run
    'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem rspec-rails-1.3.4 in vendor/gems has no specification
    file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem thoughtbot-shoulda-2.10.2 in vendor/gems has no
    specification file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem mocha-0.9.7 in vendor/gems has no specification file.
    Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem will_paginate-2.3.15 in vendor/gems has no
    specification file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem json_pure-1.5.1 in vendor/gems has no specification
    file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem haml-3.1.2 in vendor/gems has no specification file. Run
    'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem sass-3.1.2 in vendor/gems has no specification file. Run
    'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem factory_girl-1.3.3 in vendor/gems has no specification
    file. Run 'rake gems:refresh_specs' to fix this.
    DEPRECATION WARNING: Rake tasks in vendor/plugins/delayed_job/tasks are
    deprecated. Use lib/tasks instead. (called from /usr/share/puppet-
    dashboard/vendor/rails/railties/lib/tasks/rails.rb:10)



    </snip>



    ...I fail to find any info on this online ... has anyone else seen this?

    Thanks,

    //Jacob.

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/Q-XcVfScapMJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-
    users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-
    users?hl=en.



    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Jacob at Nov 21, 2012 at 7:12 am
    I don't get the expected output... (a list of my nodes)..

    only the deprecation warning.





    Il giorno martedì 20 novembre 2012 18:37:49 UTC+1, Bruno Leon ha scritto:
    Does it fail or only warn ?

    I can only see dprecation warnings in your message.



    --

    Bruno



    On November 19, 2012 11:36:17 PM Jacob wrote:

    Thanks :)

    Now I get

    <snip>

    # sudo -u puppet-dashboard rake -f /usr/share/puppet-dashboard/Rakefile
    'node:list'
    (in /usr/share/puppet-dashboard)
    DEPRECATION WARNING: Rake tasks in vendor/plugins/delayed_job/tasks are
    deprecated. Use lib/tasks instead. (called from
    /usr/share/puppet-dashboard/vendor/rails/railties/lib/tasks/rails.rb:10)

    </snip>



    Il giorno lunedì 19 novembre 2012 19:37:43 UTC+1, Stefan Heijmans ha
    scritto:

    Yes, I noticed it in 1.2.13 (
    https://groups.google.com/d/msg/puppet-users/-s07XIymxCo/Yp3DpRU4t6EJ)
    but not in 1.2.14.

    Fixed it by running the mentioned 'rake gems:refresh_specs'


    Stefan



    On Monday, November 19, 2012 10:11:35 AM UTC+1, Jacob wrote:

    Hello all,

    I am quite new to the puppet arena, but I am really impressed with puppet
    as a tool and the possibilities it gives you with regards to managing many
    systems.

    I am running dashboard 1.2.14 and am trying to query via the rake API:
    http://docs.puppetlabs.com/dashboard/manual/1.2/rake_api.html

    when I do, I get the following error:

    <snip>

    # sudo -u puppet-dashboard rake -f /usr/share/puppet-dashboard/Rakefile
    'node:list'
    (in /var/log)
    config.gem: Unpacked gem daemons-1.0.10 in vendor/gems has no
    specification file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem rack-1.1.2 in vendor/gems has no specification
    file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem rspec-1.3.2 in vendor/gems has no specification
    file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem rdoc-3.6.1 in vendor/gems has no specification
    file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem rspec-rails-1.3.4 in vendor/gems has no
    specification file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem thoughtbot-shoulda-2.10.2 in vendor/gems has no
    specification file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem mocha-0.9.7 in vendor/gems has no specification
    file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem will_paginate-2.3.15 in vendor/gems has no
    specification file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem json_pure-1.5.1 in vendor/gems has no
    specification file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem haml-3.1.2 in vendor/gems has no specification
    file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem sass-3.1.2 in vendor/gems has no specification
    file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem factory_girl-1.3.3 in vendor/gems has no
    specification file. Run 'rake gems:refresh_specs' to fix this.
    DEPRECATION WARNING: Rake tasks in vendor/plugins/delayed_job/tasks are
    deprecated. Use lib/tasks instead. (called from
    /usr/share/puppet-dashboard/vendor/rails/railties/lib/tasks/rails.rb:10)



    </snip>



    ...I fail to find any info on this online ... has anyone else seen this?

    Thanks,

    //Jacob.

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/Q-XcVfScapMJ.
    To post to this group, send email to puppet...@googlegroups.com<javascript:>
    .
    To unsubscribe from this group, send email to
    puppet-users...@googlegroups.com <javascript:>.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.


    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/DVEJ5aYLrNIJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Stefan Heijmans at Nov 21, 2012 at 8:04 am
    And when you provide the RAILS_ENV you are using? For example;

    sudo -u puppet-dashboard rake -f /usr/share/puppet-dashboard/Rakefile
    RAILS_ENV=production 'node:list'



    Op woensdag 21 november 2012 08:12:48 UTC+1 schreef Jacob het volgende:
    I don't get the expected output... (a list of my nodes)..

    only the deprecation warning.





    Il giorno martedì 20 novembre 2012 18:37:49 UTC+1, Bruno Leon ha scritto:
    Does it fail or only warn ?

    I can only see dprecation warnings in your message.



    --

    Bruno



    On November 19, 2012 11:36:17 PM Jacob wrote:

    Thanks :)

    Now I get

    <snip>

    # sudo -u puppet-dashboard rake -f /usr/share/puppet-dashboard/Rakefile
    'node:list'
    (in /usr/share/puppet-dashboard)
    DEPRECATION WARNING: Rake tasks in vendor/plugins/delayed_job/tasks are
    deprecated. Use lib/tasks instead. (called from
    /usr/share/puppet-dashboard/vendor/rails/railties/lib/tasks/rails.rb:10)

    </snip>



    Il giorno lunedì 19 novembre 2012 19:37:43 UTC+1, Stefan Heijmans ha
    scritto:

    Yes, I noticed it in 1.2.13 (
    https://groups.google.com/d/msg/puppet-users/-s07XIymxCo/Yp3DpRU4t6EJ)
    but not in 1.2.14.

    Fixed it by running the mentioned 'rake gems:refresh_specs'


    Stefan



    On Monday, November 19, 2012 10:11:35 AM UTC+1, Jacob wrote:

    Hello all,

    I am quite new to the puppet arena, but I am really impressed with puppet
    as a tool and the possibilities it gives you with regards to managing many
    systems.

    I am running dashboard 1.2.14 and am trying to query via the rake API:
    http://docs.puppetlabs.com/dashboard/manual/1.2/rake_api.html

    when I do, I get the following error:

    <snip>

    # sudo -u puppet-dashboard rake -f /usr/share/puppet-dashboard/Rakefile
    'node:list'
    (in /var/log)
    config.gem: Unpacked gem daemons-1.0.10 in vendor/gems has no
    specification file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem rack-1.1.2 in vendor/gems has no specification
    file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem rspec-1.3.2 in vendor/gems has no specification
    file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem rdoc-3.6.1 in vendor/gems has no specification
    file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem rspec-rails-1.3.4 in vendor/gems has no
    specification file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem thoughtbot-shoulda-2.10.2 in vendor/gems has no
    specification file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem mocha-0.9.7 in vendor/gems has no specification
    file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem will_paginate-2.3.15 in vendor/gems has no
    specification file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem json_pure-1.5.1 in vendor/gems has no
    specification file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem haml-3.1.2 in vendor/gems has no specification
    file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem sass-3.1.2 in vendor/gems has no specification
    file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem factory_girl-1.3.3 in vendor/gems has no
    specification file. Run 'rake gems:refresh_specs' to fix this.
    DEPRECATION WARNING: Rake tasks in vendor/plugins/delayed_job/tasks are
    deprecated. Use lib/tasks instead. (called from
    /usr/share/puppet-dashboard/vendor/rails/railties/lib/tasks/rails.rb:10)



    </snip>



    ...I fail to find any info on this online ... has anyone else seen this?

    Thanks,

    //Jacob.

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/Q-XcVfScapMJ.
    To post to this group, send email to puppet...@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users...@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.


    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/tg3uEymfq4UJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Jacob at Nov 21, 2012 at 8:07 am
    :-) Thank you - that did it!





    Il giorno mercoledì 21 novembre 2012 09:04:29 UTC+1, Stefan Heijmans ha
    scritto:
    And when you provide the RAILS_ENV you are using? For example;

    sudo -u puppet-dashboard rake -f /usr/share/puppet-dashboard/Rakefile
    RAILS_ENV=production 'node:list'



    Op woensdag 21 november 2012 08:12:48 UTC+1 schreef Jacob het volgende:
    I don't get the expected output... (a list of my nodes)..

    only the deprecation warning.





    Il giorno martedì 20 novembre 2012 18:37:49 UTC+1, Bruno Leon ha scritto:
    Does it fail or only warn ?

    I can only see dprecation warnings in your message.



    --

    Bruno



    On November 19, 2012 11:36:17 PM Jacob wrote:

    Thanks :)

    Now I get

    <snip>

    # sudo -u puppet-dashboard rake -f /usr/share/puppet-dashboard/Rakefile
    'node:list'
    (in /usr/share/puppet-dashboard)
    DEPRECATION WARNING: Rake tasks in vendor/plugins/delayed_job/tasks are
    deprecated. Use lib/tasks instead. (called from
    /usr/share/puppet-dashboard/vendor/rails/railties/lib/tasks/rails.rb:10)

    </snip>



    Il giorno lunedì 19 novembre 2012 19:37:43 UTC+1, Stefan Heijmans ha
    scritto:

    Yes, I noticed it in 1.2.13 (
    https://groups.google.com/d/msg/puppet-users/-s07XIymxCo/Yp3DpRU4t6EJ)
    but not in 1.2.14.

    Fixed it by running the mentioned 'rake gems:refresh_specs'


    Stefan



    On Monday, November 19, 2012 10:11:35 AM UTC+1, Jacob wrote:

    Hello all,

    I am quite new to the puppet arena, but I am really impressed with
    puppet as a tool and the possibilities it gives you with regards to
    managing many systems.

    I am running dashboard 1.2.14 and am trying to query via the rake API:
    http://docs.puppetlabs.com/dashboard/manual/1.2/rake_api.html

    when I do, I get the following error:

    <snip>

    # sudo -u puppet-dashboard rake -f /usr/share/puppet-dashboard/Rakefile
    'node:list'
    (in /var/log)
    config.gem: Unpacked gem daemons-1.0.10 in vendor/gems has no
    specification file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem rack-1.1.2 in vendor/gems has no specification
    file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem rspec-1.3.2 in vendor/gems has no specification
    file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem rdoc-3.6.1 in vendor/gems has no specification
    file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem rspec-rails-1.3.4 in vendor/gems has no
    specification file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem thoughtbot-shoulda-2.10.2 in vendor/gems has no
    specification file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem mocha-0.9.7 in vendor/gems has no specification
    file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem will_paginate-2.3.15 in vendor/gems has no
    specification file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem json_pure-1.5.1 in vendor/gems has no
    specification file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem haml-3.1.2 in vendor/gems has no specification
    file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem sass-3.1.2 in vendor/gems has no specification
    file. Run 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem factory_girl-1.3.3 in vendor/gems has no
    specification file. Run 'rake gems:refresh_specs' to fix this.
    DEPRECATION WARNING: Rake tasks in vendor/plugins/delayed_job/tasks are
    deprecated. Use lib/tasks instead. (called from
    /usr/share/puppet-dashboard/vendor/rails/railties/lib/tasks/rails.rb:10)



    </snip>



    ...I fail to find any info on this online ... has anyone else seen this?

    Thanks,

    //Jacob.

    --
    You received this message because you are subscribed to the Google
    Groups "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/Q-XcVfScapMJ.
    To post to this group, send email to puppet...@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users...@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.


    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/n6pqYiO6CSYJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedNov 19, '12 at 9:12a
activeNov 21, '12 at 8:07a
posts7
users3
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase