FAQ
Hi,

I am just rolling out a new puppet deployment. Which version should i go
for, 2.7 or 3.1? I am looking to use the open source version.

Many thanks,
Oli

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/5FJ6YIrjhA4J.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Llowder at Nov 15, 2012 at 2:56 pm

    On Thursday, November 15, 2012 8:47:29 AM UTC-6, vioilly wrote:
    Hi,

    I am just rolling out a new puppet deployment. Which version should i go
    for, 2.7 or 3.1? I am looking to use the open source version.
    If you plan on using an ENC, specifically TheForeman, or a lot of modules
    from the Puppet Forge, you might want to start with 2.7

    That being said, Foreman is very close to having Puppet 3 support working,
    and more and more modules on the Forge are being made 3.0 compatible every
    day.

    Puppet 2.7 is currently on 2.7.19 with 2.7.20 in RCs, and Puppet 3 is at
    3.0.1, so it is still a little rough around the edges, but the fact that
    hiera is integrated and it has the databindings is one very nice feature of
    3.0.x. It's also considerably faster.

    There are advantages and disadvantages to both, and I am sure others will
    weigh in as well, but hope this helps.

    Many thanks,
    Oli
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/UuxZtnjHn30J.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Ohad Levy at Nov 16, 2012 at 7:34 am
    On Thu, Nov 15, 2012 at 4:56 PM, llowder wrote:
    On Thursday, November 15, 2012 8:47:29 AM UTC-6, vioilly wrote:

    Hi,

    I am just rolling out a new puppet deployment. Which version should i go
    for, 2.7 or 3.1? I am looking to use the open source version.
    If you plan on using an ENC, specifically TheForeman, or a lot of modules
    from the Puppet Forge, you might want to start with 2.7

    That being said, Foreman is very close to having Puppet 3 support working,
    and more and more modules on the Forge are being made 3.0 compatible every
    day.
    For the record, Puppet 3 support was added to foreman a couple of days ago.

    Ohad
    Puppet 2.7 is currently on 2.7.19 with 2.7.20 in RCs, and Puppet 3 is at
    3.0.1, so it is still a little rough around the edges, but the fact that
    hiera is integrated and it has the databindings is one very nice feature of
    3.0.x. It's also considerably faster.

    There are advantages and disadvantages to both, and I am sure others will
    weigh in as well, but hope this helps.

    Many thanks,
    Oli
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/UuxZtnjHn30J.

    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Thomas Bendler at Nov 16, 2012 at 8:18 am
    Hi Ohad,

    2012/11/16 Ohad Levy [...]
    For the record, Puppet 3 support was added to foreman a couple of days ago.
    [...]
    do you know when the puppet 3 support will be available in the test RPMs?
    I've updated to the current test RPMs yesterday but still had to patch some
    files in foreman and foreman-proxy to get it working with Puppet 3.

    Regards, Thomas
    --
    Linux ... enjoy the ride!

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Ohad Levy at Nov 17, 2012 at 5:20 am

    On Fri, Nov 16, 2012 at 10:10 AM, Thomas Bendler wrote:

    Hi Ohad,

    2012/11/16 Ohad Levy <ohadlevy@gmail.com>
    [...]
    For the record, Puppet 3 support was added to foreman a couple of days
    ago.
    [...]
    do you know when the puppet 3 support will be available in the test RPMs?
    I've updated to the current test RPMs yesterday but still had to patch some
    files in foreman and foreman-proxy to get it working with Puppet 3.
    You would need the nightly rpms, hopefully we'll get a RC soon.

    Ohad
    Regards, Thomas
    --
    Linux ... enjoy the ride!


    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • David Schmitt at Nov 19, 2012 at 10:21 am

    On Sat, 17 Nov 2012 07:20:18 +0200, Ohad Levy wrote:
    On Fri, Nov 16, 2012 at 10:10 AM, Thomas Bendler
    wrote:
    Hi Ohad,

    2012/11/16 Ohad Levy <ohadlevy@gmail.com>
    [...]
    For the record, Puppet 3 support was added to foreman a couple of days
    ago.
    [...]
    do you know when the puppet 3 support will be available in the test
    RPMs?
    I've updated to the current test RPMs yesterday but still had to patch
    some
    files in foreman and foreman-proxy to get it working with Puppet 3.
    You would need the nightly rpms, hopefully we'll get a RC soon.
    Err, the puppet 3 support has not yet landed in the nightly RPMs. I just
    tried.

    http://theforeman.org/projects/foreman/repository/revisions/e81bf0573125fa569e35f991df451cb9e4e8a948/diff
    is missing in
    bash-4.1$ rpm -qa | grep foreman
    foreman-1.0.1-4.20121022.el6.noarch
    foreman-postgresql-1.0.1-4.20121022.el6.noarch
    foreman-proxy-1.0.0-3.20121022.el6.noarch
    [root@viepclvx-e15 foreman]# grep PUPPETVERSION
    /usr/share/foreman/lib/foreman/default_settings/loader.rb
    [root@viepclvx-e15 foreman]#

    Best Regards, David

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • David Schmitt at Nov 19, 2012 at 11:16 am

    On Mon, 19 Nov 2012 11:21:34 +0100, David Schmitt wrote:
    bash-4.1$ rpm -qa | grep foreman
    foreman-1.0.1-4.20121022.el6.noarch
    foreman-postgresql-1.0.1-4.20121022.el6.noarch
    foreman-proxy-1.0.0-3.20121022.el6.noarch

    That I didn't notice, is that those are from 2012-10-22, which is not
    quite nightly. Seems like the repo at
    http://yum.theforeman.org/nightly/el6/x86_64/?C=M;O=D has stopped updating?


    Best Regards, David

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Ohad Levy at Nov 22, 2012 at 9:53 am

    On Mon, Nov 19, 2012 at 1:16 PM, David Schmitt wrote:
    On Mon, 19 Nov 2012 11:21:34 +0100, David Schmitt wrote:
    bash-4.1$ rpm -qa | grep foreman
    foreman-1.0.1-4.20121022.el6.noarch
    foreman-postgresql-1.0.1-4.20121022.el6.noarch
    foreman-proxy-1.0.0-3.20121022.el6.noarch

    That I didn't notice, is that those are from 2012-10-22, which is not
    quite nightly. Seems like the repo at
    http://yum.theforeman.org/nightly/el6/x86_64/?C=M;O=D has stopped
    updating?
    Sorry about that, jmontleon fixed that.


    >
    Best Regards, David

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • David Schmitt at Nov 22, 2012 at 9:54 am

    On 22.11.2012 10:53, Ohad Levy wrote:


    On Mon, Nov 19, 2012 <tel:2012> at 1:16 PM, David Schmitt wrote:

    On Mon, 19 Nov 2012 <tel:2012> 11:21:34 +0100, David Schmitt
    wrote:
    bash-4.1$ rpm -qa | grep foreman
    foreman-1.0.1-4.20121022.el6.noarch
    foreman-postgresql-1.0.1-4.20121022.el6.noarch
    foreman-proxy-1.0.0-3.20121022.el6.noarch

    That I didn't notice, is that those are from 2012-10-22, which is not
    quite nightly. Seems like the repo at
    http://yum.theforeman.org/nightly/el6/x86_64/?C=M;O=D has stopped
    updating?


    Sorry about that, jmontleon fixed that.
    no worries, looking forward to checking out the new stuff!


    Best Regards, David

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Vioilly at Nov 16, 2012 at 9:13 am
    Thanks for the info. I'm going to give 3.0.1 a go. That fact about the
    performance improvement is the killer. Worth a few rough edges.

    Oli
    --
    On Thursday, November 15, 2012 2:56:41 PM UTC, llowder wrote:


    On Thursday, November 15, 2012 8:47:29 AM UTC-6, vioilly wrote:

    Hi,

    I am just rolling out a new puppet deployment. Which version should i go
    for, 2.7 or 3.1? I am looking to use the open source version.
    If you plan on using an ENC, specifically TheForeman, or a lot of modules
    from the Puppet Forge, you might want to start with 2.7

    That being said, Foreman is very close to having Puppet 3 support working,
    and more and more modules on the Forge are being made 3.0 compatible every
    day.

    Puppet 2.7 is currently on 2.7.19 with 2.7.20 in RCs, and Puppet 3 is at
    3.0.1, so it is still a little rough around the edges, but the fact that
    hiera is integrated and it has the databindings is one very nice feature of
    3.0.x. It's also considerably faster.

    There are advantages and disadvantages to both, and I am sure others will
    weigh in as well, but hope this helps.

    Many thanks,
    Oli
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/HOa8N02HZf0J.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedNov 15, '12 at 2:47p
activeNov 22, '12 at 9:54a
posts10
users5
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase