FAQ
Hi,

I've installed a jboss module for Puppet cloned from this repo:
https://github.com/example42/puppet-jboss, but when I run puppet agent -t
--trace I'm getting this error "Error 400 on SERVER: custom functions must
be called with a single array that contains the arguments"

Here is the full trace http://pastebin.com/YBJ289Tw

Amazon Linux, Ruby 1.8.7, Puppet 3.0.1

Any idea ?

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/PWnsds853QYJ.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Jcbollinger at Nov 15, 2012 at 3:18 pm

    On Thursday, November 15, 2012 5:10:51 AM UTC-6, Med75 wrote:
    Hi,

    I've installed a jboss module for Puppet cloned from this repo:
    https://github.com/example42/puppet-jboss, but when I run puppet agent -t
    --trace I'm getting this error "Error 400 on SERVER: custom functions must
    be called with a single array that contains the arguments"

    Here is the full trace http://pastebin.com/YBJ289Tw

    Amazon Linux, Ruby 1.8.7, Puppet 3.0.1

    The module is broken, at least for the latest Puppet, or possibly
    example42's Puppi module (on which the jboss module depends) is broken. It
    appears to be tripping over a recent addition of enforcement of a
    longstanding rule for the interface to custom Puppet functions. Function
    calls in Puppet manifests cannot themselves be erroneous in this way, but a
    function call appearing in a template or perhaps in another function's
    implementation could be. You should raise the issue with the module author.


    John

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/dEfsh7iVLs8J.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Mohamed Hadrouj at Nov 15, 2012 at 3:29 pm
    Hi,
    I updated to the last version hosted on Github of "Puppi" module which
    puppet-jboss relies on, then restarted the master and it worked fine.
    Puppi version (v2.0.0) hosted on PuppetForge is not up to date.

    2012/11/15 jcbollinger <john.bollinger@stjude.org>
    On Thursday, November 15, 2012 5:10:51 AM UTC-6, Med75 wrote:

    Hi,

    I've installed a jboss module for Puppet cloned from this repo:
    https://github.com/**example42/puppet-jboss<https://github.com/example42/puppet-jboss>
    , but **when I run puppet agent -t --trace I'm getting this error "Error
    400 on SERVER: custom functions must be called with a single array that
    contains the arguments"

    Here is the full trace http://pastebin.com/**YBJ289Tw<http://pastebin.com/YBJ289Tw>

    Amazon Linux, Ruby 1.8.7, Puppet 3.0.1

    The module is broken, at least for the latest Puppet, or possibly
    example42's Puppi module (on which the jboss module depends) is broken. It
    appears to be tripping over a recent addition of enforcement of a
    longstanding rule for the interface to custom Puppet functions. Function
    calls in Puppet manifests cannot themselves be erroneous in this way, but a
    function call appearing in a template or perhaps in another function's
    implementation could be. You should raise the issue with the module author.


    John

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/dEfsh7iVLs8J.

    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedNov 15, '12 at 11:10a
activeNov 15, '12 at 3:29p
posts3
users2
websitepuppetlabs.com

2 users in discussion

Mohamed Hadrouj: 2 posts Jcbollinger: 1 post

People

Translate

site design / logo © 2022 Grokbase