FAQ
Hello Everyone

I was getting the error which running

$ sudo puppet agent -t

err: Could not request certificate: Retrieved certificate does not match
private key; please remove certificate from server and regenerate it with
the current key

To solve this, I first removed the certs from the puppet server for this
host using

$ sudo puppetca --clean <hostname>

And then removed the content inside directory /var/lib/puppet/ssl on the
client.

Still it is giving me the same error. Can somebody help me solving this.


--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/MAW7OuHE7asJ.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Nikola Petrov at Nov 15, 2012 at 7:49 am

    On Wed, Nov 14, 2012 at 11:28:54PM -0800, Pradeep Chhetri wrote:
    Hello Everyone

    I was getting the error which running

    $ sudo puppet agent -t

    err: Could not request certificate: Retrieved certificate does not match
    private key; please remove certificate from server and regenerate it with
    the current key

    To solve this, I first removed the certs from the puppet server for this
    host using

    $ sudo puppetca --clean <hostname>

    And then removed the content inside directory /var/lib/puppet/ssl on the
    client.

    Still it is giving me the same error. Can somebody help me solving this.
    Can you please try to cleanup the ssl certificate on the client too. You
    can just move the ssl directory(in case you want to revert it). It is in
    the same location /var/lib/puppet/ssl

    --
    Nikola

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Pradeep Chhetri at Nov 15, 2012 at 8:40 am
    I removed from client only before. Still getting the same error.

    On Thu, Nov 15, 2012 at 1:19 PM, Nikola Petrov wrote:
    On Wed, Nov 14, 2012 at 11:28:54PM -0800, Pradeep Chhetri wrote:
    Hello Everyone

    I was getting the error which running

    $ sudo puppet agent -t

    err: Could not request certificate: Retrieved certificate does not match
    private key; please remove certificate from server and regenerate it with
    the current key

    To solve this, I first removed the certs from the puppet server for this
    host using

    $ sudo puppetca --clean <hostname>

    And then removed the content inside directory /var/lib/puppet/ssl on the
    client.

    Still it is giving me the same error. Can somebody help me solving this.
    Can you please try to cleanup the ssl certificate on the client too. You
    can just move the ssl directory(in case you want to revert it). It is in
    the same location /var/lib/puppet/ssl

    --
    Nikola

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.

    --
    Pradeep Chhetri

    In the world of Linux, who needs Windows and Gates...

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Jeff McCune at Nov 15, 2012 at 8:59 pm
    What version of Puppet? The puppetca command is pretty old.

    -Jeff

    On Thu, Nov 15, 2012 at 3:17 AM, Pradeep Chhetri
    wrote:
    I removed from client only before. Still getting the same error.

    On Thu, Nov 15, 2012 at 1:19 PM, Nikola Petrov wrote:
    On Wed, Nov 14, 2012 at 11:28:54PM -0800, Pradeep Chhetri wrote:
    Hello Everyone

    I was getting the error which running

    $ sudo puppet agent -t

    err: Could not request certificate: Retrieved certificate does not match
    private key; please remove certificate from server and regenerate it
    with
    the current key

    To solve this, I first removed the certs from the puppet server for this
    host using

    $ sudo puppetca --clean <hostname>

    And then removed the content inside directory /var/lib/puppet/ssl on the
    client.

    Still it is giving me the same error. Can somebody help me solving this.
    Can you please try to cleanup the ssl certificate on the client too. You
    can just move the ssl directory(in case you want to revert it). It is in
    the same location /var/lib/puppet/ssl

    --
    Nikola

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.


    --
    Pradeep Chhetri

    In the world of Linux, who needs Windows and Gates...

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Pradeep Chhetri at Nov 16, 2012 at 2:17 pm
    I am using puppet-2.6.6-3.2 version.

    $ rpm -qa | grep puppet
    puppet-2.6.6-3.2.amzn1.x86_64
    puppet-server-2.6.6-3.2.amzn1.x86_64


    On Fri, Nov 16, 2012 at 2:20 AM, Jeff McCune wrote:

    What version of Puppet? The puppetca command is pretty old.

    -Jeff

    On Thu, Nov 15, 2012 at 3:17 AM, Pradeep Chhetri
    wrote:
    I removed from client only before. Still getting the same error.

    On Thu, Nov 15, 2012 at 1:19 PM, Nikola Petrov wrote:
    On Wed, Nov 14, 2012 at 11:28:54PM -0800, Pradeep Chhetri wrote:
    Hello Everyone

    I was getting the error which running

    $ sudo puppet agent -t

    err: Could not request certificate: Retrieved certificate does not
    match
    private key; please remove certificate from server and regenerate it
    with
    the current key

    To solve this, I first removed the certs from the puppet server for
    this
    host using

    $ sudo puppetca --clean <hostname>

    And then removed the content inside directory /var/lib/puppet/ssl on
    the
    client.

    Still it is giving me the same error. Can somebody help me solving
    this.
    Can you please try to cleanup the ssl certificate on the client too. You
    can just move the ssl directory(in case you want to revert it). It is in
    the same location /var/lib/puppet/ssl

    --
    Nikola

    --
    You received this message because you are subscribed to the Google
    Groups
    "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.


    --
    Pradeep Chhetri

    In the world of Linux, who needs Windows and Gates...

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.

    --
    Pradeep Chhetri

    In the world of Linux, who needs Windows and Gates...

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Jeff McCune at Nov 16, 2012 at 4:12 pm

    On Fri, Nov 16, 2012 at 9:17 AM, Pradeep Chhetri wrote:
    I am using puppet-2.6.6-3.2 version.

    $ rpm -qa | grep puppet
    puppet-2.6.6-3.2.amzn1.x86_64
    puppet-server-2.6.6-3.2.amzn1.x86_64
    Do you still have the problem with 2.7.20 or 3.0.1 ? Puppet 2.6 is
    quite old at this point.

    -Jeff

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedNov 15, '12 at 7:32a
activeNov 16, '12 at 4:12p
posts6
users3
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase