FAQ
I'm working on setting things up so that I can use Cobbler to kickstart a
basic system and then use Puppet to roll out the majority of packages based
on the role a particular system will be playing for us. I've got a
kickstarter file running (a thinly modified version of the Cobbler
sample.ks) but after it runs and installs around 444 packages including
puppet, I get this after booting into the system the first time (and after
doing the certificate exchange bit):

# puppet agent -t
Info: Retrieving plugin
Timed out seeking value for ipaddress
Timed out seeking value for ipaddress
Error: Could not autoload puppet/provider/package/rpm: No child processes
Error: Could not autoload puppet/type/package: Could not autlooad
puppet/provider/package/rpm: No child processes
Error: Could not retrieve catalog from remote server: Could not intern from
pson: Could not autoload puppet/type/package: Could not autload
puppet/provider/package/rpm: No child processes
Warning: Not using cache on failed catalog
Error: Could not retrieve catalog: skipping run
#

I've seen notes about ip addresses before, but I can ping, scp, and ssh out
of the box without issue (and can reach the puppet server, since we
performed the certificate request-sign-download thing).

Any ideas?

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/7j53xwvS1LsJ.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Bret Wortman at Nov 13, 2012 at 7:46 pm

    On Tuesday, November 13, 2012 2:32:24 PM UTC-5, Bret Wortman wrote:
    I'm working on setting things up so that I can use Cobbler to kickstart a
    basic system and then use Puppet to roll out the majority of packages based
    on the role a particular system will be playing for us. I've got a
    kickstarter file running (a thinly modified version of the Cobbler
    sample.ks) but after it runs and installs around 444 packages including
    puppet, I get this after booting into the system the first time (and after
    doing the certificate exchange bit):

    # puppet agent -t
    Info: Retrieving plugin
    Timed out seeking value for ipaddress
    Timed out seeking value for ipaddress
    Error: Could not autoload puppet/provider/package/rpm: No child processes
    Error: Could not autoload puppet/type/package: Could not autlooad
    puppet/provider/package/rpm: No child processes
    Error: Could not retrieve catalog from remote server: Could not intern
    from pson: Could not autoload puppet/type/package: Could not autload
    puppet/provider/package/rpm: No child processes
    Warning: Not using cache on failed catalog
    Error: Could not retrieve catalog: skipping run
    #

    I've seen notes about ip addresses before, but I can ping, scp, and ssh
    out of the box without issue (and can reach the puppet server, since we
    performed the certificate request-sign-download thing).

    Any ideas?

    D'Oh. Solved this one myself via
    #chown <#> -R puppet:puppet /etc/puppet

    Not sure why the RPM package missed that, but it did. I'm adding a
    double-check to my kickstart for this.

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/HiyXirca4J4J.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Jcbollinger at Nov 14, 2012 at 2:10 pm

    On Tuesday, November 13, 2012 1:46:13 PM UTC-6, Bret Wortman wrote:

    On Tuesday, November 13, 2012 2:32:24 PM UTC-5, Bret Wortman wrote:

    I'm working on setting things up so that I can use Cobbler to kickstart a
    basic system and then use Puppet to roll out the majority of packages based
    on the role a particular system will be playing for us. I've got a
    kickstarter file running (a thinly modified version of the Cobbler
    sample.ks) but after it runs and installs around 444 packages including
    puppet, I get this after booting into the system the first time (and after
    doing the certificate exchange bit):

    # puppet agent -t
    Info: Retrieving plugin
    Timed out seeking value for ipaddress
    Timed out seeking value for ipaddress
    Error: Could not autoload puppet/provider/package/rpm: No child processes
    Error: Could not autoload puppet/type/package: Could not autlooad
    puppet/provider/package/rpm: No child processes
    Error: Could not retrieve catalog from remote server: Could not intern
    from pson: Could not autoload puppet/type/package: Could not autload
    puppet/provider/package/rpm: No child processes
    Warning: Not using cache on failed catalog
    Error: Could not retrieve catalog: skipping run
    #

    I've seen notes about ip addresses before, but I can ping, scp, and ssh
    out of the box without issue (and can reach the puppet server, since we
    performed the certificate request-sign-download thing).

    Any ideas?

    D'Oh. Solved this one myself via
    #chown <#38664afa-359d-43cc-b948-5c828265aba9@googlegroups.com_> -R
    puppet:puppet /etc/puppet

    Not sure why the RPM package missed that, but it did. I'm adding a
    double-check to my kickstart for this.

    The "puppet" user should not need to own that directory, and it's probably
    not a good idea for it to do. It should, however, be able to *read* that
    directory. If you have some policy in place that could have prevented it
    from reading it or any of its content, then that might explain the problem.


    John

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/58EtGNS3KfAJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Bret Wortman at Nov 15, 2012 at 12:13 pm
    It's continuing even after the ownership "fix", though it's intermittent.
    Some runs will consist of long runs of messages in the client like these:

    Error: Could not prefetch package provider 'yum': No child processes
    Error: Could not set 'present' on ensure: No child processes at
    105:/etc/puppet/moduels/workstation/manifests/init.pp
    Error: /Stage[main]/Workstation/Secure[sendmail-off]:" Could not evaluate:
    No child processes

    over and over (with different classes/packages each time.
    On Wednesday, November 14, 2012 9:10:21 AM UTC-5, jcbollinger wrote:


    On Tuesday, November 13, 2012 1:46:13 PM UTC-6, Bret Wortman wrote:


    On Tuesday, November 13, 2012 2:32:24 PM UTC-5, Bret Wortman wrote:

    I'm working on setting things up so that I can use Cobbler to kickstart
    a basic system and then use Puppet to roll out the majority of packages
    based on the role a particular system will be playing for us. I've got a
    kickstarter file running (a thinly modified version of the Cobbler
    sample.ks) but after it runs and installs around 444 packages including
    puppet, I get this after booting into the system the first time (and after
    doing the certificate exchange bit):

    # puppet agent -t
    Info: Retrieving plugin
    Timed out seeking value for ipaddress
    Timed out seeking value for ipaddress
    Error: Could not autoload puppet/provider/package/rpm: No child processes
    Error: Could not autoload puppet/type/package: Could not autlooad
    puppet/provider/package/rpm: No child processes
    Error: Could not retrieve catalog from remote server: Could not intern
    from pson: Could not autoload puppet/type/package: Could not autload
    puppet/provider/package/rpm: No child processes
    Warning: Not using cache on failed catalog
    Error: Could not retrieve catalog: skipping run
    #

    I've seen notes about ip addresses before, but I can ping, scp, and ssh
    out of the box without issue (and can reach the puppet server, since we
    performed the certificate request-sign-download thing).

    Any ideas?

    D'Oh. Solved this one myself via
    #chown<#c319397b-d8eb-46de-b5e7-7ed754ac7872@googlegroups.com_38664afa-359d-43cc-b948-5c828265aba9@googlegroups.com_>-R puppet:puppet /etc/puppet

    Not sure why the RPM package missed that, but it did. I'm adding a
    double-check to my kickstart for this.

    The "puppet" user should not need to own that directory, and it's probably
    not a good idea for it to do. It should, however, be able to *read* that
    directory. If you have some policy in place that could have prevented it
    from reading it or any of its content, then that might explain the problem.


    John
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/lrwqsbuaECEJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Edson Manners at Nov 15, 2012 at 12:47 pm
    Bret,
    I'm doing the same thing without any issues. Give us csome basic
    info. What OS, puppet version, RPMs or tarballs,
    which yum repo, SELNIUX enforcing status and so forth.
    On Thu, Nov 15, 2012 at 7:13 AM, Bret Wortman wrote:

    It's continuing even after the ownership "fix", though it's intermittent.
    Some runs will consist of long runs of messages in the client like these:

    Error: Could not prefetch package provider 'yum': No child processes
    Error: Could not set 'present' on ensure: No child processes at
    105:/etc/puppet/moduels/workstation/manifests/init.pp
    Error: /Stage[main]/Workstation/Secure[sendmail-off]:" Could not evaluate:
    No child processes

    over and over (with different classes/packages each time.

    On Wednesday, November 14, 2012 9:10:21 AM UTC-5, jcbollinger wrote:


    On Tuesday, November 13, 2012 1:46:13 PM UTC-6, Bret Wortman wrote:


    On Tuesday, November 13, 2012 2:32:24 PM UTC-5, Bret Wortman wrote:

    I'm working on setting things up so that I can use Cobbler to kickstart
    a basic system and then use Puppet to roll out the majority of packages
    based on the role a particular system will be playing for us. I've got a
    kickstarter file running (a thinly modified version of the Cobbler
    sample.ks) but after it runs and installs around 444 packages including
    puppet, I get this after booting into the system the first time (and after
    doing the certificate exchange bit):

    # puppet agent -t
    Info: Retrieving plugin
    Timed out seeking value for ipaddress
    Timed out seeking value for ipaddress
    Error: Could not autoload puppet/provider/package/rpm: No child
    processes
    Error: Could not autoload puppet/type/package: Could not autlooad
    puppet/provider/package/rpm: No child processes
    Error: Could not retrieve catalog from remote server: Could not intern
    from pson: Could not autoload puppet/type/package: Could not autload
    puppet/provider/package/rpm: No child processes
    Warning: Not using cache on failed catalog
    Error: Could not retrieve catalog: skipping run
    #

    I've seen notes about ip addresses before, but I can ping, scp, and ssh
    out of the box without issue (and can reach the puppet server, since we
    performed the certificate request-sign-download thing).

    Any ideas?

    D'Oh. Solved this one myself via
    #chown<#13b03fd1ef5eda4b_c319397b-d8eb-46de-b5e7-7ed754ac7872@googlegroups.com_38664afa-359d-43cc-b948-5c828265aba9@googlegroups.com_>-R puppet:puppet /etc/puppet

    Not sure why the RPM package missed that, but it did. I'm adding a
    double-check to my kickstart for this.

    The "puppet" user should not need to own that directory, and it's
    probably not a good idea for it to do. It should, however, be able to *
    read* that directory. If you have some policy in place that could have
    prevented it from reading it or any of its content, then that might explain
    the problem.


    John

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/lrwqsbuaECEJ.

    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Bret Wortman at Nov 15, 2012 at 12:56 pm
    F17, Puppet 3.0.1 installed from RPM from a copy of the puppetlabs repos.
    SELinux disabled, iptables disabled.

    I just added this line to /etc/security/limits.conf:

    puppet hard nproc -1

    And it seems to have solved the above issue.
    On Thursday, November 15, 2012 7:47:53 AM UTC-5, Edson Manners wrote:

    Bret,
    I'm doing the same thing without any issues. Give us csome basic
    info. What OS, puppet version, RPMs or tarballs,
    which yum repo, SELNIUX enforcing status and so forth.

    On Thu, Nov 15, 2012 at 7:13 AM, Bret Wortman <br...@thewortmans.org<javascript:>
    wrote:
    It's continuing even after the ownership "fix", though it's intermittent.
    Some runs will consist of long runs of messages in the client like these:

    Error: Could not prefetch package provider 'yum': No child processes
    Error: Could not set 'present' on ensure: No child processes at
    105:/etc/puppet/moduels/workstation/manifests/init.pp
    Error: /Stage[main]/Workstation/Secure[sendmail-off]:" Could not
    evaluate: No child processes

    over and over (with different classes/packages each time.

    On Wednesday, November 14, 2012 9:10:21 AM UTC-5, jcbollinger wrote:


    On Tuesday, November 13, 2012 1:46:13 PM UTC-6, Bret Wortman wrote:


    On Tuesday, November 13, 2012 2:32:24 PM UTC-5, Bret Wortman wrote:

    I'm working on setting things up so that I can use Cobbler to
    kickstart a basic system and then use Puppet to roll out the majority of
    packages based on the role a particular system will be playing for us. I've
    got a kickstarter file running (a thinly modified version of the Cobbler
    sample.ks) but after it runs and installs around 444 packages including
    puppet, I get this after booting into the system the first time (and after
    doing the certificate exchange bit):

    # puppet agent -t
    Info: Retrieving plugin
    Timed out seeking value for ipaddress
    Timed out seeking value for ipaddress
    Error: Could not autoload puppet/provider/package/rpm: No child
    processes
    Error: Could not autoload puppet/type/package: Could not autlooad
    puppet/provider/package/rpm: No child processes
    Error: Could not retrieve catalog from remote server: Could not intern
    from pson: Could not autoload puppet/type/package: Could not autload
    puppet/provider/package/rpm: No child processes
    Warning: Not using cache on failed catalog
    Error: Could not retrieve catalog: skipping run
    #

    I've seen notes about ip addresses before, but I can ping, scp, and
    ssh out of the box without issue (and can reach the puppet server, since we
    performed the certificate request-sign-download thing).

    Any ideas?

    D'Oh. Solved this one myself via
    #chown<#CAJZa+++hZGRNT=DSikWxNF0m2RcBZ_FmsGG1W8OwJ7mZmOQ9-g@mail.gmail.com_13b03fd1ef5eda4b_c319397b-d8eb-46de-b5e7-7ed754ac7872@googlegroups.com_38664afa-359d-43cc-b948-5c828265aba9@googlegroups.com_>-R puppet:puppet /etc/puppet

    Not sure why the RPM package missed that, but it did. I'm adding a
    double-check to my kickstart for this.

    The "puppet" user should not need to own that directory, and it's
    probably not a good idea for it to do. It should, however, be able to *
    read* that directory. If you have some policy in place that could have
    prevented it from reading it or any of its content, then that might explain
    the problem.


    John

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/lrwqsbuaECEJ.

    To post to this group, send email to puppet...@googlegroups.com<javascript:>
    .
    To unsubscribe from this group, send email to
    puppet-users...@googlegroups.com <javascript:>.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/A6wwI55t_-kJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Bret Wortman at Nov 15, 2012 at 6:38 pm

    On Thursday, November 15, 2012 7:56:43 AM UTC-5, Bret Wortman wrote:
    F17, Puppet 3.0.1 installed from RPM from a copy of the puppetlabs repos.
    SELinux disabled, iptables disabled.

    I just added this line to /etc/security/limits.conf:

    puppet hard nproc -1

    And it seems to have solved the above issue.
    On Thursday, November 15, 2012 7:47:53 AM UTC-5, Edson Manners wrote:

    Bret,
    I'm doing the same thing without any issues. Give us csome basic
    info. What OS, puppet version, RPMs or tarballs,
    which yum repo, SELNIUX enforcing status and so forth.
    *Sigh*. Something will work for a short while, then I'm back staring at
    errors again.

    # puppet agent -t
    Info: Retrieving plugin
    Timed out seeking value for ipaddress
    Timed out seeking value for ipaddress
    Error: Could not autoload puppet/provider/package/rpm: No child processes
    Error: Could not autoload puppet/provider/package/zypper: Could not
    autolaod puppet/provider/package/rpm: No child processes
    Error: Could not autoload puppet/type/package: Error: Could not autoload
    puppet/provider/package/zypper: Could not autolaod
    puppet/provider/package/rpm: No child processes
    Warning: Not using cache on failed catalog
    Error: Could not retrieve catalog: skipping run
    # cat /etc/security/limits.conf
    puppet hard nproc -1
    #

    Puppet 3.0.1 installed from RPM from a copy of the puppetlabs repos.
    SELinux disabled, iptables disabled.

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/WjYq7sgJkeYJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Gmoney at Nov 15, 2012 at 8:20 pm
    On the cobbler side do you have the folliwng in your /etc/cobbler/
    settings file?

    # if enabled, this setting ensures that puppet is installed during
    # machine provision, a client certificate is generated and a
    # certificate signing request is made with the puppet master server
    puppet_auto_setup: 1

    # when puppet starts on a system after installation it needs to have
    # its certificate signed by the puppet master server. Enabling the
    # following feature will ensure that the puppet server signs the
    # certificate after installation if the puppet master server is
    # running on the same machine as cobbler. This requires
    # puppet_auto_setup above to be enabled
    sign_puppet_certs_automatically: 1
    On Nov 15, 1:38 pm, Bret Wortman wrote:
    On Thursday, November 15, 2012 7:56:43 AM UTC-5, Bret Wortman wrote:

    F17, Puppet 3.0.1 installed from RPM from a copy of the puppetlabs repos.
    SELinux disabled, iptables disabled.
    I just added this line to /etc/security/limits.conf:
    puppet   hard   nproc   -1
    And it seems to have solved the above issue.
    On Thursday, November 15, 2012 7:47:53 AM UTC-5, Edson Manners wrote:

    Bret,
    I'm doing the same thing without any issues. Give us csome basic
    info. What OS, puppet version, RPMs or tarballs,
    which yum repo, SELNIUX enforcing status and so forth.
    *Sigh*. Something will work for a short while, then I'm back staring at
    errors again.

    # puppet agent -t
    Info: Retrieving plugin
    Timed out seeking value for ipaddress
    Timed out seeking value for ipaddress
    Error: Could not autoload puppet/provider/package/rpm: No child processes
    Error: Could not autoload puppet/provider/package/zypper: Could not
    autolaod puppet/provider/package/rpm: No child processes
    Error: Could not autoload puppet/type/package: Error: Could not autoload
    puppet/provider/package/zypper: Could not autolaod
    puppet/provider/package/rpm: No child processes
    Warning: Not using cache on failed catalog
    Error: Could not retrieve catalog: skipping run
    # cat /etc/security/limits.conf
    puppet     hard    nproc    -1
    #

    Puppet 3.0.1 installed from RPM from a copy of the puppetlabs repos.
    SELinux disabled, iptables disabled.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Bret Wortman at Nov 15, 2012 at 8:21 pm
    I do now (I was using ksmeta to set puppet_auto_setup but this is so much
    easier & cleaner!); I'll reattempt a build and see what happens.

    *
    *
    *

    Bret Wortman***
    http://bretwortman.com/
    http://twitter.com/BretWortman



    On Thu, Nov 15, 2012 at 3:14 PM, Gmoney wrote:

    On the cobbler side do you have the folliwng in your /etc/cobbler/
    settings file?

    # if enabled, this setting ensures that puppet is installed during
    # machine provision, a client certificate is generated and a
    # certificate signing request is made with the puppet master server
    puppet_auto_setup: 1

    # when puppet starts on a system after installation it needs to have
    # its certificate signed by the puppet master server. Enabling the
    # following feature will ensure that the puppet server signs the
    # certificate after installation if the puppet master server is
    # running on the same machine as cobbler. This requires
    # puppet_auto_setup above to be enabled
    sign_puppet_certs_automatically: 1
    On Nov 15, 1:38 pm, Bret Wortman wrote:
    On Thursday, November 15, 2012 7:56:43 AM UTC-5, Bret Wortman wrote:

    F17, Puppet 3.0.1 installed from RPM from a copy of the puppetlabs
    repos.
    SELinux disabled, iptables disabled.
    I just added this line to /etc/security/limits.conf:
    puppet hard nproc -1
    And it seems to have solved the above issue.
    On Thursday, November 15, 2012 7:47:53 AM UTC-5, Edson Manners wrote:

    Bret,
    I'm doing the same thing without any issues. Give us csome basic
    info. What OS, puppet version, RPMs or tarballs,
    which yum repo, SELNIUX enforcing status and so forth.
    *Sigh*. Something will work for a short while, then I'm back staring at
    errors again.

    # puppet agent -t
    Info: Retrieving plugin
    Timed out seeking value for ipaddress
    Timed out seeking value for ipaddress
    Error: Could not autoload puppet/provider/package/rpm: No child processes
    Error: Could not autoload puppet/provider/package/zypper: Could not
    autolaod puppet/provider/package/rpm: No child processes
    Error: Could not autoload puppet/type/package: Error: Could not autoload
    puppet/provider/package/zypper: Could not autolaod
    puppet/provider/package/rpm: No child processes
    Warning: Not using cache on failed catalog
    Error: Could not retrieve catalog: skipping run
    # cat /etc/security/limits.conf
    puppet hard nproc -1
    #

    Puppet 3.0.1 installed from RPM from a copy of the puppetlabs repos.
    SELinux disabled, iptables disabled.
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Bret Wortman at Nov 15, 2012 at 9:05 pm
    Nope. Same outcome. Numerous "No child processes" errors.
    On Thursday, November 15, 2012 3:22:09 PM UTC-5, Bret Wortman wrote:

    I do now (I was using ksmeta to set puppet_auto_setup but this is so much
    easier & cleaner!); I'll reattempt a build and see what happens.

    **
    *

    Bret Wortman***
    http://bretwortman.com/
    http://twitter.com/BretWortman



    On Thu, Nov 15, 2012 at 3:14 PM, Gmoney wrote:

    On the cobbler side do you have the folliwng in your /etc/cobbler/
    settings file?

    # if enabled, this setting ensures that puppet is installed during
    # machine provision, a client certificate is generated and a
    # certificate signing request is made with the puppet master server
    puppet_auto_setup: 1

    # when puppet starts on a system after installation it needs to have
    # its certificate signed by the puppet master server. Enabling the
    # following feature will ensure that the puppet server signs the
    # certificate after installation if the puppet master server is
    # running on the same machine as cobbler. This requires
    # puppet_auto_setup above to be enabled
    sign_puppet_certs_automatically: 1
    On Nov 15, 1:38 pm, Bret Wortman wrote:
    On Thursday, November 15, 2012 7:56:43 AM UTC-5, Bret Wortman wrote:

    F17, Puppet 3.0.1 installed from RPM from a copy of the puppetlabs
    repos.
    SELinux disabled, iptables disabled.
    I just added this line to /etc/security/limits.conf:
    puppet hard nproc -1
    And it seems to have solved the above issue.
    On Thursday, November 15, 2012 7:47:53 AM UTC-5, Edson Manners wrote:

    Bret,
    I'm doing the same thing without any issues. Give us csome
    basic
    info. What OS, puppet version, RPMs or tarballs,
    which yum repo, SELNIUX enforcing status and so forth.
    *Sigh*. Something will work for a short while, then I'm back staring at
    errors again.

    # puppet agent -t
    Info: Retrieving plugin
    Timed out seeking value for ipaddress
    Timed out seeking value for ipaddress
    Error: Could not autoload puppet/provider/package/rpm: No child processes
    Error: Could not autoload puppet/provider/package/zypper: Could not
    autolaod puppet/provider/package/rpm: No child processes
    Error: Could not autoload puppet/type/package: Error: Could not autoload
    puppet/provider/package/zypper: Could not autolaod
    puppet/provider/package/rpm: No child processes
    Warning: Not using cache on failed catalog
    Error: Could not retrieve catalog: skipping run
    # cat /etc/security/limits.conf
    puppet hard nproc -1
    #

    Puppet 3.0.1 installed from RPM from a copy of the puppetlabs repos.
    SELinux disabled, iptables disabled.
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/89UY9aMRxAAJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Jcbollinger at Nov 16, 2012 at 2:47 pm

    On Thursday, November 15, 2012 3:04:57 PM UTC-6, Bret Wortman wrote:
    Nope. Same outcome. Numerous "No child processes" errors.
    I'm not up to performing a code dive at the moment to find out where those
    messages may be emitted, but that might be useful information to have.

    It might also be illuminating to strace an agent run to get a low-level
    view of what's failing.

    I'm inclined to think that this is a provisioning problem, not inherently a
    Puppet problem, but there's not enough information to be sure.


    John

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/Cda5Bkajl4kJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Bret Wortman at Nov 16, 2012 at 3:13 pm
    I'm absolutely ready for this to be something I've not done properly during
    the kickstart process. I'm just getting started with these tools, so that's
    definitely a strong probability. I'll do this again shortly with strace and
    see what it reveals.

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Bret Wortman at Nov 16, 2012 at 5:44 pm

    On Friday, November 16, 2012 9:47:28 AM UTC-5, jcbollinger wrote:

    On Thursday, November 15, 2012 3:04:57 PM UTC-6, Bret Wortman wrote:

    Nope. Same outcome. Numerous "No child processes" errors.
    I'm not up to performing a code dive at the moment to find out where those
    messages may be emitted, but that might be useful information to have.

    It might also be illuminating to strace an agent run to get a low-level
    view of what's failing.

    I'm inclined to think that this is a provisioning problem, not inherently
    a Puppet problem, but there's not enough information to be sure.


    John

    I ran this with strace, and it produced 840K of output. It's on another
    network and I can't transfer the file to here for various reasons. Is there
    something I can look for and transcribe that might be illustrative?

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/cbIdN9N983kJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Jcbollinger at Nov 16, 2012 at 6:45 pm

    On Friday, November 16, 2012 11:44:38 AM UTC-6, Bret Wortman wrote:
    On Friday, November 16, 2012 9:47:28 AM UTC-5, jcbollinger wrote:


    On Thursday, November 15, 2012 3:04:57 PM UTC-6, Bret Wortman wrote:

    Nope. Same outcome. Numerous "No child processes" errors.
    I'm not up to performing a code dive at the moment to find out where
    those messages may be emitted, but that might be useful information to have.

    It might also be illuminating to strace an agent run to get a low-level
    view of what's failing.

    I'm inclined to think that this is a provisioning problem, not inherently
    a Puppet problem, but there's not enough information to be sure.


    John

    I ran this with strace, and it produced 840K of output. It's on another
    network and I can't transfer the file to here for various reasons. Is there
    something I can look for and transcribe that might be illustrative?

    The first thing I would look for is syscalls that return an error code.
    Also keep an eye out for syscall arguments that are obviously wrong --
    names with wrong domains, IP numbers on the wrong subnet, etc. Pay
    particular attention to the vicinity of the points where error messages are
    emitted.


    John

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/SpxuuBvC9YcJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedNov 13, '12 at 7:32p
activeNov 16, '12 at 6:45p
posts14
users4
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase