FAQ
I'm running dashbaord 1.2.12 on Ubuntu 10.04, with puppet 2.7.19

When I try to do an inventory search, I just get a blank screen.

When I try to view a changed file, I get a white box w/ "i/o error".

I have asked about this once before in IRC, and the fix involved using a
backported package, which I was unable to do at the time. Unfortunately, I
am unable to recall the version or the package(s) needed.

Can someone please let me know how to fix these issues?

(non-vendored) gem list:

bundler (1.1.4)
diff-lcs (1.1.3)
gorgeous (0.1.2)
gpgme (2.0.1)
hiera (1.1.0)
hiera-gpg (1.1.0)
hiera-puppet (1.0.0)
json (1.5.4)
metaclass (0.0.1)
mocha (0.12.1)
puppet-lint (0.3.2)
puppetlabs_spec_helper (0.2.0)
rack (1.1.2)
rake (0.9.2.2)
rdoc (3.11)
rspec (2.11.0)
rspec-core (2.11.1)
rspec-expectations (2.11.2)
rspec-mocks (2.11.1)
rspec-puppet (0.1.3)

Thank you.

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/0Pr5Kw0OaeEJ.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Matthaus Owens at Nov 13, 2012 at 6:41 pm
    Which activerecord is in use on the master? Does anything appear in
    the master logs? It looks like it's related to
    https://projects.puppetlabs.com/issues/16376, which is fixed in the
    current rc series for 2.7.20.
    On Tue, Nov 13, 2012 at 8:18 AM, llowder wrote:
    I'm running dashbaord 1.2.12 on Ubuntu 10.04, with puppet 2.7.19

    When I try to do an inventory search, I just get a blank screen.

    When I try to view a changed file, I get a white box w/ "i/o error".

    I have asked about this once before in IRC, and the fix involved using a
    backported package, which I was unable to do at the time. Unfortunately, I
    am unable to recall the version or the package(s) needed.

    Can someone please let me know how to fix these issues?

    (non-vendored) gem list:

    bundler (1.1.4)
    diff-lcs (1.1.3)
    gorgeous (0.1.2)
    gpgme (2.0.1)
    hiera (1.1.0)
    hiera-gpg (1.1.0)
    hiera-puppet (1.0.0)
    json (1.5.4)
    metaclass (0.0.1)
    mocha (0.12.1)
    puppet-lint (0.3.2)
    puppetlabs_spec_helper (0.2.0)
    rack (1.1.2)
    rake (0.9.2.2)
    rdoc (3.11)
    rspec (2.11.0)
    rspec-core (2.11.1)
    rspec-expectations (2.11.2)
    rspec-mocks (2.11.1)
    rspec-puppet (0.1.3)

    Thank you.

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/0Pr5Kw0OaeEJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.


    --
    Matthaus Owens
    Release Manager, Puppet Labs

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Llowder at Nov 13, 2012 at 7:01 pm

    On Tuesday, November 13, 2012 12:41:58 PM UTC-6, Matthaus Litteken wrote:
    Which activerecord is in use on the master? Does anything appear in
    the master logs? It looks like it's related to
    https://projects.puppetlabs.com/issues/16376, which is fixed in the
    current rc series for 2.7.20.
    I recently switched over to using puppetdb from storeconfigs, if that makes
    a difference.

    I'm not sure which version of the activerecord is installed - there isn't a
    package or a system gem installed, so it's whatever is vendored by puppet
    (2.7.19) or dashboard (just upgraded from 1.2.10 to 1.2.12)

    As for the logs, I could not find anything in:
    /var/log/apache2/error.log
    /var/log/puppet/*
    /var/log/puppet-dashboard/*

    I am running my puppet master via Apache + passenger, but Dashboard via
    webrick.

    Looking at that ticket, I think it may be the problem with the inventory
    issue, though there is still the filebucket issue to address.

    On Tue, Nov 13, 2012 at 8:18 AM, llowder <llow...@gmail.com <javascript:>>
    wrote:
    I'm running dashbaord 1.2.12 on Ubuntu 10.04, with puppet 2.7.19

    When I try to do an inventory search, I just get a blank screen.

    When I try to view a changed file, I get a white box w/ "i/o error".

    I have asked about this once before in IRC, and the fix involved using a
    backported package, which I was unable to do at the time. Unfortunately, I
    am unable to recall the version or the package(s) needed.

    Can someone please let me know how to fix these issues?

    (non-vendored) gem list:

    bundler (1.1.4)
    diff-lcs (1.1.3)
    gorgeous (0.1.2)
    gpgme (2.0.1)
    hiera (1.1.0)
    hiera-gpg (1.1.0)
    hiera-puppet (1.0.0)
    json (1.5.4)
    metaclass (0.0.1)
    mocha (0.12.1)
    puppet-lint (0.3.2)
    puppetlabs_spec_helper (0.2.0)
    rack (1.1.2)
    rake (0.9.2.2)
    rdoc (3.11)
    rspec (2.11.0)
    rspec-core (2.11.1)
    rspec-expectations (2.11.2)
    rspec-mocks (2.11.1)
    rspec-puppet (0.1.3)

    Thank you.

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/0Pr5Kw0OaeEJ.
    To post to this group, send email to puppet...@googlegroups.com<javascript:>.
    To unsubscribe from this group, send email to
    puppet-users...@googlegroups.com <javascript:>.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.


    --
    Matthaus Owens
    Release Manager, Puppet Labs
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/HPAzArbIr_8J.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedNov 13, '12 at 4:18p
activeNov 13, '12 at 7:01p
posts3
users2
websitepuppetlabs.com

2 users in discussion

Llowder: 2 posts Matthaus Owens: 1 post

People

Translate

site design / logo © 2022 Grokbase