FAQ
I recently enabled the rrdgraph reporting on my 2.7.19 master.

I set it to create the graphs in /var/lib/puppet/rrd.

In order to be able to access the things from the web, I set this directory
to have mode 755.

However, it keeps getting switched back to 750 during certain (all?) puppet
runs.

I then added the directory to one of my manifests to have puppet enforce
the desired permissions. Now I keep seeing "mode changed '0750' to '0775'"
for this resource.

How can I make puppet stop fighting with itself and maintain the mode I
want?

I'm on Ubuntu 10.04, with my puppet installed from packages.

Thank you.

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/F8-RM_S41w8J.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Eric Sorenson at Nov 13, 2012 at 6:41 pm
    use the attribute syntax in the config file, that way puppet won't clobber
    it

    ## puppet.conf
    [main]
    rrddir = /var/lib/puppet/rrd { mode=0755 }

    note this is currently not working under 3.0.1, tracking under #17371
    On Monday, November 12, 2012 7:54:57 AM UTC-8, llowder wrote:

    I recently enabled the rrdgraph reporting on my 2.7.19 master.

    I set it to create the graphs in /var/lib/puppet/rrd.

    In order to be able to access the things from the web, I set this
    directory to have mode 755.

    However, it keeps getting switched back to 750 during certain (all?)
    puppet runs.

    I then added the directory to one of my manifests to have puppet enforce
    the desired permissions. Now I keep seeing "mode changed '0750' to '0775'"
    for this resource.

    How can I make puppet stop fighting with itself and maintain the mode I
    want?

    I'm on Ubuntu 10.04, with my puppet installed from packages.

    Thank you.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/abfYrPqtefwJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Llowder at Nov 13, 2012 at 7:04 pm

    On Tuesday, November 13, 2012 12:41:38 PM UTC-6, Eric Sorenson wrote:
    use the attribute syntax in the config file, that way puppet won't clobber
    it

    ## puppet.conf
    [main]
    rrddir = /var/lib/puppet/rrd { mode=0755 }
    That was mentioned to me in IRC, and it did fix it.

    note this is currently not working under 3.0.1, tracking under #17371
    On Monday, November 12, 2012 7:54:57 AM UTC-8, llowder wrote:

    I recently enabled the rrdgraph reporting on my 2.7.19 master.

    I set it to create the graphs in /var/lib/puppet/rrd.

    In order to be able to access the things from the web, I set this
    directory to have mode 755.

    However, it keeps getting switched back to 750 during certain (all?)
    puppet runs.

    I then added the directory to one of my manifests to have puppet enforce
    the desired permissions. Now I keep seeing "mode changed '0750' to '0775'"
    for this resource.

    How can I make puppet stop fighting with itself and maintain the mode I
    want?

    I'm on Ubuntu 10.04, with my puppet installed from packages.

    Thank you.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/I5yZJFWV5-QJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedNov 12, '12 at 3:55p
activeNov 13, '12 at 7:04p
posts3
users2
websitepuppetlabs.com

2 users in discussion

Llowder: 2 posts Eric Sorenson: 1 post

People

Translate

site design / logo © 2022 Grokbase