FAQ
1. I get the following error when I run “puppet device’

err: Could not request certificate: Could not write
/var/opt/lib/pe-puppet/devices/certname/ssl/private_keys/certname.pem to
privatekeydir: Permission denied -
/var/opt/lib/pe-puppet/devices/certname/ssl/private_keys/certname.pem

Any thought?


Thanks,

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/rcg_UPtqyEsJ.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Gavin Williams at Nov 5, 2012 at 4:35 pm
    Looks like a file permissions error - I had similar when I started playing
    with puppet device...

    Check if the user you're running puppet as has permissions to write to
    '/var/opt/lib/pe-puppet/devices'.

    HTH

    Gav
    On Monday, 5 November 2012 16:18:03 UTC, meiji wang wrote:

    1. I get the following error when I run “puppet device’

    err: Could not request certificate: Could not write
    /var/opt/lib/pe-puppet/devices/certname/ssl/private_keys/certname.pem to
    privatekeydir: Permission denied -
    /var/opt/lib/pe-puppet/devices/certname/ssl/private_keys/certname.pem

    Any thought?


    Thanks,
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/BOdba0ATai4J.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Meiji wang at Nov 5, 2012 at 8:51 pm
    Although I change the mode to 0777, Puppet forces the mode to 0750

    debug: /File[/var/opt/lib/pe-puppet/devices/certname/state]: Autorequiring
    File[/var/opt/lib/pe-puppet/devices/certname]
    debug: /File[/var/opt/lib/pe-puppet/devices/certname/clientbucket]/mode:
    mode changed '0777' to '0750'
    debug: /File[/var/opt/lib/pe-puppet/devices/certname/ssl]/mode: mode
    changed '0777' to '0771'
    debug: /File[/var/opt/lib/pe-puppet/devices/certname/ssl/private]/mode:
    mode changed '0777' to '0750'
    debug: /File[/var/opt/lib/pe-puppet/devices/certname/state]/mode: mode
    changed '0777' to '1755'
    debug:
    /File[/var/opt/lib/pe-puppet/devices/certname/ssl/private_keys]/mode: mode
    changed '0777' to '0750'
    debug: /File[/var/opt/lib/pe-puppet/devices/certname/client_yaml]/mode:
    mode changed '0777' to '0750'
    debug: /File[/var/opt/lib/pe-puppet/devices/certname/client_data]/mode:
    mode changed '0777' to '0750'
    info: Creating a new SSL key for certname
    ......
    err: Could not request certificate: Could not write
    /var/opt/lib/pe-puppet/devices/certname/ssl/private_keys/certname.pem to
    privatekeydir: Permission denied -
    /var/opt/lib/pe-puppet/devices/certname/ssl/private_keys/certname.pem


    then Puppet throws error message..

    Meiji

    On Monday, November 5, 2012 8:18:03 AM UTC-8, meiji wang wrote:

    1. I get the following error when I run “puppet device’

    err: Could not request certificate: Could not write
    /var/opt/lib/pe-puppet/devices/certname/ssl/private_keys/certname.pem to
    privatekeydir: Permission denied -
    /var/opt/lib/pe-puppet/devices/certname/ssl/private_keys/certname.pem

    Any thought?


    Thanks,
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/CEDQ4q9o5uEJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Fatmcgav at Nov 5, 2012 at 9:16 pm
    Try changing the file owner/group to match what you're running puppet as...

    Gav
    On 5 November 2012 20:51, meiji wang wrote:

    Although I change the mode to 0777, Puppet forces the mode to 0750

    debug: /File[/var/opt/lib/pe-puppet/devices/certname/state]: Autorequiring
    File[/var/opt/lib/pe-puppet/devices/certname]
    debug: /File[/var/opt/lib/pe-puppet/devices/certname/clientbucket]/mode:
    mode changed '0777' to '0750'
    debug: /File[/var/opt/lib/pe-puppet/devices/certname/ssl]/mode: mode
    changed '0777' to '0771'
    debug: /File[/var/opt/lib/pe-puppet/devices/certname/ssl/private]/mode:
    mode changed '0777' to '0750'
    debug: /File[/var/opt/lib/pe-puppet/devices/certname/state]/mode: mode
    changed '0777' to '1755'
    debug:
    /File[/var/opt/lib/pe-puppet/devices/certname/ssl/private_keys]/mode: mode
    changed '0777' to '0750'
    debug: /File[/var/opt/lib/pe-puppet/devices/certname/client_yaml]/mode:
    mode changed '0777' to '0750'
    debug: /File[/var/opt/lib/pe-puppet/devices/certname/client_data]/mode:
    mode changed '0777' to '0750'
    info: Creating a new SSL key for certname
    ......
    err: Could not request certificate: Could not write
    /var/opt/lib/pe-puppet/devices/certname/ssl/private_keys/certname.pem to
    privatekeydir: Permission denied -
    /var/opt/lib/pe-puppet/devices/certname/ssl/private_keys/certname.pem


    then Puppet throws error message..

    Meiji

    On Monday, November 5, 2012 8:18:03 AM UTC-8, meiji wang wrote:

    1. I get the following error when I run “puppet device’

    err: Could not request certificate: Could not write
    /var/opt/lib/pe-puppet/**devices/certname/ssl/private_**keys/certname.pem
    to privatekeydir: Permission denied - /var/opt/lib/pe-puppet/**
    devices/certname/ssl/private_**keys/certname.pem

    Any thought?


    Thanks,
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/CEDQ4q9o5uEJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Srivatsa rao at May 17, 2013 at 2:05 pm
    Hello Gav and Meiji,
    I tried all the above.. still it doesn't solve my issue any further
    suggestion?

    my output when I run "puppet device --verbose"

    # puppet device --verbose
    info: starting applying configuration to sw1 at telnet://10.0.0.1/
    info: Creating a new SSL key for sw1
    err: Could not request certificate: Could not write
    /var/opt/lib/pe-puppet/devices/sw1/ssl/private_keys/sw1.pem to
    privatekeydir: Permission denied -
    /var/opt/lib/pe-puppet/devices/sw1/ssl/private_keys/sw1.pem
    info: Creating a new SSL key for sw1
    err: Could not request certificate: Could not write
    /var/opt/lib/pe-puppet/devices/sw1/ssl/private_keys/sw1.pem to
    privatekeydir: Permission denied -
    /var/opt/lib/pe-puppet/devices/sw1/ssl/private_keys/sw1.pem
    info: Creating a new SSL key for sw1
    err: Could not request certificate: Could not write
    /var/opt/lib/pe-puppet/devices/sw1/ssl/private_keys/sw1.pem to
    privatekeydir: Permission denied -
    /var/opt/lib/pe-puppet/devices/sw1/ssl/private_keys/sw1.pem
    .
    .
    .
    .

    Thanks,
    Vatsa
    On Monday, 5 November 2012 13:17:05 UTC-8, Gavin Williams wrote:

    Try changing the file owner/group to match what you're running puppet
    as...

    Gav

    On 5 November 2012 20:51, meiji wang <wang...@gmail.com <javascript:>>wrote:
    Although I change the mode to 0777, Puppet forces the mode to 0750

    debug: /File[/var/opt/lib/pe-puppet/devices/certname/state]:
    Autorequiring File[/var/opt/lib/pe-puppet/devices/certname]
    debug: /File[/var/opt/lib/pe-puppet/devices/certname/clientbucket]/mode:
    mode changed '0777' to '0750'
    debug: /File[/var/opt/lib/pe-puppet/devices/certname/ssl]/mode: mode
    changed '0777' to '0771'
    debug: /File[/var/opt/lib/pe-puppet/devices/certname/ssl/private]/mode:
    mode changed '0777' to '0750'
    debug: /File[/var/opt/lib/pe-puppet/devices/certname/state]/mode: mode
    changed '0777' to '1755'
    debug:
    /File[/var/opt/lib/pe-puppet/devices/certname/ssl/private_keys]/mode: mode
    changed '0777' to '0750'
    debug: /File[/var/opt/lib/pe-puppet/devices/certname/client_yaml]/mode:
    mode changed '0777' to '0750'
    debug: /File[/var/opt/lib/pe-puppet/devices/certname/client_data]/mode:
    mode changed '0777' to '0750'
    info: Creating a new SSL key for certname
    ......
    err: Could not request certificate: Could not write
    /var/opt/lib/pe-puppet/devices/certname/ssl/private_keys/certname.pem to
    privatekeydir: Permission denied -
    /var/opt/lib/pe-puppet/devices/certname/ssl/private_keys/certname.pem


    then Puppet throws error message..

    Meiji

    On Monday, November 5, 2012 8:18:03 AM UTC-8, meiji wang wrote:

    1. I get the following error when I run “puppet device’

    err: Could not request certificate: Could not write
    /var/opt/lib/pe-puppet/**devices/certname/ssl/private_**keys/certname.pem
    to privatekeydir: Permission denied - /var/opt/lib/pe-puppet/**
    devices/certname/ssl/private_**keys/certname.pem

    Any thought?


    Thanks,
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/CEDQ4q9o5uEJ.
    To post to this group, send email to puppet...@googlegroups.com<javascript:>
    .
    To unsubscribe from this group, send email to
    puppet-users...@googlegroups.com <javascript:>.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Piotr Jasiulewicz at Jul 18, 2013 at 9:42 am
    Hi,

    have you solved the problem? Having the same issue.

    Cheers,
    Piotr

    W dniu piątek, 17 maja 2013 15:04:22 UTC+1 użytkownik srivatsa rao napisał:
    Hello Gav and Meiji,
    I tried all the above.. still it doesn't solve my issue any further
    suggestion?

    my output when I run "puppet device --verbose"

    # puppet device --verbose
    info: starting applying configuration to sw1 at telnet://10.0.0.1/
    info: Creating a new SSL key for sw1
    err: Could not request certificate: Could not write
    /var/opt/lib/pe-puppet/devices/sw1/ssl/private_keys/sw1.pem to
    privatekeydir: Permission denied -
    /var/opt/lib/pe-puppet/devices/sw1/ssl/private_keys/sw1.pem
    info: Creating a new SSL key for sw1
    err: Could not request certificate: Could not write
    /var/opt/lib/pe-puppet/devices/sw1/ssl/private_keys/sw1.pem to
    privatekeydir: Permission denied -
    /var/opt/lib/pe-puppet/devices/sw1/ssl/private_keys/sw1.pem
    info: Creating a new SSL key for sw1
    err: Could not request certificate: Could not write
    /var/opt/lib/pe-puppet/devices/sw1/ssl/private_keys/sw1.pem to
    privatekeydir: Permission denied -
    /var/opt/lib/pe-puppet/devices/sw1/ssl/private_keys/sw1.pem
    .
    .
    .
    .

    Thanks,
    Vatsa
    On Monday, 5 November 2012 13:17:05 UTC-8, Gavin Williams wrote:

    Try changing the file owner/group to match what you're running puppet
    as...

    Gav
    On 5 November 2012 20:51, meiji wang wrote:

    Although I change the mode to 0777, Puppet forces the mode to 0750

    debug: /File[/var/opt/lib/pe-puppet/devices/certname/state]:
    Autorequiring File[/var/opt/lib/pe-puppet/devices/certname]
    debug: /File[/var/opt/lib/pe-puppet/devices/certname/clientbucket]/mode:
    mode changed '0777' to '0750'
    debug: /File[/var/opt/lib/pe-puppet/devices/certname/ssl]/mode: mode
    changed '0777' to '0771'
    debug: /File[/var/opt/lib/pe-puppet/devices/certname/ssl/private]/mode:
    mode changed '0777' to '0750'
    debug: /File[/var/opt/lib/pe-puppet/devices/certname/state]/mode: mode
    changed '0777' to '1755'
    debug:
    /File[/var/opt/lib/pe-puppet/devices/certname/ssl/private_keys]/mode: mode
    changed '0777' to '0750'
    debug: /File[/var/opt/lib/pe-puppet/devices/certname/client_yaml]/mode:
    mode changed '0777' to '0750'
    debug: /File[/var/opt/lib/pe-puppet/devices/certname/client_data]/mode:
    mode changed '0777' to '0750'
    info: Creating a new SSL key for certname
    ......
    err: Could not request certificate: Could not write
    /var/opt/lib/pe-puppet/devices/certname/ssl/private_keys/certname.pem to
    privatekeydir: Permission denied -
    /var/opt/lib/pe-puppet/devices/certname/ssl/private_keys/certname.pem


    then Puppet throws error message..

    Meiji

    On Monday, November 5, 2012 8:18:03 AM UTC-8, meiji wang wrote:

    1. I get the following error when I run “puppet device’

    err: Could not request certificate: Could not write
    /var/opt/lib/pe-puppet/**devices/certname/ssl/private_**keys/certname.pem
    to privatekeydir: Permission denied - /var/opt/lib/pe-puppet/**
    devices/certname/ssl/private_**keys/certname.pem

    Any thought?


    Thanks,
    --
    You received this message because you are subscribed to the Google
    Groups "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/CEDQ4q9o5uEJ.
    To post to this group, send email to puppet...@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users...@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Srivatsa rao at Jul 18, 2013 at 1:10 pm
    Hey,
    I tried a Lotta things. Nothing seemed to work so I bought up a new VM and carefully installed puppet following steps on website and things started to work.

    But I always had a doubt that I did not have the config file right or once its wrong the changes does not take effect, just my guess. Try with config file if it doesn't work just resort to re-install.

    Vatsa

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedNov 5, '12 at 4:18p
activeJul 18, '13 at 1:10p
posts7
users4
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase