FAQ
Does anyone know if using variable as tag values is permitted in puppet
2.7.19

Here is my example :

@@custom_define { 'export':
tag => $variable,
}

Custom_define <<| tag == $variable |>>

If i set the tag to a string (e.g tag => 'tag1',) it works without
problems, however if i use a variable the exported resource is not applied.

Thanks,
Cosmin

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/xBal_C1wqycJ.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Bernd Adamowicz at Oct 31, 2012 at 3:59 pm
    This could be a scope issue. You may want to try $::variable or some other prefix depending on where this variable actually is defined.

    See: http://docs.puppetlabs.com/guides/scope_and_puppet.html

    Bernd

    From: puppet-users@googlegroups.com On Behalf Of Cosmin-Viorel Ilie
    Sent: Mittwoch, 31. Oktober 2012 16:14
    To: puppet-users@googlegroups.com
    Subject: [Puppet Users] Problem using exported resources with tag => $variable

    Does anyone know if using variable as tag values is permitted in puppet 2.7.19

    Here is my example :
    @@custom_define { 'export':
    tag => $variable,
    }

    Custom_define <<| tag == $variable |>>

    If i set the tag to a string (e.g tag => 'tag1',) it works without problems, however if i use a variable the exported resource is not applied.

    Thanks,
    Cosmin
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/xBal_C1wqycJ.
    To post to this group, send email to puppet-users@googlegroups.com .
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com .
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Jeff McCune at Oct 31, 2012 at 4:21 pm

    On Wed, Oct 31, 2012 at 8:14 AM, Cosmin-Viorel Ilie wrote:

    Does anyone know if using variable as tag values is permitted in puppet
    2.7.19
    Yes, this should definitely work. If it doesn't please consider filing a
    bug at http://projects.puppetlabs.com/projects/puppet with an example that
    reproduces the problem.

    There may already be a bug filed on this issue.

    -Jeff

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedOct 31, '12 at 3:14p
activeOct 31, '12 at 4:21p
posts3
users3
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase