FAQ
Hi everyone,

I am trying to configure a puppet master with a puppetdb for storeconfigs backend. I am using Ubuntu 12.10 and the packages from puppetlabs repository. The option I chose for the master is to use passanger as I am far more familiar with apache than with the ruby web servers that are available as an option. I will also need puppetDB for proper nagios configuration so I got that as well from the ubuntu packages. Here is the full package list that I installed:

     apt-get install puppet-common puppetdb puppetdb-terminus puppetmaster-common puppetmaster-passenger

I followed the guides on puppetlabs and everything worked fine for a vagrant virtual machine I have locally as an agent. The problem came when I tried to add puppetDB to the picture. I started getting strange error on

     puppet agent -t

on the agent. I am also getting the following message in the system log
when I try to connect to the master

     Could not configure routes from /etc/puppet/routes.yaml: Could not find terminus puppetdb for indirection facts

Strangely enough I couldn't find any answers with googling so I decided to post here for help.

Best, Nikola

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Deepak Giridharagopal at Oct 24, 2012 at 8:58 pm
    We ended up hashing this out on the #puppet IRC channel earlier today.
    Nikola helped us identify a problem with our packaging on Debian/Ubuntu
    systems that are using Ruby 1.9:

    http://projects.puppetlabs.com/issues/17178

    We'll be cutting a new release soon that should have the above fix
    included. Stay tuned!

    deepak
    On Wed, Oct 24, 2012 at 7:16 AM, Nikola Petrov wrote:

    Hi everyone,

    I am trying to configure a puppet master with a puppetdb for storeconfigs
    backend. I am using Ubuntu 12.10 and the packages from puppetlabs
    repository. The option I chose for the master is to use passanger as I am
    far more familiar with apache than with the ruby web servers that are
    available as an option. I will also need puppetDB for proper nagios
    configuration so I got that as well from the ubuntu packages. Here is the
    full package list that I installed:

    apt-get install puppet-common puppetdb puppetdb-terminus
    puppetmaster-common puppetmaster-passenger

    I followed the guides on puppetlabs and everything worked fine for a
    vagrant virtual machine I have locally as an agent. The problem came when I
    tried to add puppetDB to the picture. I started getting strange error on

    puppet agent -t

    on the agent. I am also getting the following message in the system log
    when I try to connect to the master

    Could not configure routes from /etc/puppet/routes.yaml: Could not
    find terminus puppetdb for indirection facts

    Strangely enough I couldn't find any answers with googling so I decided to
    post here for help.

    Best, Nikola

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Alastair McFarlane at Jun 18, 2013 at 2:30 pm
    Hi,

    I'm currently receiving the above error trying to start the puppet master.
    I've followed the instructions to install PuppetDB and puppetdb-terminus,
    through packages, but I cannot get it to start up.

    The master would run successfully before setting up PuppetDB.

    The host system is running CentOS 6 and ruby 1.8, so this may not be the
    same issue you resolved in the above issue.

    Regards,

    Alastair
    On Wednesday, 24 October 2012 21:58:19 UTC+1, Deepak Giridharagopal wrote:

    We ended up hashing this out on the #puppet IRC channel earlier today.
    Nikola helped us identify a problem with our packaging on Debian/Ubuntu
    systems that are using Ruby 1.9:

    http://projects.puppetlabs.com/issues/17178

    We'll be cutting a new release soon that should have the above fix
    included. Stay tuned!

    deepak

    On Wed, Oct 24, 2012 at 7:16 AM, Nikola Petrov <niko...@gmail.com<javascript:>
    wrote:
    Hi everyone,

    I am trying to configure a puppet master with a puppetdb for storeconfigs
    backend. I am using Ubuntu 12.10 and the packages from puppetlabs
    repository. The option I chose for the master is to use passanger as I am
    far more familiar with apache than with the ruby web servers that are
    available as an option. I will also need puppetDB for proper nagios
    configuration so I got that as well from the ubuntu packages. Here is the
    full package list that I installed:

    apt-get install puppet-common puppetdb puppetdb-terminus
    puppetmaster-common puppetmaster-passenger

    I followed the guides on puppetlabs and everything worked fine for a
    vagrant virtual machine I have locally as an agent. The problem came when I
    tried to add puppetDB to the picture. I started getting strange error on

    puppet agent -t

    on the agent. I am also getting the following message in the system log
    when I try to connect to the master

    Could not configure routes from /etc/puppet/routes.yaml: Could not
    find terminus puppetdb for indirection facts

    Strangely enough I couldn't find any answers with googling so I decided
    to post here for help.

    Best, Nikola

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To post to this group, send email to puppet...@googlegroups.com<javascript:>
    .
    To unsubscribe from this group, send email to
    puppet-users...@googlegroups.com <javascript:>.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Alastair McFarlane at Jun 18, 2013 at 2:30 pm
    I've actually just raised an issue for the problem I just posted, I found
    the solution. Please see:

    http://projects.puppetlabs.com/issues/21283

    Alastair
    On Wednesday, 24 October 2012 21:58:19 UTC+1, Deepak Giridharagopal wrote:

    We ended up hashing this out on the #puppet IRC channel earlier today.
    Nikola helped us identify a problem with our packaging on Debian/Ubuntu
    systems that are using Ruby 1.9:

    http://projects.puppetlabs.com/issues/17178

    We'll be cutting a new release soon that should have the above fix
    included. Stay tuned!

    deepak

    On Wed, Oct 24, 2012 at 7:16 AM, Nikola Petrov <niko...@gmail.com<javascript:>
    wrote:
    Hi everyone,

    I am trying to configure a puppet master with a puppetdb for storeconfigs
    backend. I am using Ubuntu 12.10 and the packages from puppetlabs
    repository. The option I chose for the master is to use passanger as I am
    far more familiar with apache than with the ruby web servers that are
    available as an option. I will also need puppetDB for proper nagios
    configuration so I got that as well from the ubuntu packages. Here is the
    full package list that I installed:

    apt-get install puppet-common puppetdb puppetdb-terminus
    puppetmaster-common puppetmaster-passenger

    I followed the guides on puppetlabs and everything worked fine for a
    vagrant virtual machine I have locally as an agent. The problem came when I
    tried to add puppetDB to the picture. I started getting strange error on

    puppet agent -t

    on the agent. I am also getting the following message in the system log
    when I try to connect to the master

    Could not configure routes from /etc/puppet/routes.yaml: Could not
    find terminus puppetdb for indirection facts

    Strangely enough I couldn't find any answers with googling so I decided
    to post here for help.

    Best, Nikola

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To post to this group, send email to puppet...@googlegroups.com<javascript:>
    .
    To unsubscribe from this group, send email to
    puppet-users...@googlegroups.com <javascript:>.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Robin Lee Powell at Sep 24, 2013 at 8:02 am

    On Wed, Oct 24, 2012 at 05:16:51PM +0300, Nikola Petrov wrote:
    Hi everyone,

    I am trying to configure a puppet master with a puppetdb for storeconfigs backend. I am using Ubuntu 12.10 and the packages from puppetlabs repository. The option I chose for the master is to use passanger as I am far more familiar with apache than with the ruby web servers that are available as an option. I will also need puppetDB for proper nagios configuration so I got that as well from the ubuntu packages. Here is the full package list that I installed:

    apt-get install puppet-common puppetdb puppetdb-terminus puppetmaster-common puppetmaster-passenger

    I followed the guides on puppetlabs and everything worked fine for a vagrant virtual machine I have locally as an agent. The problem came when I tried to add puppetDB to the picture. I started getting strange error on

    puppet agent -t

    on the agent. I am also getting the following message in the system log
    when I try to connect to the master

    Could not configure routes from /etc/puppet/routes.yaml: Could not find terminus puppetdb for indirection facts

    Strangely enough I couldn't find any answers with googling so I decided to post here for help.
    This is a very old message, but since I couldn't find anything
    either, my answers to http://projects.puppetlabs.com/issues/16529
    might help some future searcher.

    -Robin

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedOct 24, '12 at 2:17p
activeSep 24, '13 at 8:02a
posts5
users4
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase