FAQ
I am attempting to use Chocolatey ( http://chocolatey.org ) as a package
provider for Puppet, but I continually get this error when running the
Puppet agent on my Win 7 box.

info: Caching catalog for ldap-windows-vm.localdomain
err: Failed to apply catalog: Parameter provider failed: Invalid package provide
r 'chocolatey' at /etc/puppet/environments/beta/modules/stormaas/manifests/init.
pp:9

I've placed this module, https://github.com/rismoney/puppet-chocolatey, in
my modules/ directory on my Puppet master, I have pluginsync set to true on
both the master and slave - and am already using a few imported types that
are working with the same setup.

Calling the package with:

package { 'stormaas':
ensure => installed,
provider => 'chocolatey',
}

I've tried with both the provider set to 'chocolatey' and chocolatey in
case it was a quotes issue, and restarted both the master and slave on
every change and ran the agent multiple times to ensure it was refreshed.

All other aspects of the module that is being applied to the machine works
- just not this.

It seems there *are* modules being loaded
into C:\ProgramData\PuppetLabs\puppet\var\lib\puppet\provider , including
this guy which I installed yesterday:
http://forge.puppetlabs.com/puppetlabs/dism , but this is not one of them.

Any thoughts?

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/2p1wylYT1pwJ.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Thomas Biddle at Oct 17, 2012 at 2:58 am
    Got it.

    Not sure if this is a bug, if I was placing it in the wrong scope and
    that's just bad practice - but:

    The provider needed to be in ` /etc/puppet/modules ` while I had it in `
    /etc/puppet/environments/beta/modules ` (With the rest of the items in my
    beta environment).

    Would still love to hear input on this though :-)

    TJ
    On Tuesday, October 16, 2012 4:32:55 PM UTC-7, Thomas Biddle wrote:

    I am attempting to use Chocolatey ( http://chocolatey.org ) as a package
    provider for Puppet, but I continually get this error when running the
    Puppet agent on my Win 7 box.

    info: Caching catalog for ldap-windows-vm.localdomain
    err: Failed to apply catalog: Parameter provider failed: Invalid package provide
    r 'chocolatey' at /etc/puppet/environments/beta/modules/stormaas/manifests/init.
    pp:9

    I've placed this module, https://github.com/rismoney/puppet-chocolatey,
    in my modules/ directory on my Puppet master, I have pluginsync set to true
    on both the master and slave - and am already using a few imported types
    that are working with the same setup.

    Calling the package with:

    package { 'stormaas':
    ensure => installed,
    provider => 'chocolatey',
    }

    I've tried with both the provider set to 'chocolatey' and chocolatey in
    case it was a quotes issue, and restarted both the master and slave on
    every change and ran the agent multiple times to ensure it was refreshed.

    All other aspects of the module that is being applied to the machine works
    - just not this.

    It seems there *are* modules being loaded
    into C:\ProgramData\PuppetLabs\puppet\var\lib\puppet\provider , including
    this guy which I installed yesterday:
    http://forge.puppetlabs.com/puppetlabs/dism , but this is not one of
    them.

    Any thoughts?
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/_9eTNb_1oDgJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Ryan Coleman at Oct 17, 2012 at 2:08 am
    Hi TJ,
    On Tue, Oct 16, 2012 at 7:00 PM, Thomas Biddle wrote:

    Got it.

    Not sure if this is a bug, if I was placing it in the wrong scope and
    that's just bad practice - but:

    The provider needed to be in ` /etc/puppet/modules ` while I had it in `
    /etc/puppet/environments/beta/modules ` (With the rest of the items in my
    beta environment).
    Aw, crap. I think we might have an open bug about this somewhere. Had you
    run a puppet agent with pluginsync on the master? I think there's something
    about having the master syncing plugins to its own libdir from an
    environment before it'll serve that to agents. I'm hand-waving most of this
    because I can't find the ticket I'm thinking of.

    Anyhow, if you try that.. can you sync the provider to a windows agent from
    your environment?

    Would still love to hear input on this though :-)

    TJ
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedOct 17, '12 at 12:43a
activeOct 17, '12 at 2:58a
posts3
users2
websitepuppetlabs.com

2 users in discussion

Thomas Biddle: 2 posts Ryan Coleman: 1 post

People

Translate

site design / logo © 2022 Grokbase