FAQ
Hi Everyone;

I am now getting a puppetdb connection error when I attempt to run
#puppet agent --test

Error: Could not retrieve catalog from remote server: Error 400 on SERVER:
Failed to submit 'replace facts' command for puppetdev to PuppetDB at
puppetdev:8081: Connection refused - connect(2)


puppet.conf
[master]
storeconfigs = true
storeconfigs_backend = puppetdb


puppetdb.conf
[main]
server = puppetdev04
port = 8081
JAVA_ARGS="-Xmx192m"

I am running 3.0 open source with passenger....
Using postgres

I have the puppetdb daemin running

Any advice, as always, would be greatly appreciated!


Bee

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Chris Price at Oct 18, 2012 at 5:36 pm
    Hello Bee,

    This message is often the result of one of the following:

    1) Firewall blocking the puppetdb port
    2) DNS issue with the hostname specified in your puppetdb.conf
    3) DNS issue with the ssl-host specified in your jetty.ini on the puppetdb
    server

    Are you able to connect (e.g. via telnet) from the master machine to port
    8081 on the puppetdb machine?

    Please feel free to jump on the #puppet channel in Freenode if you need
    rapid assistance! We'll be happy to help.

    Thanks
    Chris
    On Wednesday, October 17, 2012 1:42:06 PM UTC-7, Worker Bee wrote:

    Hi Everyone;

    I am now getting a puppetdb connection error when I attempt to run
    #puppet agent --test

    Error: Could not retrieve catalog from remote server: Error 400 on SERVER:
    Failed to submit 'replace facts' command for puppetdev to PuppetDB at
    puppetdev:8081: Connection refused - connect(2)


    puppet.conf
    [master]
    storeconfigs = true
    storeconfigs_backend = puppetdb


    puppetdb.conf
    [main]
    server = puppetdev04
    port = 8081
    JAVA_ARGS="-Xmx192m"

    I am running 3.0 open source with passenger....
    Using postgres

    I have the puppetdb daemin running

    Any advice, as always, would be greatly appreciated!


    Bee
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/DwtFZvuAGtcJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Jacqueline Atkins at Oct 18, 2012 at 8:29 pm
    Thanks so much!

    I actually got to the bottom of the issue late last night. It was an issue
    with how I had configured postgres.

    Thanks everyone!


    On Thu, Oct 18, 2012 at 12:33 PM, Chris Price wrote:

    Hello Bee,

    This message is often the result of one of the following:

    1) Firewall blocking the puppetdb port
    2) DNS issue with the hostname specified in your puppetdb.conf
    3) DNS issue with the ssl-host specified in your jetty.ini on the puppetdb
    server

    Are you able to connect (e.g. via telnet) from the master machine to port
    8081 on the puppetdb machine?

    Please feel free to jump on the #puppet channel in Freenode if you need
    rapid assistance! We'll be happy to help.

    Thanks
    Chris

    On Wednesday, October 17, 2012 1:42:06 PM UTC-7, Worker Bee wrote:

    Hi Everyone;

    I am now getting a puppetdb connection error when I attempt to run
    #puppet agent --test

    Error: Could not retrieve catalog from remote server: Error 400 on
    SERVER: Failed to submit 'replace facts' command for puppetdev to PuppetDB
    at puppetdev:8081: Connection refused - connect(2)


    puppet.conf
    [master]
    storeconfigs = true
    storeconfigs_backend = puppetdb


    puppetdb.conf
    [main]
    server = puppetdev04
    port = 8081
    JAVA_ARGS="-Xmx192m"

    I am running 3.0 open source with passenger....
    Using postgres

    I have the puppetdb daemin running

    Any advice, as always, would be greatly appreciated!


    Bee
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/DwtFZvuAGtcJ.

    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedOct 17, '12 at 11:22p
activeOct 18, '12 at 8:29p
posts3
users3
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase