FAQ
Hello,



I installed puppet-server, passenger and dashboard. I have tested every
step in between to make sure all is running well and not errors are
carrying forward. Dashboard worked well with my test in WEBrick.

After configure the dashboard with passenger I got the message” The
environment must be purely alphanumeric, not ''” instead of the dashboard.

I verified the configuration files and all look to be in place, but I
should be missing something.

This is my current environment:

CentOS release 6.3 x86_64

puppet-2.7.19-1.el6.noarch

puppet-server-2.7.19-1.el6.noarch

puppet-dashboard-1.2.12-1.el6.noarch



*** LOCAL GEMS ***



activemodel (3.2.8)

activerecord (3.2.8)

activesupport (3.2.8)

arel (3.0.2)

builder (3.0.3)

daemon_controller (1.0.0)

fastthread (1.0.7)

i18n (0.6.1)

json (1.4.6)

multi_json (1.3.6)

passenger (3.0.17)

rack (1.4.1)

rake (0.9.2.2, 0.8.7)

tzinfo (0.3.33)



# rpm -qa | grep ruby

ruby-devel-1.8.7.352-7.el6_2.x86_64

ruby-mysql-2.8.2-1.el6.x86_64

ruby-libs-1.8.7.352-7.el6_2.x86_64

ruby-irb-1.8.7.352-7.el6_2.x86_64

rubygems-1.3.7-1.el6.noarch

ruby-shadow-1.4.1-13.el6.x86_64

libselinux-ruby-2.0.94-5.3.el6.x86_64

ruby-augeas-0.4.1-1.el6.x86_64

rubygem-json-1.4.6-1.el6.x86_64

rubygem-rake-0.8.7-2.1.el6.noarch

ruby-ri-1.8.7.352-7.el6_2.x86_64

ruby-1.8.7.352-7.el6_2.x86_64

ruby-rdoc-1.8.7.352-7.el6_2.x86_64



rpm -qa | grep mysql

ruby-mysql-2.8.2-1.el6.x86_64

mysql-5.1.61-4.el6.x86_64

mysql-devel-5.1.61-4.el6.x86_64

mysql-libs-5.1.61-4.el6.x86_64

mysql-server-5.1.61-4.el6.x86_64







Any help will be welcome.

Thanks,



Andrew

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/EuSF65nrsroJ.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Eric Sorenson at Oct 18, 2012 at 6:44 pm
    Hi andrew, that error is one that comes from the puppet master process
    itself when you connect to it with a regular HTTP client. So it looks like
    your apache virtualhost setup is pointing connections to that port/host at
    the puppetmaster config.ru, not dashboard. Does that help track down the
    issue?

    -=Eric
    On Tuesday, October 16, 2012 12:50:59 PM UTC-7, Andrew Gooding wrote:

    Hello,



    I installed puppet-server, passenger and dashboard. I have tested every
    step in between to make sure all is running well and not errors are
    carrying forward. Dashboard worked well with my test in WEBrick.

    After configure the dashboard with passenger I got the message” The
    environment must be purely alphanumeric, not ''” instead of the dashboard.

    I verified the configuration files and all look to be in place, but I
    should be missing something.

    This is my current environment:

    CentOS release 6.3 x86_64

    puppet-2.7.19-1.el6.noarch

    puppet-server-2.7.19-1.el6.noarch

    puppet-dashboard-1.2.12-1.el6.noarch



    *** LOCAL GEMS ***



    activemodel (3.2.8)

    activerecord (3.2.8)

    activesupport (3.2.8)

    arel (3.0.2)

    builder (3.0.3)

    daemon_controller (1.0.0)

    fastthread (1.0.7)

    i18n (0.6.1)

    json (1.4.6)

    multi_json (1.3.6)

    passenger (3.0.17)

    rack (1.4.1)

    rake (0.9.2.2, 0.8.7)

    tzinfo (0.3.33)



    # rpm -qa | grep ruby

    ruby-devel-1.8.7.352-7.el6_2.x86_64

    ruby-mysql-2.8.2-1.el6.x86_64

    ruby-libs-1.8.7.352-7.el6_2.x86_64

    ruby-irb-1.8.7.352-7.el6_2.x86_64

    rubygems-1.3.7-1.el6.noarch

    ruby-shadow-1.4.1-13.el6.x86_64

    libselinux-ruby-2.0.94-5.3.el6.x86_64

    ruby-augeas-0.4.1-1.el6.x86_64

    rubygem-json-1.4.6-1.el6.x86_64

    rubygem-rake-0.8.7-2.1.el6.noarch

    ruby-ri-1.8.7.352-7.el6_2.x86_64

    ruby-1.8.7.352-7.el6_2.x86_64

    ruby-rdoc-1.8.7.352-7.el6_2.x86_64



    rpm -qa | grep mysql

    ruby-mysql-2.8.2-1.el6.x86_64

    mysql-5.1.61-4.el6.x86_64

    mysql-devel-5.1.61-4.el6.x86_64

    mysql-libs-5.1.61-4.el6.x86_64

    mysql-server-5.1.61-4.el6.x86_64







    Any help will be welcome.

    Thanks,



    Andrew
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/WYUESZuF8bMJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Andrew Gooding at Nov 16, 2012 at 6:04 pm
    This is the config.ru file that I have inside the folder
    /usr/share/puppet-dashboard :

    # a config.ru, for use with every rack-compatible webserver.
    # SSL needs to be handled outside this, though.

    # if puppet is not in your RUBYLIB:
    # $LOAD_PATH.unshift('/opt/puppet/lib')

    $0 = "master"

    # if you want debugging:
    # ARGV << "--debug"

    ARGV << "--rack"

    # Rack applications typically don't start as root. Set --confdir to prevent
    # reading configuration from ~/.puppet/puppet.conf
    ARGV << "--confdir" << "/etc/puppet"

    # NOTE: it's unfortunate that we have to use the "CommandLine" class
    # here to launch the app, but it contains some initialization logic
    # (such as triggering the parsing of the config file) that is very
    # important. We should do something less nasty here when we've
    # gotten our API and settings initialization logic cleaned up.
    #
    # Also note that the "$0 = master" line up near the top here is
    # the magic that allows the CommandLine class to know that it's
    # supposed to be running master.
    #
    # --cprice 2012-05-22

    require 'puppet/application/master'
    # we're usually running inside a Rack::Builder.new {} block,
    # therefore we need to call run *here*.
    run Puppet::Application[:master].run


    Where should I apply the changes?
    On Thursday, October 18, 2012 10:37:54 AM UTC-7, Eric Sorenson wrote:

    Hi andrew, that error is one that comes from the puppet master process
    itself when you connect to it with a regular HTTP client. So it looks like
    your apache virtualhost setup is pointing connections to that port/host at
    the puppetmaster config.ru, not dashboard. Does that help track down the
    issue?

    -=Eric
    On Tuesday, October 16, 2012 12:50:59 PM UTC-7, Andrew Gooding wrote:

    Hello,



    I installed puppet-server, passenger and dashboard. I have tested every
    step in between to make sure all is running well and not errors are
    carrying forward. Dashboard worked well with my test in WEBrick.

    After configure the dashboard with passenger I got the message” The
    environment must be purely alphanumeric, not ''” instead of the dashboard.

    I verified the configuration files and all look to be in place, but I
    should be missing something.

    This is my current environment:

    CentOS release 6.3 x86_64

    puppet-2.7.19-1.el6.noarch

    puppet-server-2.7.19-1.el6.noarch

    puppet-dashboard-1.2.12-1.el6.noarch



    *** LOCAL GEMS ***



    activemodel (3.2.8)

    activerecord (3.2.8)

    activesupport (3.2.8)

    arel (3.0.2)

    builder (3.0.3)

    daemon_controller (1.0.0)

    fastthread (1.0.7)

    i18n (0.6.1)

    json (1.4.6)

    multi_json (1.3.6)

    passenger (3.0.17)

    rack (1.4.1)

    rake (0.9.2.2, 0.8.7)

    tzinfo (0.3.33)



    # rpm -qa | grep ruby

    ruby-devel-1.8.7.352-7.el6_2.x86_64

    ruby-mysql-2.8.2-1.el6.x86_64

    ruby-libs-1.8.7.352-7.el6_2.x86_64

    ruby-irb-1.8.7.352-7.el6_2.x86_64

    rubygems-1.3.7-1.el6.noarch

    ruby-shadow-1.4.1-13.el6.x86_64

    libselinux-ruby-2.0.94-5.3.el6.x86_64

    ruby-augeas-0.4.1-1.el6.x86_64

    rubygem-json-1.4.6-1.el6.x86_64

    rubygem-rake-0.8.7-2.1.el6.noarch

    ruby-ri-1.8.7.352-7.el6_2.x86_64

    ruby-1.8.7.352-7.el6_2.x86_64

    ruby-rdoc-1.8.7.352-7.el6_2.x86_64



    rpm -qa | grep mysql

    ruby-mysql-2.8.2-1.el6.x86_64

    mysql-5.1.61-4.el6.x86_64

    mysql-devel-5.1.61-4.el6.x86_64

    mysql-libs-5.1.61-4.el6.x86_64

    mysql-server-5.1.61-4.el6.x86_64







    Any help will be welcome.

    Thanks,



    Andrew
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/uxBa8zyglS4J.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Eric Sorenson at Nov 19, 2012 at 11:08 pm
    Hi Andrew, sorry I wasn't clear -- The config.ru is probably fine, the
    problem is more likely in the Apache configuration (usually in
    /etc/httpd/conf.d/) that sets up the two virtual hosts (One for the
    puppetmaster and the other for Dashboard). There might be an overlapping
    virtualhost definition or the like. If you have trouble unwinding it,
    please make a gist on github or pastie.com that shows these Apache config
    files.
    On Friday, November 16, 2012 10:04:38 AM UTC-8, Andrew Gooding wrote:

    This is the config.ru file that I have inside the folder
    /usr/share/puppet-dashboard :

    # a config.ru, for use with every rack-compatible webserver.
    # SSL needs to be handled outside this, though.

    # if puppet is not in your RUBYLIB:
    # $LOAD_PATH.unshift('/opt/puppet/lib')

    $0 = "master"

    # if you want debugging:
    # ARGV << "--debug"

    ARGV << "--rack"

    # Rack applications typically don't start as root. Set --confdir to
    prevent
    # reading configuration from ~/.puppet/puppet.conf
    ARGV << "--confdir" << "/etc/puppet"

    # NOTE: it's unfortunate that we have to use the "CommandLine" class
    # here to launch the app, but it contains some initialization logic
    # (such as triggering the parsing of the config file) that is very
    # important. We should do something less nasty here when we've
    # gotten our API and settings initialization logic cleaned up.
    #
    # Also note that the "$0 = master" line up near the top here is
    # the magic that allows the CommandLine class to know that it's
    # supposed to be running master.
    #
    # --cprice 2012-05-22

    require 'puppet/application/master'
    # we're usually running inside a Rack::Builder.new {} block,
    # therefore we need to call run *here*.
    run Puppet::Application[:master].run


    Where should I apply the changes?
    On Thursday, October 18, 2012 10:37:54 AM UTC-7, Eric Sorenson wrote:

    Hi andrew, that error is one that comes from the puppet master process
    itself when you connect to it with a regular HTTP client. So it looks like
    your apache virtualhost setup is pointing connections to that port/host at
    the puppetmaster config.ru, not dashboard. Does that help track down
    the issue?

    -=Eric
    On Tuesday, October 16, 2012 12:50:59 PM UTC-7, Andrew Gooding wrote:

    Hello,



    I installed puppet-server, passenger and dashboard. I have tested every
    step in between to make sure all is running well and not errors are
    carrying forward. Dashboard worked well with my test in WEBrick.

    After configure the dashboard with passenger I got the message” The
    environment must be purely alphanumeric, not ''” instead of the dashboard.

    I verified the configuration files and all look to be in place, but I
    should be missing something.

    This is my current environment:

    CentOS release 6.3 x86_64

    puppet-2.7.19-1.el6.noarch

    puppet-server-2.7.19-1.el6.noarch

    puppet-dashboard-1.2.12-1.el6.noarch



    *** LOCAL GEMS ***



    activemodel (3.2.8)

    activerecord (3.2.8)

    activesupport (3.2.8)

    arel (3.0.2)

    builder (3.0.3)

    daemon_controller (1.0.0)

    fastthread (1.0.7)

    i18n (0.6.1)

    json (1.4.6)

    multi_json (1.3.6)

    passenger (3.0.17)

    rack (1.4.1)

    rake (0.9.2.2, 0.8.7)

    tzinfo (0.3.33)



    # rpm -qa | grep ruby

    ruby-devel-1.8.7.352-7.el6_2.x86_64

    ruby-mysql-2.8.2-1.el6.x86_64

    ruby-libs-1.8.7.352-7.el6_2.x86_64

    ruby-irb-1.8.7.352-7.el6_2.x86_64

    rubygems-1.3.7-1.el6.noarch

    ruby-shadow-1.4.1-13.el6.x86_64

    libselinux-ruby-2.0.94-5.3.el6.x86_64

    ruby-augeas-0.4.1-1.el6.x86_64

    rubygem-json-1.4.6-1.el6.x86_64

    rubygem-rake-0.8.7-2.1.el6.noarch

    ruby-ri-1.8.7.352-7.el6_2.x86_64

    ruby-1.8.7.352-7.el6_2.x86_64

    ruby-rdoc-1.8.7.352-7.el6_2.x86_64



    rpm -qa | grep mysql

    ruby-mysql-2.8.2-1.el6.x86_64

    mysql-5.1.61-4.el6.x86_64

    mysql-devel-5.1.61-4.el6.x86_64

    mysql-libs-5.1.61-4.el6.x86_64

    mysql-server-5.1.61-4.el6.x86_64







    Any help will be welcome.

    Thanks,



    Andrew
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/mNTjwoteit0J.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedOct 16, '12 at 7:57p
activeNov 19, '12 at 11:08p
posts4
users2
websitepuppetlabs.com

2 users in discussion

Eric Sorenson: 2 posts Andrew Gooding: 2 posts

People

Translate

site design / logo © 2022 Grokbase