FAQ
Hi Everyone;

I am getting the following error when I try to install PuppetDB.

Maybe I have stale instructions??

Thanks!
Bee

Error: Could not retrieve catalog from remote server: Error 400 on SERVER:
Invalid tag "::postgresql::validate_db_connection" at
/etc/puppet/modules/puppetdb/manifests/server/validate_db.pp:62

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Nr18 at Oct 30, 2012 at 9:28 pm
    I have the same issue did you find a solution or explanation for this issue?
    On Friday, 12 October 2012 16:04:01 UTC+2, Worker Bee wrote:

    Hi Everyone;

    I am getting the following error when I try to install PuppetDB.

    Maybe I have stale instructions??

    Thanks!
    Bee

    Error: Could not retrieve catalog from remote server: Error 400 on SERVER:
    Invalid tag "::postgresql::validate_db_connection" at
    /etc/puppet/modules/puppetdb/manifests/server/validate_db.pp:62
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/LPifBJID-N8J.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Nr18 at Oct 30, 2012 at 9:42 pm
    Found it!!

    You need to include the dependencies of the module in you module path:

    cprice404/inifile -> http://forge.puppetlabs.com/cprice404/inifile
    puppetlabs/postgresql -> http://forge.puppetlabs.com/puppetlabs/postgresql

    Regards,

    Nr18

    On Tuesday, 30 October 2012 22:18:01 UTC+1, Nr18 wrote:

    I have the same issue did you find a solution or explanation for this
    issue?
    On Friday, 12 October 2012 16:04:01 UTC+2, Worker Bee wrote:

    Hi Everyone;

    I am getting the following error when I try to install PuppetDB.

    Maybe I have stale instructions??

    Thanks!
    Bee

    Error: Could not retrieve catalog from remote server: Error 400 on
    SERVER: Invalid tag "::postgresql::validate_db_connection" at
    /etc/puppet/modules/puppetdb/manifests/server/validate_db.pp:62
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/Wf8DXzYUoh8J.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Worker Bee at Oct 31, 2012 at 4:44 pm
    thanks, I was just getting ready to reply.
    I did actually find this information and get it working!

    Thank and feel free to ping me if you have any problems!



    On Tue, Oct 30, 2012 at 5:42 PM, Nr18 wrote:

    Found it!!

    You need to include the dependencies of the module in you module path:

    cprice404/inifile -> http://forge.puppetlabs.com/cprice404/inifile
    puppetlabs/postgresql -> http://forge.puppetlabs.com/puppetlabs/postgresql

    Regards,

    Nr18

    On Tuesday, 30 October 2012 22:18:01 UTC+1, Nr18 wrote:

    I have the same issue did you find a solution or explanation for this
    issue?
    On Friday, 12 October 2012 16:04:01 UTC+2, Worker Bee wrote:

    Hi Everyone;

    I am getting the following error when I try to install PuppetDB.

    Maybe I have stale instructions??

    Thanks!
    Bee

    Error: Could not retrieve catalog from remote server: Error 400 on
    SERVER: Invalid tag "::postgresql::validate_db_**connection" at
    /etc/puppet/modules/puppetdb/**manifests/server/validate_db.**pp:62
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/Wf8DXzYUoh8J.

    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Chris Price at Oct 31, 2012 at 6:58 pm
    Great, glad you were able to work it out. Out of curiosity, how did you
    install the puppetdb module? I presume you did not use the `puppet module`
    tool, which installs those dependencies for you. Would it be valuable for
    us to put some more explicit information about the dependencies somewhere
    so that others don't encounter the same issue? Any suggestions on where we
    should put that info?

    Thanks for the feedback! Please let us know if you have any additional
    trouble!

    On Wednesday, October 31, 2012 9:44:31 AM UTC-7, Worker Bee wrote:

    thanks, I was just getting ready to reply.
    I did actually find this information and get it working!

    Thank and feel free to ping me if you have any problems!




    On Tue, Oct 30, 2012 at 5:42 PM, Nr18 <j...@woodwing.com <javascript:>>wrote:
    Found it!!

    You need to include the dependencies of the module in you module path:

    cprice404/inifile -> http://forge.puppetlabs.com/cprice404/inifile
    puppetlabs/postgresql ->
    http://forge.puppetlabs.com/puppetlabs/postgresql

    Regards,

    Nr18

    On Tuesday, 30 October 2012 22:18:01 UTC+1, Nr18 wrote:

    I have the same issue did you find a solution or explanation for this
    issue?
    On Friday, 12 October 2012 16:04:01 UTC+2, Worker Bee wrote:

    Hi Everyone;

    I am getting the following error when I try to install PuppetDB.

    Maybe I have stale instructions??

    Thanks!
    Bee

    Error: Could not retrieve catalog from remote server: Error 400 on
    SERVER: Invalid tag "::postgresql::validate_db_**connection" at
    /etc/puppet/modules/puppetdb/**manifests/server/validate_db.**pp:62
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/Wf8DXzYUoh8J.

    To post to this group, send email to puppet...@googlegroups.com<javascript:>
    .
    To unsubscribe from this group, send email to
    puppet-users...@googlegroups.com <javascript:>.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/vjlJF8Azs-sJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Worker Bee at Oct 31, 2012 at 7:24 pm
    In my case, I need to be able to install as an rpm because we use yum (for
    now) to ensure consistent distribution across all of our environments.

    Just for testing, I also did an install via 'puppet module' and that worked
    pretty well...

    On Wed, Oct 31, 2012 at 2:51 PM, Chris Price wrote:

    Great, glad you were able to work it out. Out of curiosity, how did you
    install the puppetdb module? I presume you did not use the `puppet module`
    tool, which installs those dependencies for you. Would it be valuable for
    us to put some more explicit information about the dependencies somewhere
    so that others don't encounter the same issue? Any suggestions on where we
    should put that info?

    Thanks for the feedback! Please let us know if you have any additional
    trouble!

    On Wednesday, October 31, 2012 9:44:31 AM UTC-7, Worker Bee wrote:

    thanks, I was just getting ready to reply.
    I did actually find this information and get it working!

    Thank and feel free to ping me if you have any problems!



    On Tue, Oct 30, 2012 at 5:42 PM, Nr18 wrote:

    Found it!!

    You need to include the dependencies of the module in you module path:

    cprice404/inifile -> http://forge.puppetlabs.**com/cprice404/inifile<http://forge.puppetlabs.com/cprice404/inifile>
    puppetlabs/postgresql -> http://forge.puppetlabs.**
    com/puppetlabs/postgresql<http://forge.puppetlabs.com/puppetlabs/postgresql>

    Regards,

    Nr18

    On Tuesday, 30 October 2012 22:18:01 UTC+1, Nr18 wrote:

    I have the same issue did you find a solution or explanation for this
    issue?
    On Friday, 12 October 2012 16:04:01 UTC+2, Worker Bee wrote:

    Hi Everyone;

    I am getting the following error when I try to install PuppetDB.

    Maybe I have stale instructions??

    Thanks!
    Bee

    Error: Could not retrieve catalog from remote server: Error 400 on
    SERVER: Invalid tag "::postgresql::validate_db_**con**nection" at
    /etc/puppet/modules/puppetdb/**m**anifests/server/validate_db.**pp**:62
    --
    You received this message because you are subscribed to the Google
    Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/**
    msg/puppet-users/-/**Wf8DXzYUoh8J<https://groups.google.com/d/msg/puppet-users/-/Wf8DXzYUoh8J>
    .

    To post to this group, send email to puppet...@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users...@**
    googlegroups.com.

    For more options, visit this group at http://groups.google.com/**
    group/puppet-users?hl=en<http://groups.google.com/group/puppet-users?hl=en>
    .
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/vjlJF8Azs-sJ.

    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Chris Price at Oct 31, 2012 at 10:32 pm
    Ah, I see... so you downloaded the module tarball and built your own RPM?
    Anything we could have done to help highlight the fact that the module had
    some dependencies?
    On Wednesday, October 31, 2012 11:54:44 AM UTC-7, Worker Bee wrote:

    In my case, I need to be able to install as an rpm because we use yum (for
    now) to ensure consistent distribution across all of our environments.

    Just for testing, I also did an install via 'puppet module' and that
    worked pretty well...


    On Wed, Oct 31, 2012 at 2:51 PM, Chris Price <ch...@puppetlabs.com<javascript:>
    wrote:
    Great, glad you were able to work it out. Out of curiosity, how did you
    install the puppetdb module? I presume you did not use the `puppet module`
    tool, which installs those dependencies for you. Would it be valuable for
    us to put some more explicit information about the dependencies somewhere
    so that others don't encounter the same issue? Any suggestions on where we
    should put that info?

    Thanks for the feedback! Please let us know if you have any additional
    trouble!

    On Wednesday, October 31, 2012 9:44:31 AM UTC-7, Worker Bee wrote:

    thanks, I was just getting ready to reply.
    I did actually find this information and get it working!

    Thank and feel free to ping me if you have any problems!



    On Tue, Oct 30, 2012 at 5:42 PM, Nr18 wrote:

    Found it!!

    You need to include the dependencies of the module in you module path:

    cprice404/inifile -> http://forge.puppetlabs.**com/cprice404/inifile<http://forge.puppetlabs.com/cprice404/inifile>
    puppetlabs/postgresql -> http://forge.puppetlabs.**
    com/puppetlabs/postgresql<http://forge.puppetlabs.com/puppetlabs/postgresql>

    Regards,

    Nr18

    On Tuesday, 30 October 2012 22:18:01 UTC+1, Nr18 wrote:

    I have the same issue did you find a solution or explanation for this
    issue?
    On Friday, 12 October 2012 16:04:01 UTC+2, Worker Bee wrote:

    Hi Everyone;

    I am getting the following error when I try to install PuppetDB.

    Maybe I have stale instructions??

    Thanks!
    Bee

    Error: Could not retrieve catalog from remote server: Error 400 on
    SERVER: Invalid tag "::postgresql::validate_db_**con**nection" at
    /etc/puppet/modules/puppetdb/**m**anifests/server/validate_db.**pp**:62
    --
    You received this message because you are subscribed to the Google
    Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/**
    msg/puppet-users/-/**Wf8DXzYUoh8J<https://groups.google.com/d/msg/puppet-users/-/Wf8DXzYUoh8J>
    .

    To post to this group, send email to puppet...@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users...@**
    googlegroups.com.

    For more options, visit this group at http://groups.google.com/**
    group/puppet-users?hl=en<http://groups.google.com/group/puppet-users?hl=en>
    .
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/vjlJF8Azs-sJ.

    To post to this group, send email to puppet...@googlegroups.com<javascript:>
    .
    To unsubscribe from this group, send email to
    puppet-users...@googlegroups.com <javascript:>.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/7z61tiLXXYoJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedOct 12, '12 at 3:00p
activeOct 31, '12 at 10:32p
posts7
users3
websitepuppetlabs.com

3 users in discussion

Worker Bee: 3 posts Nr18: 2 posts Chris Price: 2 posts

People

Translate

site design / logo © 2022 Grokbase