FAQ
Hello list,

I try to install puppet agent on Debian Lenny. I got following error.
Seems the repo is broken :

-----------------------------------------------------------------------------------------------------------------------------------

node001:~# wget http://apt.puppetlabs.com/puppetlabs-release-lenny.deb
--2012-10-12 02:12:12-- http://apt.puppetlabs.com/puppetlabs-release-lenny.deb
Resolving apt.puppetlabs.com... 96.126.116.126, 2600:3c00::f03c:91ff:fe93:711a
Connecting to apt.puppetlabs.com|96.126.116.126|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 3396 (3.3K) [application/x-debian-package]
Saving to: `puppetlabs-release-lenny.deb'
100%[==================================================================================================>]
3,396 --.-K/s in 0s
2012-10-12 02:12:18 (426 MB/s) - `puppetlabs-release-lenny.deb' saved
[3396/3396]
node001:~# dpkg -i puppetlabs-release-lenny.deb
Selecting previously deselected package puppetlabs-release.
(Reading database ... 21509 files and directories currently installed.)
Unpacking puppetlabs-release (from puppetlabs-release-lenny.deb) ...
Setting up puppetlabs-release (1.0-5) ...
node001:~# cat /etc/apt/sources.list.d/puppetlabs.list
# Puppetlabs products
deb http://apt.puppetlabs.com lenny main
deb-src http://apt.puppetlabs.com lenny main
# Puppetlabs devel (uncomment to activate)
# deb http://apt.puppetlabs.com lenny devel
# deb-src http://apt.puppetlabs.com lenny devel
node001:~# apt-get install puppet
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
puppet: Depends: puppet-common (= 2.7.19-1puppetlabs2) but it is not
going to be installed
E: Broken packages
node001:~# apt-get update
Hit http://debian.securedservers.com lenny Release.gpg
Hit http://apt.puppetlabs.com lenny Release.gpg
Ign http://apt.puppetlabs.com lenny/main Translation-en_US
Hit http://apt.puppetlabs.com lenny Release
Ign http://debian.securedservers.com lenny/main Translation-en_US
Ign http://apt.puppetlabs.com lenny/main Packages/DiffIndex
Ign http://apt.puppetlabs.com lenny/main Sources/DiffIndex
Hit http://debian.securedservers.com lenny Release
Hit http://apt.puppetlabs.com lenny/main Packages
Ign http://debian.securedservers.com lenny/main Packages/DiffIndex
Hit http://apt.puppetlabs.com lenny/main Sources
Ign http://debian.securedservers.com lenny/main Sources/DiffIndex
Hit http://debian.securedservers.com lenny/main Packages
Hit http://debian.securedservers.com lenny/main Sources
Reading package lists... Done
node001:~# apt-get install puppet
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
puppet: Depends: puppet-common (= 2.7.19-1puppetlabs2) but it is not
going to be installed
E: Broken packages
------------------------------------------------------------------------------

Any chances got puppet works in debian lenny ? Thanks in advance.

--
Best regards,
Phan Quoc Hien

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Felipe Salum at Oct 12, 2012 at 9:57 pm
    I just answered it in another thread :)

    Install the Lenny Backports Repository, install puppet from there to bring
    all dependencies and then install it again from puppetlabs. Lenny is a mess
    :)

    apt-get -t lenny-backports install -y puppet
    apt-get -t puppetlabs install -y puppet

    and the backports repo if you don't have:

    deb http://archive.debian.org/debian-backports lenny-backports main
    On Friday, October 12, 2012 6:48:28 AM UTC-7, Hien Phan wrote:

    Hello list,

    I try to install puppet agent on Debian Lenny. I got following error.
    Seems the repo is broken :

    -----------------------------------------------------------------------------------------------------------------------------------


    node001:~# wget http://apt.puppetlabs.com/puppetlabs-release-lenny.deb
    --2012-10-12<http://apt.puppetlabs.com/puppetlabs-release-lenny.deb--2012-10-12>02:12:12--
    http://apt.puppetlabs.com/puppetlabs-release-lenny.deb
    Resolving apt.puppetlabs.com... 96.126.116.126,
    2600:3c00::f03c:91ff:fe93:711a
    Connecting to apt.puppetlabs.com|96.126.116.126|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 3396 (3.3K) [application/x-debian-package]
    Saving to: `puppetlabs-release-lenny.deb'
    100%[==================================================================================================>]

    3,396 --.-K/s in 0s
    2012-10-12 02:12:18 (426 MB/s) - `puppetlabs-release-lenny.deb' saved
    [3396/3396]
    node001:~# dpkg -i puppetlabs-release-lenny.deb
    Selecting previously deselected package puppetlabs-release.
    (Reading database ... 21509 files and directories currently installed.)
    Unpacking puppetlabs-release (from puppetlabs-release-lenny.deb) ...
    Setting up puppetlabs-release (1.0-5) ...
    node001:~# cat /etc/apt/sources.list.d/puppetlabs.list
    # Puppetlabs products
    deb http://apt.puppetlabs.com lenny main
    deb-src http://apt.puppetlabs.com lenny main
    # Puppetlabs devel (uncomment to activate)
    # deb http://apt.puppetlabs.com lenny devel
    # deb-src http://apt.puppetlabs.com lenny devel
    node001:~# apt-get install puppet
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    The following packages have unmet dependencies:
    puppet: Depends: puppet-common (= 2.7.19-1puppetlabs2) but it is not
    going to be installed
    E: Broken packages
    node001:~# apt-get update
    Hit http://debian.securedservers.com lenny Release.gpg
    Hit http://apt.puppetlabs.com lenny Release.gpg
    Ign http://apt.puppetlabs.com lenny/main Translation-en_US
    Hit http://apt.puppetlabs.com lenny Release
    Ign http://debian.securedservers.com lenny/main Translation-en_US
    Ign http://apt.puppetlabs.com lenny/main Packages/DiffIndex
    Ign http://apt.puppetlabs.com lenny/main Sources/DiffIndex
    Hit http://debian.securedservers.com lenny Release
    Hit http://apt.puppetlabs.com lenny/main Packages
    Ign http://debian.securedservers.com lenny/main Packages/DiffIndex
    Hit http://apt.puppetlabs.com lenny/main Sources
    Ign http://debian.securedservers.com lenny/main Sources/DiffIndex
    Hit http://debian.securedservers.com lenny/main Packages
    Hit http://debian.securedservers.com lenny/main Sources
    Reading package lists... Done
    node001:~# apt-get install puppet
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    The following packages have unmet dependencies:
    puppet: Depends: puppet-common (= 2.7.19-1puppetlabs2) but it is not
    going to be installed
    E: Broken packages
    ------------------------------------------------------------------------------


    Any chances got puppet works in debian lenny ? Thanks in advance.

    --
    Best regards,
    Phan Quoc Hien
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/-9lA84pFTa0J.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedOct 12, '12 at 1:48p
activeOct 12, '12 at 9:57p
posts2
users2
websitepuppetlabs.com

2 users in discussion

Hien Phan: 1 post Felipe Salum: 1 post

People

Translate

site design / logo © 2022 Grokbase