FAQ
Hi guys.

I don't see the latest puppet 3.0 on the puppetlabs debian repository for
lenny and also the latest puppet dashboard.

Aren't you guys adding the new versions to the deprecated Debian Lenny
anymore ?

Can I grab the puppet 3.0 agent from squeeze to use on Lenny ?

Regards,
Felipe

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/uLwlJAd5VIIJ.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Matthaus Owens at Oct 9, 2012 at 8:54 pm
    Yes, the squeeze packages *should* work just fine on lenny. We aren't
    building new packages for lenny because, as you note, lenny went EOL
    in February.
    On Tue, Oct 9, 2012 at 11:29 AM, Felipe Salum wrote:
    Hi guys.

    I don't see the latest puppet 3.0 on the puppetlabs debian repository for
    lenny and also the latest puppet dashboard.

    Aren't you guys adding the new versions to the deprecated Debian Lenny
    anymore ?

    Can I grab the puppet 3.0 agent from squeeze to use on Lenny ?

    Regards,
    Felipe

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/uLwlJAd5VIIJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.


    --
    Matthaus Owens
    Release Manager, Puppet Labs

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Christian Page at Oct 12, 2012 at 6:38 pm
    Felipe,

    Perhaps you can answer a question for me, I am in a similar boat as you
    with having to continue to support Lenny after EOL. I am trying to install
    puppet but I have an unmet dependency of libaugeas0. It appears that only
    version 0.2.2-1 is in the backports repository on archive.debian.org, and
    puppet from apt.puppetlabs.com requires version 0.6.0. What did you have to
    do to get this dependency met?

    Thanks for your help,

    Christian
    On Tuesday, October 9, 2012 12:29:22 PM UTC-6, Felipe Salum wrote:

    Hi guys.

    I don't see the latest puppet 3.0 on the puppetlabs debian repository for
    lenny and also the latest puppet dashboard.

    Aren't you guys adding the new versions to the deprecated Debian Lenny
    anymore ?

    Can I grab the puppet 3.0 agent from squeeze to use on Lenny ?

    Regards,
    Felipe
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/_EVTTDOUqkYJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Felipe Salum at Oct 12, 2012 at 9:46 pm
    Hi Christian,

    My libaugeas0 is 0.7.2 from backports:
    http://archive.debian.org/debian-backports/pool/main/a/augeas/libaugeas0_0.7.2-1~bpo50+1_amd64.deb

    Install puppet from backports first so it will bring all the dependencies,
    then upgrade to puppet from puppetlabs. That is how I do on Lenny.

    apt-get -t lenny-backports install -y puppet
    apt-get -t puppetlabs install -y puppet

    Regards,
    Felipe
    On Friday, October 12, 2012 9:40:45 AM UTC-7, Christian Page wrote:

    Felipe,

    Perhaps you can answer a question for me, I am in a similar boat as you
    with having to continue to support Lenny after EOL. I am trying to install
    puppet but I have an unmet dependency of libaugeas0. It appears that only
    version 0.2.2-1 is in the backports repository on archive.debian.org, and
    puppet from apt.puppetlabs.com requires version 0.6.0. What did you have
    to do to get this dependency met?

    Thanks for your help,

    Christian
    On Tuesday, October 9, 2012 12:29:22 PM UTC-6, Felipe Salum wrote:

    Hi guys.

    I don't see the latest puppet 3.0 on the puppetlabs debian repository for
    lenny and also the latest puppet dashboard.

    Aren't you guys adding the new versions to the deprecated Debian Lenny
    anymore ?

    Can I grab the puppet 3.0 agent from squeeze to use on Lenny ?

    Regards,
    Felipe
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/q72d2w1UjaoJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Christian Page at Oct 12, 2012 at 10:31 pm
    Felipe,

    Thanks for the information, I will give this a shot!

    Cheers,
    Christian
    On Friday, October 12, 2012 3:46:18 PM UTC-6, Felipe Salum wrote:

    Hi Christian,

    My libaugeas0 is 0.7.2 from backports:
    http://archive.debian.org/debian-backports/pool/main/a/augeas/libaugeas0_0.7.2-1~bpo50+1_amd64.deb

    Install puppet from backports first so it will bring all the dependencies,
    then upgrade to puppet from puppetlabs. That is how I do on Lenny.

    apt-get -t lenny-backports install -y puppet
    apt-get -t puppetlabs install -y puppet

    Regards,
    Felipe
    On Friday, October 12, 2012 9:40:45 AM UTC-7, Christian Page wrote:

    Felipe,

    Perhaps you can answer a question for me, I am in a similar boat as you
    with having to continue to support Lenny after EOL. I am trying to install
    puppet but I have an unmet dependency of libaugeas0. It appears that only
    version 0.2.2-1 is in the backports repository on archive.debian.org,
    and puppet from apt.puppetlabs.com requires version 0.6.0. What did you
    have to do to get this dependency met?

    Thanks for your help,

    Christian
    On Tuesday, October 9, 2012 12:29:22 PM UTC-6, Felipe Salum wrote:

    Hi guys.

    I don't see the latest puppet 3.0 on the puppetlabs debian repository
    for lenny and also the latest puppet dashboard.

    Aren't you guys adding the new versions to the deprecated Debian Lenny
    anymore ?

    Can I grab the puppet 3.0 agent from squeeze to use on Lenny ?

    Regards,
    Felipe
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/QnBBgfqSY2kJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedOct 9, '12 at 7:24p
activeOct 12, '12 at 10:31p
posts5
users3
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase