FAQ
Hi,
I can't download file using: source => 'puppet:///modules/mymodule/myfile',

Got this error in puppet client:
err: /Stage[main]/Nginx/File[server_key]: Could not evaluate: Error 403 on
SERVER: Forbidden request: (HOSTNAME) access to
/file_metadata/modules/mymodule/myfile [find] authenticated at line 73
Could not retrieve file metadata for puppet:///modules/mymodule/myfile:
Error 403 on SERVER: Forbidden request:(HOSTNAME) access to
/file_metadata/modules/mymodule/myfile [find] authenticated at line 73 at
/etc/puppet/modules/nginx/manifests/init.pp:97


on puppet master I have:
err: /usr/lib/ruby/1.8/puppet/network/rest_authconfig.rb:51:in
`check_authorization'
/usr/lib/ruby/1.8/puppet/network/rest_authorization.rb:19:in
`check_authorization'
/usr/lib/ruby/1.8/puppet/network/http/handler.rb:66:in `process'
/usr/lib/ruby/1.8/puppet/network/http/webrick/rest.rb:24:in `service'
/usr/lib/ruby/1.8/webrick/httpserver.rb:104:in `service'
/usr/lib/ruby/1.8/webrick/httpserver.rb:65:in `run'
/usr/lib/ruby/1.8/puppet/network/http/webrick.rb:45:in `listen'
/usr/lib/ruby/1.8/webrick/server.rb:173:in `call'
/usr/lib/ruby/1.8/webrick/server.rb:173:in `start_thread'
/usr/lib/ruby/1.8/webrick/server.rb:162:in `start'
/usr/lib/ruby/1.8/webrick/server.rb:162:in `start_thread'
/usr/lib/ruby/1.8/webrick/server.rb:95:in `start'
/usr/lib/ruby/1.8/webrick/server.rb:92:in `each'
/usr/lib/ruby/1.8/webrick/server.rb:92:in `start'
/usr/lib/ruby/1.8/webrick/server.rb:23:in `start'
/usr/lib/ruby/1.8/webrick/server.rb:82:in `start'
/usr/lib/ruby/1.8/puppet/network/http/webrick.rb:42:in `listen'
/usr/lib/ruby/1.8/puppet/network/http/webrick.rb:41:in `initialize'
/usr/lib/ruby/1.8/puppet/network/http/webrick.rb:41:in `new'
/usr/lib/ruby/1.8/puppet/network/http/webrick.rb:41:in `listen'
/usr/lib/ruby/1.8/puppet/network/http/webrick.rb:38:in `synchronize'
/usr/lib/ruby/1.8/puppet/network/http/webrick.rb:38:in `listen'
/usr/lib/ruby/1.8/puppet/network/server.rb:126:in `listen'
/usr/lib/ruby/1.8/puppet/network/server.rb:141:in `start'
/usr/lib/ruby/1.8/puppet/daemon.rb:124:in `start'
/usr/lib/ruby/1.8/puppet/application/master.rb:202:in `main'
/usr/lib/ruby/1.8/puppet/application/master.rb:146:in `run_command'
/usr/lib/ruby/1.8/puppet/application.rb:309:in `run'
/usr/lib/ruby/1.8/puppet/application.rb:416:in `hook'
/usr/lib/ruby/1.8/puppet/application.rb:309:in `run'
/usr/lib/ruby/1.8/puppet/application.rb:407:in `exit_on_fail'
/usr/lib/ruby/1.8/puppet/application.rb:309:in `run'
/usr/lib/ruby/1.8/puppet/util/command_line.rb:69:in `execute'
/usr/bin/puppet:4
err: Forbidden request:(HOSTNAME) access to
/file_metadata/modules/mymodule/myfilet [find] authenticated at line 73
info: access[/]: defaulting to no access for (HOSTNAME)
warning: Denying access: Forbidden request: (HOSTNAME) access to
/report/(HOSTNAME) [save] authenticated at line 73

both client and master are at 2.7.19 version

any help, would be appreciated


--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/9OIFXWze2r4J.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Craig White at Oct 8, 2012 at 6:11 pm
    Seems like you need to edit auth.conf on your puppet server to allow access which is currently being denied. See the comments in the file (and the messages below) which should give you clues as to which rules need to be enabled.

    Craig
    On Oct 8, 2012, at 5:42 AM, Mantas Klasavičius wrote:

    Hi,
    I can't download file using: source => 'puppet:///modules/mymodule/myfile',

    Got this error in puppet client:
    err: /Stage[main]/Nginx/File[server_key]: Could not evaluate: Error 403 on SERVER: Forbidden request: (HOSTNAME) access to /file_metadata/modules/mymodule/myfile [find] authenticated at line 73 Could not retrieve file metadata for puppet:///modules/mymodule/myfile: Error 403 on SERVER: Forbidden request:(HOSTNAME) access to /file_metadata/modules/mymodule/myfile [find] authenticated at line 73 at /etc/puppet/modules/nginx/manifests/init.pp:97


    on puppet master I have:
    err: /usr/lib/ruby/1.8/puppet/network/rest_authconfig.rb:51:in `check_authorization'
    /usr/lib/ruby/1.8/puppet/network/rest_authorization.rb:19:in `check_authorization'
    /usr/lib/ruby/1.8/puppet/network/http/handler.rb:66:in `process'
    /usr/lib/ruby/1.8/puppet/network/http/webrick/rest.rb:24:in `service'
    /usr/lib/ruby/1.8/webrick/httpserver.rb:104:in `service'
    /usr/lib/ruby/1.8/webrick/httpserver.rb:65:in `run'
    /usr/lib/ruby/1.8/puppet/network/http/webrick.rb:45:in `listen'
    /usr/lib/ruby/1.8/webrick/server.rb:173:in `call'
    /usr/lib/ruby/1.8/webrick/server.rb:173:in `start_thread'
    /usr/lib/ruby/1.8/webrick/server.rb:162:in `start'
    /usr/lib/ruby/1.8/webrick/server.rb:162:in `start_thread'
    /usr/lib/ruby/1.8/webrick/server.rb:95:in `start'
    /usr/lib/ruby/1.8/webrick/server.rb:92:in `each'
    /usr/lib/ruby/1.8/webrick/server.rb:92:in `start'
    /usr/lib/ruby/1.8/webrick/server.rb:23:in `start'
    /usr/lib/ruby/1.8/webrick/server.rb:82:in `start'
    /usr/lib/ruby/1.8/puppet/network/http/webrick.rb:42:in `listen'
    /usr/lib/ruby/1.8/puppet/network/http/webrick.rb:41:in `initialize'
    /usr/lib/ruby/1.8/puppet/network/http/webrick.rb:41:in `new'
    /usr/lib/ruby/1.8/puppet/network/http/webrick.rb:41:in `listen'
    /usr/lib/ruby/1.8/puppet/network/http/webrick.rb:38:in `synchronize'
    /usr/lib/ruby/1.8/puppet/network/http/webrick.rb:38:in `listen'
    /usr/lib/ruby/1.8/puppet/network/server.rb:126:in `listen'
    /usr/lib/ruby/1.8/puppet/network/server.rb:141:in `start'
    /usr/lib/ruby/1.8/puppet/daemon.rb:124:in `start'
    /usr/lib/ruby/1.8/puppet/application/master.rb:202:in `main'
    /usr/lib/ruby/1.8/puppet/application/master.rb:146:in `run_command'
    /usr/lib/ruby/1.8/puppet/application.rb:309:in `run'
    /usr/lib/ruby/1.8/puppet/application.rb:416:in `hook'
    /usr/lib/ruby/1.8/puppet/application.rb:309:in `run'
    /usr/lib/ruby/1.8/puppet/application.rb:407:in `exit_on_fail'
    /usr/lib/ruby/1.8/puppet/application.rb:309:in `run'
    /usr/lib/ruby/1.8/puppet/util/command_line.rb:69:in `execute'
    /usr/bin/puppet:4
    err: Forbidden request:(HOSTNAME) access to /file_metadata/modules/mymodule/myfilet [find] authenticated at line 73
    info: access[/]: defaulting to no access for (HOSTNAME)
    warning: Denying access: Forbidden request: (HOSTNAME) access to /report/(HOSTNAME) [save] authenticated at line 73

    both client and master are at 2.7.19 version

    any help, would be appreciated



    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/9OIFXWze2r4J.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
    --
    Craig White ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ craig.white@ttiltd.com
    1.800.869.6908 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ www.ttiassessments.com

    Register Now!
    TTI Winners' Conference 2013
    January 20th - 22nd
    The Earlier You Register the More FREE Product You Receive
    Click here for more information!


    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Denmat at Oct 8, 2012 at 10:22 pm
    While Craig maybe right, are you sure it's not a typo? Are you trying to find a file in the mymodule module or in nginx module?

    Normally you would try to keep files required by a module in the module that calls them.

    Den
    On 09/10/2012, at 5:11, Craig White wrote:

    Seems like you need to edit auth.conf on your puppet server to allow access which is currently being denied. See the comments in the file (and the messages below) which should give you clues as to which rules need to be enabled.

    Craig
    On Oct 8, 2012, at 5:42 AM, Mantas Klasavičius wrote:

    Hi,
    I can't download file using: source => 'puppet:///modules/mymodule/myfile',

    Got this error in puppet client:
    err: /Stage[main]/Nginx/File[server_key]: Could not evaluate: Error 403 on SERVER: Forbidden request: (HOSTNAME) access to /file_metadata/modules/mymodule/myfile [find] authenticated at line 73 Could not retrieve file metadata for puppet:///modules/mymodule/myfile: Error 403 on SERVER: Forbidden request:(HOSTNAME) access to /file_metadata/modules/mymodule/myfile [find] authenticated at line 73 at /etc/puppet/modules/nginx/manifests/init.pp:97


    on puppet master I have:
    err: /usr/lib/ruby/1.8/puppet/network/rest_authconfig.rb:51:in `check_authorization'
    /usr/lib/ruby/1.8/puppet/network/rest_authorization.rb:19:in `check_authorization'
    /usr/lib/ruby/1.8/puppet/network/http/handler.rb:66:in `process'
    /usr/lib/ruby/1.8/puppet/network/http/webrick/rest.rb:24:in `service'
    /usr/lib/ruby/1.8/webrick/httpserver.rb:104:in `service'
    /usr/lib/ruby/1.8/webrick/httpserver.rb:65:in `run'
    /usr/lib/ruby/1.8/puppet/network/http/webrick.rb:45:in `listen'
    /usr/lib/ruby/1.8/webrick/server.rb:173:in `call'
    /usr/lib/ruby/1.8/webrick/server.rb:173:in `start_thread'
    /usr/lib/ruby/1.8/webrick/server.rb:162:in `start'
    /usr/lib/ruby/1.8/webrick/server.rb:162:in `start_thread'
    /usr/lib/ruby/1.8/webrick/server.rb:95:in `start'
    /usr/lib/ruby/1.8/webrick/server.rb:92:in `each'
    /usr/lib/ruby/1.8/webrick/server.rb:92:in `start'
    /usr/lib/ruby/1.8/webrick/server.rb:23:in `start'
    /usr/lib/ruby/1.8/webrick/server.rb:82:in `start'
    /usr/lib/ruby/1.8/puppet/network/http/webrick.rb:42:in `listen'
    /usr/lib/ruby/1.8/puppet/network/http/webrick.rb:41:in `initialize'
    /usr/lib/ruby/1.8/puppet/network/http/webrick.rb:41:in `new'
    /usr/lib/ruby/1.8/puppet/network/http/webrick.rb:41:in `listen'
    /usr/lib/ruby/1.8/puppet/network/http/webrick.rb:38:in `synchronize'
    /usr/lib/ruby/1.8/puppet/network/http/webrick.rb:38:in `listen'
    /usr/lib/ruby/1.8/puppet/network/server.rb:126:in `listen'
    /usr/lib/ruby/1.8/puppet/network/server.rb:141:in `start'
    /usr/lib/ruby/1.8/puppet/daemon.rb:124:in `start'
    /usr/lib/ruby/1.8/puppet/application/master.rb:202:in `main'
    /usr/lib/ruby/1.8/puppet/application/master.rb:146:in `run_command'
    /usr/lib/ruby/1.8/puppet/application.rb:309:in `run'
    /usr/lib/ruby/1.8/puppet/application.rb:416:in `hook'
    /usr/lib/ruby/1.8/puppet/application.rb:309:in `run'
    /usr/lib/ruby/1.8/puppet/application.rb:407:in `exit_on_fail'
    /usr/lib/ruby/1.8/puppet/application.rb:309:in `run'
    /usr/lib/ruby/1.8/puppet/util/command_line.rb:69:in `execute'
    /usr/bin/puppet:4
    err: Forbidden request:(HOSTNAME) access to /file_metadata/modules/mymodule/myfilet [find] authenticated at line 73
    info: access[/]: defaulting to no access for (HOSTNAME)
    warning: Denying access: Forbidden request: (HOSTNAME) access to /report/(HOSTNAME) [save] authenticated at line 73

    both client and master are at 2.7.19 version

    any help, would be appreciated



    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/9OIFXWze2r4J.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
    --
    Craig White ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ craig.white@ttiltd.com
    1.800.869.6908 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ www.ttiassessments.com

    Register Now!
    TTI Winners' Conference 2013
    January 20th - 22nd
    The Earlier You Register the More FREE Product You Receive
    Click here for more information!


    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedOct 8, '12 at 3:19p
activeOct 8, '12 at 10:22p
posts3
users3
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase