FAQ
Good day

I seem to have a problem whereby, I get the following message when I do
a puppet run.

Warning: Unable to fetch my node definition, but the agent run will
continue:
Warning: Could not intern from pson: source '"#<Puppet::Node:0x7f' not
in PSON!

I did google and I came across this for the second error message.

http://projects.puppetlabs.com/issues/3160#note-7

I did make the mistake of first upgrading the client to version 3 on one
of my test hosts. But then after seeing the above message, I upgraded
the puppet master.
But the above error message is still present.

If someone could shed some light, it would gratefully be appreciated.

Kind regards
Brent Clark

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Henrik Lindberg at Oct 5, 2012 at 1:30 am

    On 2012-03-10 20:29, Brent Clark wrote:
    Good day

    I seem to have a problem whereby, I get the following message when I do
    a puppet run.

    Warning: Unable to fetch my node definition, but the agent run will
    continue:
    Warning: Could not intern from pson: source '"#<Puppet::Node:0x7f' not
    in PSON!

    I did google and I came across this for the second error message.

    http://projects.puppetlabs.com/issues/3160#note-7

    I did make the mistake of first upgrading the client to version 3 on one
    of my test hosts. But then after seeing the above message, I upgraded
    the puppet master.
    But the above error message is still present.

    If someone could shed some light, it would gratefully be appreciated.

    Kind regards
    Brent Clark
    A wild guess here - the client is in broken state. Did you try
    downgrading the client, make a run and then upgrade it.

    What did you upgrade from?

    Regards
    - henrik

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedOct 3, '12 at 6:29p
activeOct 5, '12 at 1:30a
posts2
users2
websitepuppetlabs.com

2 users in discussion

Henrik Lindberg: 1 post Brent Clark: 1 post

People

Translate

site design / logo © 2022 Grokbase