FAQ
After upgrading to Puppet 3.0.0 it seems that puppet doc is no longer
producing documentation from my modules / manifests.
I have a setup with two environments in
/etc/puppet/environments/[production, testing], and I'm running the
following command to generate the docs:

puppet doc --all --mode rdoc --environment production --outputdir doc

After running this it creates the 'doc' directory but there are no files in
it.
The same command was working OK on 2.7.19.

Has anything changed in the required format of doc comments in the
manifests?

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/_wWW_iC720cJ.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Jeff McCune at Oct 4, 2012 at 8:01 pm

    On Wed, Oct 3, 2012 at 6:31 AM, Hugh Cole-Baker wrote:
    After upgrading to Puppet 3.0.0 it seems that puppet doc is no longer
    producing documentation from my modules / manifests.
    I have a setup with two environments in
    /etc/puppet/environments/[production, testing], and I'm running the
    following command to generate the docs:

    puppet doc --all --mode rdoc --environment production --outputdir doc

    After running this it creates the 'doc' directory but there are no files in
    it.
    The same command was working OK on 2.7.19.

    Has anything changed in the required format of doc comments in the
    manifests?
    This is likely a bug. Could you please file an issue at
    http://projects.puppetlabs.com/projects/puppet describing the problem
    and snippets of commands showing how to reproduce the issue? If you
    follow up to this conversation with the ticket number, I'll start
    watching the ticket and work to reproduce the issue. With some effort
    we might be able to fix this for the 3.0.1 release.

    Thanks,
    -Jeff

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Hugh Cole-Baker at Oct 5, 2012 at 3:09 pm

    On Thursday, October 4, 2012 9:01:58 PM UTC+1, Jeff McCune wrote:
    On Wed, Oct 3, 2012 at 6:31 AM, Hugh Cole-Baker wrote:
    After upgrading to Puppet 3.0.0 it seems that puppet doc is no longer
    producing documentation from my modules / manifests.
    I have a setup with two environments in
    /etc/puppet/environments/[production, testing], and I'm running the
    following command to generate the docs:

    puppet doc --all --mode rdoc --environment production --outputdir doc

    After running this it creates the 'doc' directory but there are no files in
    it.
    The same command was working OK on 2.7.19.

    Has anything changed in the required format of doc comments in the
    manifests?
    This is likely a bug. Could you please file an issue at
    http://projects.puppetlabs.com/projects/puppet describing the problem
    and snippets of commands showing how to reproduce the issue? If you
    follow up to this conversation with the ticket number, I'll start
    watching the ticket and work to reproduce the issue. With some effort
    we might be able to fix this for the 3.0.1 release.

    Thanks,
    -Jeff
    Hi Jeff,

    I've created https://projects.puppetlabs.com/issues/16803 in the issue
    tracker.

    Thanks,
    Hugh

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/graOEp0CFq0J.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedOct 3, '12 at 1:33p
activeOct 5, '12 at 3:09p
posts3
users2
websitepuppetlabs.com

2 users in discussion

Hugh Cole-Baker: 2 posts Jeff McCune: 1 post

People

Translate

site design / logo © 2022 Grokbase