FAQ
I have a directive like this:

file { "/etc/sudoers":
owner => root,
group => root,
mode => 440,
source => "puppet:///modules/sudo/sudoers"
}

When i try to get this file on puppet agent, i see error:
err: /Stage[main]/Sudo/File[/etc/sudoers]: Could not evaluate: Error 403 on
SERVER: Forbidden request: puppet-client(192.168.200.170) access to
/file_metadata/modules/sudo/sudoers [find] authenticated at line 104 Could
not retrieve file metadata for puppet:///modules/sudo/sudoers: Error 403 on
SERVER: Forbidden request: puppet-client(192.168.200.170) access to
/file_metadata/modules/sudo/sudoers [find] authenticated at line 104 at
/etc/puppet/manifests/site.pp:12

In this error message i see a path "/file_metadata/modules/sudo/sudoers"!
Where i can find directory "file_metadata"?

I trying to change any of directives like vardir, modulepath and much more,
but not anyone of path not work as /file_metadata/ =(

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/lkTUkWCYUBEJ.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Cosmin-Viorel Ilie at Sep 14, 2012 at 2:24 pm
    I think you need to edit the auth.conf file to allow the puppet client
    access.
    On Friday, September 14, 2012 5:12:49 PM UTC+3, itJunky wrote:

    I have a directive like this:

    file { "/etc/sudoers":
    owner => root,
    group => root,
    mode => 440,
    source => "puppet:///modules/sudo/sudoers"
    }

    When i try to get this file on puppet agent, i see error:
    err: /Stage[main]/Sudo/File[/etc/sudoers]: Could not evaluate: Error 403
    on SERVER: Forbidden request: puppet-client(192.168.200.170) access to
    /file_metadata/modules/sudo/sudoers [find] authenticated at line 104 Could
    not retrieve file metadata for puppet:///modules/sudo/sudoers: Error 403 on
    SERVER: Forbidden request: puppet-client(192.168.200.170) access to
    /file_metadata/modules/sudo/sudoers [find] authenticated at line 104 at
    /etc/puppet/manifests/site.pp:12

    In this error message i see a path "/file_metadata/modules/sudo/sudoers"!
    Where i can find directory "file_metadata"?

    I trying to change any of directives like vardir, modulepath and much
    more, but not anyone of path not work as /file_metadata/ =(
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/Enei8SKQLjkJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • itJunky at Sep 17, 2012 at 7:42 am
    My main issue it Where i can find directory "file_metadata"?
    If I learn it, i can edit auth.conf to it directory.

    пятница, 14 сентября 2012 г., 18:24:43 UTC+4 пользователь Cosmin-Viorel
    Ilie написал:
    I think you need to edit the auth.conf file to allow the puppet client
    access.
    On Friday, September 14, 2012 5:12:49 PM UTC+3, itJunky wrote:

    I have a directive like this:

    file { "/etc/sudoers":
    owner => root,
    group => root,
    mode => 440,
    source => "puppet:///modules/sudo/sudoers"
    }

    When i try to get this file on puppet agent, i see error:
    err: /Stage[main]/Sudo/File[/etc/sudoers]: Could not evaluate: Error 403
    on SERVER: Forbidden request: puppet-client(192.168.200.170) access to
    /file_metadata/modules/sudo/sudoers [find] authenticated at line 104 Could
    not retrieve file metadata for puppet:///modules/sudo/sudoers: Error 403 on
    SERVER: Forbidden request: puppet-client(192.168.200.170) access to
    /file_metadata/modules/sudo/sudoers [find] authenticated at line 104 at
    /etc/puppet/manifests/site.pp:12

    In this error message i see a path "/file_metadata/modules/sudo/sudoers"!
    Where i can find directory "file_metadata"?

    I trying to change any of directives like vardir, modulepath and much
    more, but not anyone of path not work as /file_metadata/ =(
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/wp1XZ-ftqjMJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Martijn at Sep 17, 2012 at 11:56 am
    I don't know where your Puppet gets that path from. I've never seen it
    before. Maybe the setting is specified in your config file. Run the
    following commands as the user that your puppetmaster uses:

    puppet --configprint modulepath

    This command will show in which directories Puppet looks for your modules.
    In your case, I'd expect /file_metadata to be in that list.

    puppet --configprint config

    This command will show where Puppet's config file is stored. Open that file
    and you can set your prefered modulepath like this example:

    [main]
    modulepath =
    /etc/puppetlabs/puppet/modules:/opt/puppet/share/puppet/modules

    Run the first command again, and you should see that Puppet now uses the
    path you specified.

    Hope this helps,
    Martijn Heemels

    Op maandag 17 september 2012 09:42:12 UTC+2 schreef itJunky het volgende:
    My main issue it Where i can find directory "file_metadata"?
    If I learn it, i can edit auth.conf to it directory.

    пятница, 14 сентября 2012 г., 18:24:43 UTC+4 пользователь Cosmin-Viorel
    Ilie написал:
    I think you need to edit the auth.conf file to allow the puppet client
    access.
    On Friday, September 14, 2012 5:12:49 PM UTC+3, itJunky wrote:

    I have a directive like this:

    file { "/etc/sudoers":
    owner => root,
    group => root,
    mode => 440,
    source => "puppet:///modules/sudo/sudoers"
    }

    When i try to get this file on puppet agent, i see error:
    err: /Stage[main]/Sudo/File[/etc/sudoers]: Could not evaluate: Error 403
    on SERVER: Forbidden request: puppet-client(192.168.200.170) access to
    /file_metadata/modules/sudo/sudoers [find] authenticated at line 104 Could
    not retrieve file metadata for puppet:///modules/sudo/sudoers: Error 403 on
    SERVER: Forbidden request: puppet-client(192.168.200.170) access to
    /file_metadata/modules/sudo/sudoers [find] authenticated at line 104 at
    /etc/puppet/manifests/site.pp:12

    In this error message i see a path
    "/file_metadata/modules/sudo/sudoers"! Where i can find directory
    "file_metadata"?

    I trying to change any of directives like vardir, modulepath and much
    more, but not anyone of path not work as /file_metadata/ =(
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/KnWddP9IBtsJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • itJunky at Sep 18, 2012 at 1:02 pm
    I found this sh*t...

    test169 alp # grep -R dist /etc/puppet/
    /etc/puppet/modules/testing170/manifests/init.pp:
    "puppet:///dist/apache2/*//" ]
    /etc/puppet/modules/testing170/manifests/init.pp: } # real_path
    /usr/li/i/puppet/dist
    /etc/puppet/modules/testing170/manifests/init.pp:
    "puppet:///dist/sudo/sudoers" ]
    /etc/puppet/modules/testing170/manifests/init.pp: } # real_path
    /usr/lib/puppet/dist
    /etc/puppet/fileserver.conf:[dist]
    /etc/puppet/fileserver.conf: path /usr/lib/puppet/dist

    This path i have in only one config /etc/puppet/fileserver.conf.

    понедельник, 17 сентября 2012 г., 15:56:35 UTC+4 пользователь Martijn
    написал:
    I don't know where your Puppet gets that path from. I've never seen it
    before. Maybe the setting is specified in your config file. Run the
    following commands as the user that your puppetmaster uses:

    puppet --configprint modulepath

    This command will show in which directories Puppet looks for your modules.
    In your case, I'd expect /file_metadata to be in that list.

    puppet --configprint config

    This command will show where Puppet's config file is stored. Open that
    file and you can set your prefered modulepath like this example:

    [main]
    modulepath =
    /etc/puppetlabs/puppet/modules:/opt/puppet/share/puppet/modules

    Run the first command again, and you should see that Puppet now uses the
    path you specified.

    Hope this helps,
    Martijn Heemels

    Op maandag 17 september 2012 09:42:12 UTC+2 schreef itJunky het volgende:
    My main issue it Where i can find directory "file_metadata"?
    If I learn it, i can edit auth.conf to it directory.

    пятница, 14 сентября 2012 г., 18:24:43 UTC+4 пользователь Cosmin-Viorel
    Ilie написал:
    I think you need to edit the auth.conf file to allow the puppet client
    access.
    On Friday, September 14, 2012 5:12:49 PM UTC+3, itJunky wrote:

    I have a directive like this:

    file { "/etc/sudoers":
    owner => root,
    group => root,
    mode => 440,
    source => "puppet:///modules/sudo/sudoers"
    }

    When i try to get this file on puppet agent, i see error:
    err: /Stage[main]/Sudo/File[/etc/sudoers]: Could not evaluate: Error
    403 on SERVER: Forbidden request: puppet-client(192.168.200.170) access to
    /file_metadata/modules/sudo/sudoers [find] authenticated at line 104 Could
    not retrieve file metadata for puppet:///modules/sudo/sudoers: Error 403 on
    SERVER: Forbidden request: puppet-client(192.168.200.170) access to
    /file_metadata/modules/sudo/sudoers [find] authenticated at line 104 at
    /etc/puppet/manifests/site.pp:12

    In this error message i see a path
    "/file_metadata/modules/sudo/sudoers"! Where i can find directory
    "file_metadata"?

    I trying to change any of directives like vardir, modulepath and much
    more, but not anyone of path not work as /file_metadata/ =(
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/ssrORpstAsgJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedSep 14, '12 at 2:14p
activeSep 18, '12 at 1:02p
posts5
users3
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase