I have a pretty straightforward puppet.conf file on my agents. I'm trying
to use the logdest directive to get puppet to write it's own logs. But
I've tried this every which way and I can't seem to get puppet agent to do
anything but write into /var/log/syslog. Anyone else struggling with this

I'm running v2.7.11 on Ubuntu 12.04 installed from Ubuntu's repos.

logdir = /var/log/puppet
vardir = /var/lib/puppet
ssldir = /var/lib/puppet/ssl
rundir = /var/run/puppet
factpath = $vardir/lib/facter
templatedir = $confdir/templates
server = puppetd-qa-ops.2tor.net
autoflush = true
reportdir = /var/lib/puppet/reports

logdest = /var/log/puppet/agent.log
verbose = true
autoflush = true
report = true

# These are needed when the puppetmaster is run by passenger
# and can safely be removed if webrick is used.
ssl_client_header = SSL_CLIENT_S_DN
ssl_client_verify_header = SSL_CLIENT_VERIFY

Greg Damiani
DevOps Engineer - 2tor, Inc.
e: gdamiani@2tor.com
s: gregory.damiani
p: (646) 597-5506
c: (845) 548-6361

You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
postedSep 10, '12 at 5:10p
activeSep 10, '12 at 5:10p

1 user in discussion

Gregory Damiani: 1 post



site design / logo © 2022 Grokbase