FAQ
Hi guys, I'm trying to add a domain user to the local group Administrators
of windows, and I got this error:

err: /Stage[main]/Userwindows/Group[Administrators]/members: change from
AdministratorFarm AdminsDomain AdminsDomain Adminsbandrewsmruizmparra to
DOMAIN\user failed: Add
OLE error code:8007056B in Active Directory
A member could not be added to or removed from the local group
because the member does not exist.

HRESULT error code:0x80020009
Exception occurred.
debug: /Schedule[puppet]: Skipping device resources because running on a
host
debug: Finishing transaction 143308680


my manifest is this:

class userwindows()
{

group { 'Administrators':
members => 'DOMAIN\user',
}

}

where DOMAIN is my real domain name, and user is the real username...

Isn't a permission issue, when I tested adding manually the user to the
group works fine, is only with the puppet agent, by the way I'm running
puppet agent as administrator on that server, is a windows 2008 R2 server.
puppet agent version 2.7.14 , what am i doing wrong?

Any help will be appreciated, thank you in advance..

Best regards



Thank you in

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/6uDFYvpatrYJ.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Josh Cooper at Sep 10, 2012 at 4:24 pm
    Hi Marco,
    On Thu, Sep 6, 2012 at 6:36 AM, mparrad wrote:
    Hi guys, I'm trying to add a domain user to the local group Administrators
    of windows, and I got this error:

    err: /Stage[main]/Userwindows/Group[Administrators]/members: change from
    AdministratorFarm AdminsDomain AdminsDomain Adminsbandrewsmruizmparra to
    DOMAIN\user failed: Add
    OLE error code:8007056B in Active Directory
    A member could not be added to or removed from the local group because
    the member does not exist.

    HRESULT error code:0x80020009
    Exception occurred.
    debug: /Schedule[puppet]: Skipping device resources because running on a
    host
    debug: Finishing transaction 143308680


    my manifest is this:

    class userwindows()
    {

    group { 'Administrators':
    members => 'DOMAIN\user',
    }

    }

    where DOMAIN is my real domain name, and user is the real username...

    Isn't a permission issue, when I tested adding manually the user to the
    group works fine, is only with the puppet agent, by the way I'm running
    puppet agent as administrator on that server, is a windows 2008 R2 server.
    puppet agent version 2.7.14 , what am i doing wrong?

    Any help will be appreciated, thank you in advance..

    Best regards



    Thank you in

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/6uDFYvpatrYJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    This is related to the scheduled_task + domain user issue discussed
    here: https://groups.google.com/d/msg/puppet-users/pkePgl72M6M/qTO3atT-ouMJ
    Basically, when using WMI to lookup a user, we restrict the query to
    only local user accounts. The issue should be resolved as part of
    this: https://projects.puppetlabs.com/issues/15326

    Josh

    --
    Josh Cooper
    Developer, Puppet Labs

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Marco Parra D. at Sep 10, 2012 at 6:04 pm
    Hi Josh,
    On 10-09-2012 13:24, Josh Cooper wrote:
    Hi Marco,
    On Thu, Sep 6, 2012 at 6:36 AM, mparrad wrote:
    Hi guys, I'm trying to add a domain user to the local group Administrators
    of windows, and I got this error:

    err: /Stage[main]/Userwindows/Group[Administrators]/members: change from
    AdministratorFarm AdminsDomain AdminsDomain Adminsbandrewsmruizmparra to
    DOMAIN\user failed: Add
    OLE error code:8007056B in Active Directory
    A member could not be added to or removed from the local group because
    the member does not exist.

    HRESULT error code:0x80020009
    Exception occurred.
    debug: /Schedule[puppet]: Skipping device resources because running on a
    host
    debug: Finishing transaction 143308680


    my manifest is this:

    class userwindows()
    {

    group { 'Administrators':
    members => 'DOMAIN\user',
    }

    }

    where DOMAIN is my real domain name, and user is the real username...

    Isn't a permission issue, when I tested adding manually the user to the
    group works fine, is only with the puppet agent, by the way I'm running
    puppet agent as administrator on that server, is a windows 2008 R2 server.
    puppet agent version 2.7.14 , what am i doing wrong?

    Any help will be appreciated, thank you in advance..

    Best regards



    Thank you in

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/6uDFYvpatrYJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    I'll check those URLs, thank you for your answer Josh.

    Regards.
    This is related to the scheduled_task + domain user issue discussed
    here: https://groups.google.com/d/msg/puppet-users/pkePgl72M6M/qTO3atT-ouMJ
    Basically, when using WMI to lookup a user, we restrict the query to
    only local user accounts. The issue should be resolved as part of
    this: https://projects.puppetlabs.com/issues/15326

    Josh
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedSep 6, '12 at 1:37p
activeSep 10, '12 at 6:04p
posts3
users2
websitepuppetlabs.com

2 users in discussion

Marco Parra D.: 2 posts Josh Cooper: 1 post

People

Translate

site design / logo © 2022 Grokbase