FAQ
I'm trying to install solr using puppet. I have a module installing
tomcat. Now I'm trying to make another module that installs the solr
files. However, it's not copying the file. Any ideas what I'm doing wrong?

init.pp:
class solr {
file { '/opt/apache-tomcat/conf/Catalina/localhost':
source => 'puppet://modules/solr/solr.xml',
owner => 'tomcat',
group => 'tomcat',
mode => '311',
notify => Service['apache-tomcat'],
require => Package['apache-tomcat'],
}
}

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Ramin K at Aug 31, 2012 at 5:03 pm

    On 8/31/2012 7:18 AM, Bai Shen wrote:
    I'm trying to install solr using puppet. I have a module installing
    tomcat. Now I'm trying to make another module that installs the solr
    files. However, it's not copying the file. Any ideas what I'm doing wrong?

    init.pp:
    class solr {
    file { '/opt/apache-tomcat/conf/Catalina/localhost':
    source => 'puppet://modules/solr/solr.xml',
    owner => 'tomcat',
    group => 'tomcat',
    mode => '311',
    notify => Service['apache-tomcat'],
    require => Package['apache-tomcat'],
    }
    }
    You're missing ensure => present,

    Ramin

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Josh Cooper at Aug 31, 2012 at 6:23 pm

    On Fri, Aug 31, 2012 at 10:03 AM, Ramin K wrote:
    On 8/31/2012 7:18 AM, Bai Shen wrote:

    class solr {
    file { '/opt/apache-tomcat/conf/Catalina/localhost':
    source => 'puppet://modules/solr/solr.xml',
    That should be puppet:///modules/solr/solr.xml

    The way to think about puppet URI's is that the server host and port
    have been omitted, so there are two slashes for puppet://, and the URI
    path always has a leading slash, /modules/solr/solr.xml.

    See http://docs.puppetlabs.com/guides/file_serving.html

    --
    Josh Cooper
    Developer, Puppet Labs

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Bai Shen at Sep 4, 2012 at 3:21 pm
    Along with everything else that was pointed out, it turned out that I was
    using a node with the same name as my module, and therefore it was not
    being called.
    On Fri, Aug 31, 2012 at 2:23 PM, Josh Cooper wrote:
    On Fri, Aug 31, 2012 at 10:03 AM, Ramin K wrote:
    On 8/31/2012 7:18 AM, Bai Shen wrote:

    class solr {
    file { '/opt/apache-tomcat/conf/Catalina/localhost':
    source => 'puppet://modules/solr/solr.xml',
    That should be puppet:///modules/solr/solr.xml

    The way to think about puppet URI's is that the server host and port
    have been omitted, so there are two slashes for puppet://, and the URI
    path always has a leading slash, /modules/solr/solr.xml.

    See http://docs.puppetlabs.com/guides/file_serving.html

    --
    Josh Cooper
    Developer, Puppet Labs

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Dick Davies at Aug 31, 2012 at 5:04 pm
    isn't /opt/apache-tomcat/conf/Catalina/localhost a directory?
    You should still get output saying that on a puppet agent run though.
    On 31 August 2012 15:18, Bai Shen wrote:
    I'm trying to install solr using puppet. I have a module installing tomcat.
    Now I'm trying to make another module that installs the solr files.
    However, it's not copying the file. Any ideas what I'm doing wrong?

    init.pp:
    class solr {
    file { '/opt/apache-tomcat/conf/Catalina/localhost':
    source => 'puppet://modules/solr/solr.xml',
    owner => 'tomcat',
    group => 'tomcat',
    mode => '311',
    notify => Service['apache-tomcat'],
    require => Package['apache-tomcat'],
    }
    }

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedAug 31, '12 at 2:18p
activeSep 4, '12 at 3:21p
posts5
users4
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase