FAQ
Hi ,

I am trying to run puppet agent on windows. The Master is running on
Linux RHEL6.2.
Puppet Version : 2.7.12.

The puppet agent service starts properly and the client is able to
fetch its catalouge evry 30 mins. My requirement is to reduce this
interval to 2 mins. I tried changing the puppet.conf and restarted the
service on the agent (via start->services.msc). But somehow this does
not work for me. Still the client continues to fetch the catalogue at
default time(30 mins).

puppet.conf:

[agent]
server=puppet
pluginsync=true
report=true
runinterval=60
listen=true
certname=hawkeye.kodiak-internal.com
tags=job-schedular

please let me know if i am missing something.

regards
Neemish

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Josh Cooper at Aug 29, 2012 at 6:16 pm
    Hi Nimish,

    On Wed, Aug 29, 2012 at 10:52 AM, Nimish Vidyarthi
    wrote:
    I tried changing the puppet.conf
    Likely the file you are editing is not the same one that the service
    is looking at. Since the puppet agent service runs under the
    LocalSystem account, make sure you are editing the puppet.conf within
    the CommonAppData directory[1].

    Also follow these directions[2] for starting a command prompt (running
    as an administrator) and run `puppet agent --configprint runinterval`
    But somehow this does not work for me. Still the client continues to fetch the catalogue at
    default time(30 mins).

    puppet.conf:

    [agent]
    server=puppet
    pluginsync=true
    report=true
    runinterval=60
    This says to run every 60 seconds (not 2 mins). See[3]
    listen=true
    certname=hawkeye.kodiak-internal.com
    tags=job-schedular
    Josh

    [1] http://docs.puppetlabs.com/windows/installing.html#data-directory
    [2] http://docs.puppetlabs.com/windows/running.html#running-other-puppet-tasks
    [3] http://docs.puppetlabs.com/references/latest/configuration.html#runinterval
    --
    Josh Cooper
    Developer, Puppet Labs

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Nimish Vidyarthi at Aug 29, 2012 at 6:24 pm
    Yes i know i was trying out things to make it work. it does not work
    for 60 sec also.

    Ok i fetched the values from puppet config print all | find "config".
    the puppet.conf is showing to be correct( as the file i changed)

    But the runinterval is showing as 1800.

    I presume this is the issue , how can i change this time setting. and
    why it is not being read from puppet.conf

    Regards
    Neemish
    On Wed, Aug 29, 2012 at 11:16 AM, Josh Cooper wrote:
    Hi Nimish,

    On Wed, Aug 29, 2012 at 10:52 AM, Nimish Vidyarthi
    wrote:
    I tried changing the puppet.conf
    Likely the file you are editing is not the same one that the service
    is looking at. Since the puppet agent service runs under the
    LocalSystem account, make sure you are editing the puppet.conf within
    the CommonAppData directory[1].

    Also follow these directions[2] for starting a command prompt (running
    as an administrator) and run `puppet agent --configprint runinterval`
    But somehow this does not work for me. Still the client continues to fetch the catalogue at
    default time(30 mins).

    puppet.conf:

    [agent]
    server=puppet
    pluginsync=true
    report=true
    runinterval=60
    This says to run every 60 seconds (not 2 mins). See[3]
    listen=true
    certname=hawkeye.kodiak-internal.com
    tags=job-schedular
    Josh

    [1] http://docs.puppetlabs.com/windows/installing.html#data-directory
    [2] http://docs.puppetlabs.com/windows/running.html#running-other-puppet-tasks
    [3] http://docs.puppetlabs.com/references/latest/configuration.html#runinterval
    --
    Josh Cooper
    Developer, Puppet Labs

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedAug 29, '12 at 5:53p
activeAug 29, '12 at 6:24p
posts3
users2
websitepuppetlabs.com

2 users in discussion

Nimish Vidyarthi: 2 posts Josh Cooper: 1 post

People

Translate

site design / logo © 2022 Grokbase