FAQ
Greetings,

I'm testing Fedora 17 in our environment and have come across an interesting/annoying issue (that may or may not be isolated to my environment). Puppet runs fine on the test node but the reports are failing to import to dashboard and are showing up as background task failures with these details:


Importing report report-19732-119.yaml at 2012-08-17 09:01 EDT
undefined method `each' for nil:NilClass

Backtrace:
   /opt/puppet-dashboard/lib/puppet/report.rb:202:in `extended'
   /opt/puppet-dashboard/lib/puppet/report.rb:200:in `each'
   /opt/puppet-dashboard/lib/puppet/report.rb:200:in `extended'
   /opt/puppet-dashboard/lib/puppet/report.rb:114:in `extend'
   /opt/puppet-dashboard/lib/puppet/report.rb:114:in `extended'
   /opt/puppet-dashboard/app/models/report.rb:107:in `extend'
   /opt/puppet-dashboard/app/models/report.rb:107:in `create_from_yaml'
   /opt/puppet-dashboard/app/models/report.rb:86:in `create_from_yaml_file'


Anyone have any ideas why this might be occurring?

The Fedora 17 node and the puppetmaster are running puppet 2.7.18.
My puppetmaster has ruby enterprise 1.8.7 (patch level 334), the node has ruby 1.9.3p194.
Puppetmaster is hosting puppet-dashboard version 1.2.10. OS is Scientific Linux 5.5.


--
Peter M. Bukowinski
Sr. Systems Engineer
Janelia Farm Research Campus, HHMI

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Pmbuko at Aug 20, 2012 at 4:29 pm

    On Friday, August 17, 2012 9:51:06 AM UTC-4, pmbuko wrote:
    Greetings,

    I'm testing Fedora 17 in our environment and have come across an
    interesting/annoying issue (that may or may not be isolated to my
    environment). Puppet runs fine on the test node but the reports are failing
    to import to dashboard and are showing up as background task failures with
    these details:


    Importing report report-19732-119.yaml at 2012-08-17 09:01 EDT
    undefined method `each' for nil:NilClass

    Backtrace:
    /opt/puppet-dashboard/lib/puppet/report.rb:202:in `extended'
    /opt/puppet-dashboard/lib/puppet/report.rb:200:in `each'
    /opt/puppet-dashboard/lib/puppet/report.rb:200:in `extended'
    /opt/puppet-dashboard/lib/puppet/report.rb:114:in `extend'
    /opt/puppet-dashboard/lib/puppet/report.rb:114:in `extended'
    /opt/puppet-dashboard/app/models/report.rb:107:in `extend'
    /opt/puppet-dashboard/app/models/report.rb:107:in `create_from_yaml'
    /opt/puppet-dashboard/app/models/report.rb:86:in `create_from_yaml_file'


    Anyone have any ideas why this might be occurring?

    The Fedora 17 node and the puppetmaster are running puppet 2.7.18.
    My puppetmaster has ruby enterprise 1.8.7 (patch level 334), the node
    has ruby 1.9.3p194.
    Puppetmaster is hosting puppet-dashboard version 1.2.10. OS is Scientific
    Linux 5.5.

    I have a bit more data to add. In looking at the yaml files sent to my
    puppetmaster from the Fedora 17 host, I see that the resource statuses are
    coming in empty. For example, see this exerpt:

    file: 201208201315.yaml
    ----------
       puppet_version: 2.7.18
       report_format: 2
       resource_statuses:
         "Service[cups]": !ruby/object:Puppet::Resource::Status {}
         "File[/etc/cups/cupsd.conf]": !ruby/object:Puppet::Resource::Status {}

    Note the empty curly brackets.

    On a node that's working properly (Fedora 16), I see the following:

    file: 201208201333.yaml
    ----------
       puppet_version: 2.7.18
       report_format: 2
       resource_statuses:
         "File[/etc/cups/cupsd.conf]": !ruby/object:Puppet::Resource::Status
           change_count: 0
           changed: false
           evaluation_time: 0.016504
           events: []
           failed: false
           file: *id003
           line: 15
           out_of_sync: false
           out_of_sync_count: 0
           resource: "File[/etc/cups/cupsd.conf]"
           resource_type: File
           skipped: false
           tags:
             - file
             - class
             - cups
             - node
             - janelia.priv
           time: 2012-08-20 09:33:49.215995 -04:00
           title: /etc/cups/cupsd.conf
         "Service[cups]": !ruby/object:Puppet::Resource::Status
           change_count: 0
           changed: false
           evaluation_time: 0.092452
           events: []
           failed: false
           file: &id003 /etc/puppet/modules/cups/manifests/init.pp
           line: 22
           out_of_sync: false
           out_of_sync_count: 0
           resource: "Service[cups]"
           resource_type: Service
           skipped: false
           tags:
             - service
             - cups
             - class
             - node
             - janelia.priv
           time: 2012-08-20 09:33:49.233521 -04:00
           title: cups

    Also, note that I've verified that puppet has correctly applied the cups
    resources on the Fedora 17 node.



    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/2PgqtNlHpbUJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Tmv at Sep 8, 2012 at 8:48 pm
    Hi,

    Did you solve this issue? I'm experiencing the same problem on a Fedora 17
    box. The report it generates fails when imported to the dashboard:

    *Importing report report-20291-1.yaml* at *2012-09-08 20:37 UTC*undefined
    method `each' for nil:NilClass
    Backtrace
    /opt/puppet/share/puppet-dashboard/lib/puppet/report.rb:202:in `extended'/opt/puppet/share/puppet-dashboard/lib/puppet/report.rb:200:in
    `each'/opt/puppet/share/puppet-dashboard/lib/puppet/report.rb:200:in
    `extended'/opt/puppet/share/puppet-dashboard/lib/puppet/report.rb:114:in
    `extend'/opt/puppet/share/puppet-dashboard/lib/puppet/report.rb:114:in
    `extended'/opt/puppet/share/puppet-dashboard/app/models/report.rb:107:in
    `extend'/opt/puppet/share/puppet-dashboard/app/models/report.rb:107:in
    `create_from_yaml'/opt/puppet/share/puppet-dashboard/app/models/report.rb:86:in
    `create_from_yaml_file'
    I can't get this machine to display on the dashboard.

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/8qpqilzd7eMJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Peter Bukowinski at Sep 8, 2012 at 8:58 pm
    No, it's still unresolved. I only have one Fedora 17 client at the moment so it's not a big deal yet, but it's only a matter of time until I have more. I'll submit it as a bug so it gets some attention.

    -- Peter Bukowinski
    On Sep 8, 2012, at 4:47 PM, tmv wrote:


    Hi,

    Did you solve this issue? I'm experiencing the same problem on a Fedora 17 box. The report it generates fails when imported to the dashboard:

    Importing report report-20291-1.yaml at 2012-09-08 20:37 UTC
    undefined method `each' for nil:NilClass
    Backtrace
    /opt/puppet/share/puppet-dashboard/lib/puppet/report.rb:202:in `extended'
    /opt/puppet/share/puppet-dashboard/lib/puppet/report.rb:200:in `each'
    /opt/puppet/share/puppet-dashboard/lib/puppet/report.rb:200:in `extended'
    /opt/puppet/share/puppet-dashboard/lib/puppet/report.rb:114:in `extend'
    /opt/puppet/share/puppet-dashboard/lib/puppet/report.rb:114:in `extended'
    /opt/puppet/share/puppet-dashboard/app/models/report.rb:107:in `extend'
    /opt/puppet/share/puppet-dashboard/app/models/report.rb:107:in `create_from_yaml'
    /opt/puppet/share/puppet-dashboard/app/models/report.rb:86:in `create_from_yaml_file'

    I can't get this machine to display on the dashboard.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/8qpqilzd7eMJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Clayton Wight at May 30, 2013 at 1:50 pm
    Greetings,


    Has this issue been fix yet? I have about 300 fedora/ubuntu boxes that has
    this error when importing into dashboad.



    Clayton

    On Friday, August 17, 2012 7:51:06 AM UTC-6, pmbuko wrote:

    Greetings,

    I'm testing Fedora 17 in our environment and have come across an
    interesting/annoying issue (that may or may not be isolated to my
    environment). Puppet runs fine on the test node but the reports are failing
    to import to dashboard and are showing up as background task failures with
    these details:


    Importing report report-19732-119.yaml at 2012-08-17 09:01 EDT
    undefined method `each' for nil:NilClass

    Backtrace:
    /opt/puppet-dashboard/lib/puppet/report.rb:202:in `extended'
    /opt/puppet-dashboard/lib/puppet/report.rb:200:in `each'
    /opt/puppet-dashboard/lib/puppet/report.rb:200:in `extended'
    /opt/puppet-dashboard/lib/puppet/report.rb:114:in `extend'
    /opt/puppet-dashboard/lib/puppet/report.rb:114:in `extended'
    /opt/puppet-dashboard/app/models/report.rb:107:in `extend'
    /opt/puppet-dashboard/app/models/report.rb:107:in `create_from_yaml'
    /opt/puppet-dashboard/app/models/report.rb:86:in `create_from_yaml_file'


    Anyone have any ideas why this might be occurring?

    The Fedora 17 node and the puppetmaster are running puppet 2.7.18.
    My puppetmaster has ruby enterprise 1.8.7 (patch level 334), the node
    has ruby 1.9.3p194.
    Puppetmaster is hosting puppet-dashboard version 1.2.10. OS is Scientific
    Linux 5.5.


    --
    *Peter M. Bukowinski*
    Sr. Systems Engineer
    Janelia Farm Research Campus, HHMI
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Michael Stahnke at May 30, 2013 at 5:24 pm
    Fedora stock ships Puppet 2.7.18 and Ruby 1.9.3, which are not compatible.

    I suggest adding yum.puppetlabs.com and upgrading to Puppet 3.

    Either that or downgrade Ruby to 1.8.7.

    This is a known issue with Puppet 2.7 and Ruby 1.9.3.

    On Fri, Aug 17, 2012 at 6:51 AM, Peter Bukowinski wrote:
    Greetings,

    I'm testing Fedora 17 in our environment and have come across an
    interesting/annoying issue (that may or may not be isolated to my
    environment). Puppet runs fine on the test node but the reports are failing
    to import to dashboard and are showing up as background task failures with
    these details:


    Importing report report-19732-119.yaml at 2012-08-17 09:01 EDT
    undefined method `each' for nil:NilClass

    Backtrace:
    /opt/puppet-dashboard/lib/puppet/report.rb:202:in `extended'
    /opt/puppet-dashboard/lib/puppet/report.rb:200:in `each'
    /opt/puppet-dashboard/lib/puppet/report.rb:200:in `extended'
    /opt/puppet-dashboard/lib/puppet/report.rb:114:in `extend'
    /opt/puppet-dashboard/lib/puppet/report.rb:114:in `extended'
    /opt/puppet-dashboard/app/models/report.rb:107:in `extend'
    /opt/puppet-dashboard/app/models/report.rb:107:in `create_from_yaml'
    /opt/puppet-dashboard/app/models/report.rb:86:in `create_from_yaml_file'


    Anyone have any ideas why this might be occurring?

    The Fedora 17 node and the puppetmaster are running puppet 2.7.18.
    My puppetmaster has ruby enterprise 1.8.7 (patch level 334), the node has
    ruby 1.9.3p194.
    Puppetmaster is hosting puppet-dashboard version 1.2.10. OS is Scientific
    Linux 5.5.


    --
    Peter M. Bukowinski
    Sr. Systems Engineer
    Janelia Farm Research Campus, HHMI

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedAug 17, '12 at 1:51p
activeMay 30, '13 at 5:24p
posts6
users4
websitepuppetlabs.com

People

Translate

site design / logo © 2021 Grokbase