FAQ
Hi,

I've got an issue on installing Puppet Dashboard on Debian wheezy. When I
launch the db:migrate, I've got an error :
rake RAILS_ENV=production db:migrate --trace
NOTE: Gem.source_index is deprecated, use Specification. It will be
removed on or after 2011-11-01.
Gem.source_index called from
/usr/share/puppet-dashboard/vendor/rails/railties/lib/rails/gem_dependency.rb:21.
NOTE: Gem::SourceIndex#initialize is deprecated with no replacement. It
will be removed on or after 2011-11-01.
Gem::SourceIndex#initialize called from
/usr/share/puppet-dashboard/vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:100.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from
/usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from
/usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from
/usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from
/usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from
/usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from
/usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from
/usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from
/usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from
/usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from
/usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from
/usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from
/usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from
/usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from
/usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from
/usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from
/usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from
/usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from
/usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
rake aborted!
cannot load such file -- ftools
/usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
/usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
/usr/share/puppet-dashboard/vendor/rails/activesupport/lib/active_support/dependencies.rb:182:in
`block in require'
/usr/share/puppet-dashboard/vendor/rails/activesupport/lib/active_support/dependencies.rb:547:in
`new_constants_in'
/usr/share/puppet-dashboard/vendor/rails/activesupport/lib/active_support/dependencies.rb:182:in
`require'
/usr/share/puppet-dashboard/lib/tasks/plugins.rake:2:in `<top (required)>'
/usr/share/puppet-dashboard/vendor/rails/activesupport/lib/active_support/dependencies.rb:171:in
`load'
/usr/share/puppet-dashboard/vendor/rails/activesupport/lib/active_support/dependencies.rb:171:in
`block in load_with_new_constant_marking'
/usr/share/puppet-dashboard/vendor/rails/activesupport/lib/active_support/dependencies.rb:547:in
`new_constants_in'
/usr/share/puppet-dashboard/vendor/rails/activesupport/lib/active_support/dependencies.rb:171:in
`load_with_new_constant_marking'
/usr/share/puppet-dashboard/vendor/rails/railties/lib/tasks/rails.rb:14:in
`block in <top (required)>'
/usr/share/puppet-dashboard/vendor/rails/railties/lib/tasks/rails.rb:14:in
`each'
/usr/share/puppet-dashboard/vendor/rails/railties/lib/tasks/rails.rb:14:in
`<top (required)>'
/usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
/usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
/usr/share/puppet-dashboard/Rakefile:11:in `<top (required)>'
/usr/lib/ruby/vendor_ruby/rake/rake_module.rb:25:in `load'
/usr/lib/ruby/vendor_ruby/rake/rake_module.rb:25:in `load_rakefile'
/usr/lib/ruby/vendor_ruby/rake/application.rb:501:in `raw_load_rakefile'
/usr/lib/ruby/vendor_ruby/rake/application.rb:82:in `block in
load_rakefile'
/usr/lib/ruby/vendor_ruby/rake/application.rb:133:in
`standard_exception_handling'
/usr/lib/ruby/vendor_ruby/rake/application.rb:81:in `load_rakefile'
/usr/lib/ruby/vendor_ruby/rake/application.rb:65:in `block in run'
/usr/lib/ruby/vendor_ruby/rake/application.rb:133:in
`standard_exception_handling'
/usr/lib/ruby/vendor_ruby/rake/application.rb:63:in `run'
/usr/bin/rake:27:in `<main>'
It looks like a ruby version problem. On version 1.8 ftools exists, but not
on 1.9.1 (the standard on Debian wheezy). Does someone has an idea ? I've
searched on the web, but didn't find something relevant.

Thanks in advance

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/UjclRqRVMCcJ.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Juan Sierra Pons at Aug 8, 2012 at 4:53 pm
    Hi

    Yesterday I had the same problem. I solved it using this link:

    http://docs.puppetlabs.com/dashboard/manual/1.2/bootstrapping.html#installing-dependencies

    Install the RubyGems package system with the script provided.

    Hope it helps.

    Best regards
    On Aug 8, 2012 5:59 PM, "Deimos Fr" wrote:

    Hi,

    I've got an issue on installing Puppet Dashboard on Debian wheezy. When I
    launch the db:migrate, I've got an error :
    rake RAILS_ENV=production db:migrate --trace
    NOTE: Gem.source_index is deprecated, use Specification. It will be
    removed on or after 2011-11-01.
    Gem.source_index called from
    /usr/share/puppet-dashboard/vendor/rails/railties/lib/rails/gem_dependency.rb:21.
    NOTE: Gem::SourceIndex#initialize is deprecated with no replacement. It
    will be removed on or after 2011-11-01.
    Gem::SourceIndex#initialize called from
    /usr/share/puppet-dashboard/vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:100.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    rake aborted!
    cannot load such file -- ftools
    /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    /usr/share/puppet-dashboard/vendor/rails/activesupport/lib/active_support/dependencies.rb:182:in
    `block in require'
    /usr/share/puppet-dashboard/vendor/rails/activesupport/lib/active_support/dependencies.rb:547:in
    `new_constants_in'
    /usr/share/puppet-dashboard/vendor/rails/activesupport/lib/active_support/dependencies.rb:182:in
    `require'
    /usr/share/puppet-dashboard/lib/tasks/plugins.rake:2:in `<top (required)>'
    /usr/share/puppet-dashboard/vendor/rails/activesupport/lib/active_support/dependencies.rb:171:in
    `load'
    /usr/share/puppet-dashboard/vendor/rails/activesupport/lib/active_support/dependencies.rb:171:in
    `block in load_with_new_constant_marking'
    /usr/share/puppet-dashboard/vendor/rails/activesupport/lib/active_support/dependencies.rb:547:in
    `new_constants_in'
    /usr/share/puppet-dashboard/vendor/rails/activesupport/lib/active_support/dependencies.rb:171:in
    `load_with_new_constant_marking'
    /usr/share/puppet-dashboard/vendor/rails/railties/lib/tasks/rails.rb:14:in
    `block in <top (required)>'
    /usr/share/puppet-dashboard/vendor/rails/railties/lib/tasks/rails.rb:14:in
    `each'
    /usr/share/puppet-dashboard/vendor/rails/railties/lib/tasks/rails.rb:14:in
    `<top (required)>'
    /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    /usr/share/puppet-dashboard/Rakefile:11:in `<top (required)>'
    /usr/lib/ruby/vendor_ruby/rake/rake_module.rb:25:in `load'
    /usr/lib/ruby/vendor_ruby/rake/rake_module.rb:25:in `load_rakefile'
    /usr/lib/ruby/vendor_ruby/rake/application.rb:501:in `raw_load_rakefile'
    /usr/lib/ruby/vendor_ruby/rake/application.rb:82:in `block in
    load_rakefile'
    /usr/lib/ruby/vendor_ruby/rake/application.rb:133:in
    `standard_exception_handling'
    /usr/lib/ruby/vendor_ruby/rake/application.rb:81:in `load_rakefile'
    /usr/lib/ruby/vendor_ruby/rake/application.rb:65:in `block in run'
    /usr/lib/ruby/vendor_ruby/rake/application.rb:133:in
    `standard_exception_handling'
    /usr/lib/ruby/vendor_ruby/rake/application.rb:63:in `run'
    /usr/bin/rake:27:in `<main>'
    It looks like a ruby version problem. On version 1.8 ftools exists, but
    not on 1.9.1 (the standard on Debian wheezy). Does someone has an idea ?
    I've searched on the web, but didn't find something relevant.

    Thanks in advance

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/UjclRqRVMCcJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Deimos Fr at Aug 13, 2012 at 9:37 am
    Hi,

    Thanks for the answer, but still searching as I've got this error now :

    ruby setup.rb
    /usr/lib/ruby/1.9.1/rubygems.rb:206:in `try_activate': undefined method
    `find_by_path' for Gem::Specification:Class (NoMethodError)
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:59:in `rescue in
    require'
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:35:in `require'
    from
    /tmp/install_rubygems.wX4fqo5x78/rubygems-1.3.7/lib/rubygems/config_file.rb:50:in
    `<class:ConfigFile>'
    from
    /tmp/install_rubygems.wX4fqo5x78/rubygems-1.3.7/lib/rubygems/config_file.rb:28:in
    `<top (required)>'
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from
    /tmp/install_rubygems.wX4fqo5x78/rubygems-1.3.7/lib/rubygems/gem_runner.rb:8:in
    `<top (required)>'
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from setup.rb:25:in `<main>'

    Le mercredi 8 août 2012 18:53:30 UTC+2, Juan Sierra Pons a écrit :
    Hi

    Yesterday I had the same problem. I solved it using this link:


    http://docs.puppetlabs.com/dashboard/manual/1.2/bootstrapping.html#installing-dependencies

    Install the RubyGems package system with the script provided.

    Hope it helps.

    Best regards
    On Aug 8, 2012 5:59 PM, "Deimos Fr" <deim...@gmail.com <javascript:>>
    wrote:
    Hi,

    I've got an issue on installing Puppet Dashboard on Debian wheezy. When I
    launch the db:migrate, I've got an error :
    rake RAILS_ENV=production db:migrate --trace
    NOTE: Gem.source_index is deprecated, use Specification. It will be
    removed on or after 2011-11-01.
    Gem.source_index called from
    /usr/share/puppet-dashboard/vendor/rails/railties/lib/rails/gem_dependency.rb:21.
    NOTE: Gem::SourceIndex#initialize is deprecated with no replacement. It
    will be removed on or after 2011-11-01.
    Gem::SourceIndex#initialize called from
    /usr/share/puppet-dashboard/vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:100.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    rake aborted!
    cannot load such file -- ftools
    /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    /usr/share/puppet-dashboard/vendor/rails/activesupport/lib/active_support/dependencies.rb:182:in
    `block in require'
    /usr/share/puppet-dashboard/vendor/rails/activesupport/lib/active_support/dependencies.rb:547:in
    `new_constants_in'
    /usr/share/puppet-dashboard/vendor/rails/activesupport/lib/active_support/dependencies.rb:182:in
    `require'
    /usr/share/puppet-dashboard/lib/tasks/plugins.rake:2:in `<top
    (required)>'
    /usr/share/puppet-dashboard/vendor/rails/activesupport/lib/active_support/dependencies.rb:171:in
    `load'
    /usr/share/puppet-dashboard/vendor/rails/activesupport/lib/active_support/dependencies.rb:171:in
    `block in load_with_new_constant_marking'
    /usr/share/puppet-dashboard/vendor/rails/activesupport/lib/active_support/dependencies.rb:547:in
    `new_constants_in'
    /usr/share/puppet-dashboard/vendor/rails/activesupport/lib/active_support/dependencies.rb:171:in
    `load_with_new_constant_marking'
    /usr/share/puppet-dashboard/vendor/rails/railties/lib/tasks/rails.rb:14:in
    `block in <top (required)>'
    /usr/share/puppet-dashboard/vendor/rails/railties/lib/tasks/rails.rb:14:in
    `each'
    /usr/share/puppet-dashboard/vendor/rails/railties/lib/tasks/rails.rb:14:in
    `<top (required)>'
    /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    /usr/share/puppet-dashboard/Rakefile:11:in `<top (required)>'
    /usr/lib/ruby/vendor_ruby/rake/rake_module.rb:25:in `load'
    /usr/lib/ruby/vendor_ruby/rake/rake_module.rb:25:in `load_rakefile'
    /usr/lib/ruby/vendor_ruby/rake/application.rb:501:in `raw_load_rakefile'
    /usr/lib/ruby/vendor_ruby/rake/application.rb:82:in `block in
    load_rakefile'
    /usr/lib/ruby/vendor_ruby/rake/application.rb:133:in
    `standard_exception_handling'
    /usr/lib/ruby/vendor_ruby/rake/application.rb:81:in `load_rakefile'
    /usr/lib/ruby/vendor_ruby/rake/application.rb:65:in `block in run'
    /usr/lib/ruby/vendor_ruby/rake/application.rb:133:in
    `standard_exception_handling'
    /usr/lib/ruby/vendor_ruby/rake/application.rb:63:in `run'
    /usr/bin/rake:27:in `<main>'
    It looks like a ruby version problem. On version 1.8 ftools exists, but
    not on 1.9.1 (the standard on Debian wheezy). Does someone has an idea ?
    I've searched on the web, but didn't find something relevant.

    Thanks in advance

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/UjclRqRVMCcJ.
    To post to this group, send email to puppet...@googlegroups.com<javascript:>
    .
    To unsubscribe from this group, send email to
    puppet-users...@googlegroups.com <javascript:>.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/S0dIFMCurekJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Juan Sierra Pons at Aug 13, 2012 at 9:44 am

    2012/8/13 Deimos Fr <deimosfr@gmail.com>:
    Hi,

    Thanks for the answer, but still searching as I've got this error now :
    ruby setup.rb
    /usr/lib/ruby/1.9.1/rubygems.rb:206:in `try_activate': undefined method
    `find_by_path' for Gem::Specification:Class (NoMethodError)
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:59:in `rescue in
    require'
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:35:in `require'
    from
    /tmp/install_rubygems.wX4fqo5x78/rubygems-1.3.7/lib/rubygems/config_file.rb:50:in
    `<class:ConfigFile>'
    from
    /tmp/install_rubygems.wX4fqo5x78/rubygems-1.3.7/lib/rubygems/config_file.rb:28:in
    `<top (required)>'
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from
    /tmp/install_rubygems.wX4fqo5x78/rubygems-1.3.7/lib/rubygems/gem_runner.rb:8:in
    `<top (required)>'
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from setup.rb:25:in `<main>'


    Le mercredi 8 août 2012 18:53:30 UTC+2, Juan Sierra Pons a écrit :
    Hi

    Yesterday I had the same problem. I solved it using this link:


    http://docs.puppetlabs.com/dashboard/manual/1.2/bootstrapping.html#installing-dependencies

    Install the RubyGems package system with the script provided.

    Hope it helps.

    Best regards
    On Aug 8, 2012 5:59 PM, "Deimos Fr" wrote:

    Hi,

    I've got an issue on installing Puppet Dashboard on Debian wheezy. When I
    launch the db:migrate, I've got an error :
    rake RAILS_ENV=production db:migrate --trace
    NOTE: Gem.source_index is deprecated, use Specification. It will be
    removed on or after 2011-11-01.
    Gem.source_index called from
    /usr/share/puppet-dashboard/vendor/rails/railties/lib/rails/gem_dependency.rb:21.
    NOTE: Gem::SourceIndex#initialize is deprecated with no replacement. It
    will be removed on or after 2011-11-01.
    Gem::SourceIndex#initialize called from
    /usr/share/puppet-dashboard/vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:100.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    rake aborted!
    cannot load such file -- ftools
    /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'

    /usr/share/puppet-dashboard/vendor/rails/activesupport/lib/active_support/dependencies.rb:182:in
    `block in require'

    /usr/share/puppet-dashboard/vendor/rails/activesupport/lib/active_support/dependencies.rb:547:in
    `new_constants_in'

    /usr/share/puppet-dashboard/vendor/rails/activesupport/lib/active_support/dependencies.rb:182:in
    `require'
    /usr/share/puppet-dashboard/lib/tasks/plugins.rake:2:in `<top
    (required)>'

    /usr/share/puppet-dashboard/vendor/rails/activesupport/lib/active_support/dependencies.rb:171:in
    `load'

    /usr/share/puppet-dashboard/vendor/rails/activesupport/lib/active_support/dependencies.rb:171:in
    `block in load_with_new_constant_marking'

    /usr/share/puppet-dashboard/vendor/rails/activesupport/lib/active_support/dependencies.rb:547:in
    `new_constants_in'

    /usr/share/puppet-dashboard/vendor/rails/activesupport/lib/active_support/dependencies.rb:171:in
    `load_with_new_constant_marking'

    /usr/share/puppet-dashboard/vendor/rails/railties/lib/tasks/rails.rb:14:in
    `block in <top (required)>'

    /usr/share/puppet-dashboard/vendor/rails/railties/lib/tasks/rails.rb:14:in
    `each'

    /usr/share/puppet-dashboard/vendor/rails/railties/lib/tasks/rails.rb:14:in
    `<top (required)>'
    /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    /usr/share/puppet-dashboard/Rakefile:11:in `<top (required)>'
    /usr/lib/ruby/vendor_ruby/rake/rake_module.rb:25:in `load'
    /usr/lib/ruby/vendor_ruby/rake/rake_module.rb:25:in `load_rakefile'
    /usr/lib/ruby/vendor_ruby/rake/application.rb:501:in `raw_load_rakefile'
    /usr/lib/ruby/vendor_ruby/rake/application.rb:82:in `block in
    load_rakefile'
    /usr/lib/ruby/vendor_ruby/rake/application.rb:133:in
    `standard_exception_handling'
    /usr/lib/ruby/vendor_ruby/rake/application.rb:81:in `load_rakefile'
    /usr/lib/ruby/vendor_ruby/rake/application.rb:65:in `block in run'
    /usr/lib/ruby/vendor_ruby/rake/application.rb:133:in
    `standard_exception_handling'
    /usr/lib/ruby/vendor_ruby/rake/application.rb:63:in `run'
    /usr/bin/rake:27:in `<main>'

    It looks like a ruby version problem. On version 1.8 ftools exists, but
    not on 1.9.1 (the standard on Debian wheezy). Does someone has an idea ?
    I've searched on the web, but didn't find something relevant.

    Thanks in advance

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/UjclRqRVMCcJ.
    To post to this group, send email to puppet...@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users...@googlegroups.com.

    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/S0dIFMCurekJ.

    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    Hi

    Did you update the alternatives? as stated in point number 3 [1]

    update-alternatives --install /usr/bin/gem gem /usr/bin/gem1.8 1

    It seems you are still using the 1.9.1 ruby version instead of the
    1.8.1 recently installed

    [1] http://docs.puppetlabs.com/dashboard/manual/1.2/bootstrapping.html#installing-dependencies

    Best regards

    --------------------------------------------------------------------------------------
    Juan Sierra Pons juan@elsotanillo.net
    Linux User Registered: #257202 http://www.elsotanillo.net
    GPG key = 0xA110F4FE
    Key Fingerprint = DF53 7415 0936 244E 9B00 6E66 E934 3406 A110 F4FE
    --------------------------------------------------------------------------------------

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Deimos Fr at Aug 13, 2012 at 9:56 am

    I did as well. But I'm still blocked to the rubygem compilation :

    update-alternatives --install /usr/bin/gem gem /usr/bin/gem1.8 1
    ruby setup.rb
    /usr/lib/ruby/1.9.1/rubygems.rb:206:in `try_activate': undefined method
    `find_by_path' for Gem::Specification:Class (NoMethodError)
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:59:in `rescue in
    require'
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:35:in `require'
    from
    /tmp/install_rubygems.wX4fqo5x78/rubygems-1.3.7/lib/rubygems/config_file.rb:50:in
    `<class:ConfigFile>'
    from
    /tmp/install_rubygems.wX4fqo5x78/rubygems-1.3.7/lib/rubygems/config_file.rb:28:in
    `<top (required)>'
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from
    /tmp/install_rubygems.wX4fqo5x78/rubygems-1.3.7/lib/rubygems/gem_runner.rb:8:in
    `<top (required)>'
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from setup.rb:25:in `<main>'

    And of course, I've installed all required packages.

    Le lundi 13 août 2012 11:44:05 UTC+2, Juan Sierra Pons a écrit :
    2012/8/13 Deimos Fr <deim...@gmail.com <javascript:>>:
    Hi,

    Thanks for the answer, but still searching as I've got this error now :
    ruby setup.rb
    /usr/lib/ruby/1.9.1/rubygems.rb:206:in `try_activate': undefined method
    `find_by_path' for Gem::Specification:Class (NoMethodError)
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:59:in `rescue
    in
    require'
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:35:in `require'
    from
    /tmp/install_rubygems.wX4fqo5x78/rubygems-1.3.7/lib/rubygems/config_file.rb:50:in
    `<class:ConfigFile>'
    from
    /tmp/install_rubygems.wX4fqo5x78/rubygems-1.3.7/lib/rubygems/config_file.rb:28:in
    `<top (required)>'
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from
    /tmp/install_rubygems.wX4fqo5x78/rubygems-1.3.7/lib/rubygems/gem_runner.rb:8:in
    `<top (required)>'
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from setup.rb:25:in `<main>'


    Le mercredi 8 août 2012 18:53:30 UTC+2, Juan Sierra Pons a écrit :
    Hi

    Yesterday I had the same problem. I solved it using this link:

    http://docs.puppetlabs.com/dashboard/manual/1.2/bootstrapping.html#installing-dependencies
    Install the RubyGems package system with the script provided.

    Hope it helps.

    Best regards
    On Aug 8, 2012 5:59 PM, "Deimos Fr" wrote:

    Hi,

    I've got an issue on installing Puppet Dashboard on Debian wheezy.
    When I
    launch the db:migrate, I've got an error :
    rake RAILS_ENV=production db:migrate --trace
    NOTE: Gem.source_index is deprecated, use Specification. It will be
    removed on or after 2011-11-01.
    Gem.source_index called from
    /usr/share/puppet-dashboard/vendor/rails/railties/lib/rails/gem_dependency.rb:21.
    NOTE: Gem::SourceIndex#initialize is deprecated with no replacement.
    It
    will be removed on or after 2011-11-01.
    Gem::SourceIndex#initialize called from
    /usr/share/puppet-dashboard/vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:100.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    rake aborted!
    cannot load such file -- ftools
    /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    /usr/share/puppet-dashboard/vendor/rails/activesupport/lib/active_support/dependencies.rb:182:in
    `block in require'
    /usr/share/puppet-dashboard/vendor/rails/activesupport/lib/active_support/dependencies.rb:547:in
    `new_constants_in'
    /usr/share/puppet-dashboard/vendor/rails/activesupport/lib/active_support/dependencies.rb:182:in
    `require'
    /usr/share/puppet-dashboard/lib/tasks/plugins.rake:2:in `<top
    (required)>'
    /usr/share/puppet-dashboard/vendor/rails/activesupport/lib/active_support/dependencies.rb:171:in
    `load'
    /usr/share/puppet-dashboard/vendor/rails/activesupport/lib/active_support/dependencies.rb:171:in
    `block in load_with_new_constant_marking'
    /usr/share/puppet-dashboard/vendor/rails/activesupport/lib/active_support/dependencies.rb:547:in
    `new_constants_in'
    /usr/share/puppet-dashboard/vendor/rails/activesupport/lib/active_support/dependencies.rb:171:in
    `load_with_new_constant_marking'
    /usr/share/puppet-dashboard/vendor/rails/railties/lib/tasks/rails.rb:14:in
    `block in <top (required)>'
    /usr/share/puppet-dashboard/vendor/rails/railties/lib/tasks/rails.rb:14:in
    `each'
    /usr/share/puppet-dashboard/vendor/rails/railties/lib/tasks/rails.rb:14:in
    `<top (required)>'
    /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    /usr/share/puppet-dashboard/Rakefile:11:in `<top (required)>'
    /usr/lib/ruby/vendor_ruby/rake/rake_module.rb:25:in `load'
    /usr/lib/ruby/vendor_ruby/rake/rake_module.rb:25:in `load_rakefile'
    /usr/lib/ruby/vendor_ruby/rake/application.rb:501:in
    `raw_load_rakefile'
    /usr/lib/ruby/vendor_ruby/rake/application.rb:82:in `block in
    load_rakefile'
    /usr/lib/ruby/vendor_ruby/rake/application.rb:133:in
    `standard_exception_handling'
    /usr/lib/ruby/vendor_ruby/rake/application.rb:81:in `load_rakefile'
    /usr/lib/ruby/vendor_ruby/rake/application.rb:65:in `block in run'
    /usr/lib/ruby/vendor_ruby/rake/application.rb:133:in
    `standard_exception_handling'
    /usr/lib/ruby/vendor_ruby/rake/application.rb:63:in `run'
    /usr/bin/rake:27:in `<main>'

    It looks like a ruby version problem. On version 1.8 ftools exists,
    but
    not on 1.9.1 (the standard on Debian wheezy). Does someone has an idea
    ?
    I've searched on the web, but didn't find something relevant.

    Thanks in advance

    --
    You received this message because you are subscribed to the Google
    Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/UjclRqRVMCcJ.
    To post to this group, send email to puppet...@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users...@googlegroups.com.

    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/S0dIFMCurekJ.

    To post to this group, send email to puppet...@googlegroups.com<javascript:>.
    To unsubscribe from this group, send email to
    puppet-users...@googlegroups.com <javascript:>.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    Hi

    Did you update the alternatives? as stated in point number 3 [1]

    update-alternatives --install /usr/bin/gem gem /usr/bin/gem1.8 1

    It seems you are still using the 1.9.1 ruby version instead of the
    1.8.1 recently installed

    [1]
    http://docs.puppetlabs.com/dashboard/manual/1.2/bootstrapping.html#installing-dependencies

    Best regards

    --------------------------------------------------------------------------------------

    Juan Sierra Pons ju...@elsotanillo.net<javascript:>
    Linux User Registered: #257202 http://www.elsotanillo.net
    GPG key = 0xA110F4FE
    Key Fingerprint = DF53 7415 0936 244E 9B00 6E66 E934 3406 A110 F4FE
    --------------------------------------------------------------------------------------
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/6DBsxQNfPbYJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Deimos Fr at Aug 13, 2012 at 10:07 am
    Ok, works now. I has to did a sad thing. For unknow reasons, this doesn't
    work at all :
    update-alternatives --install /usr/bin/ruby ruby /usr/bin/ruby1.8 1
    update-alternatives --remove ruby /usr/bin/ruby
    So what I did is :
    rm /etc/alternatives/ruby
    ln -s /usr/bin/ruby1.8 /etc/alternatives/ruby
    Now it works :-) Using gems with the appropriate Ruby version is better :-)

    Thanks again

    Le lundi 13 août 2012 11:56:04 UTC+2, Deimos Fr a écrit :
    I did as well. But I'm still blocked to the rubygem compilation :
    update-alternatives --install /usr/bin/gem gem /usr/bin/gem1.8 1
    ruby setup.rb
    /usr/lib/ruby/1.9.1/rubygems.rb:206:in `try_activate': undefined method
    `find_by_path' for Gem::Specification:Class (NoMethodError)
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:59:in `rescue in
    require'
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:35:in `require'
    from
    /tmp/install_rubygems.wX4fqo5x78/rubygems-1.3.7/lib/rubygems/config_file.rb:50:in
    `<class:ConfigFile>'
    from
    /tmp/install_rubygems.wX4fqo5x78/rubygems-1.3.7/lib/rubygems/config_file.rb:28:in
    `<top (required)>'
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from
    /tmp/install_rubygems.wX4fqo5x78/rubygems-1.3.7/lib/rubygems/gem_runner.rb:8:in
    `<top (required)>'
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from setup.rb:25:in `<main>'

    And of course, I've installed all required packages.

    Le lundi 13 août 2012 11:44:05 UTC+2, Juan Sierra Pons a écrit :
    2012/8/13 Deimos Fr <deim...@gmail.com>:
    Hi,

    Thanks for the answer, but still searching as I've got this error now :
    ruby setup.rb
    /usr/lib/ruby/1.9.1/rubygems.rb:206:in `try_activate': undefined
    method
    `find_by_path' for Gem::Specification:Class (NoMethodError)
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:59:in `rescue
    in
    require'
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:35:in
    `require'
    from
    /tmp/install_rubygems.wX4fqo5x78/rubygems-1.3.7/lib/rubygems/config_file.rb:50:in
    `<class:ConfigFile>'
    from
    /tmp/install_rubygems.wX4fqo5x78/rubygems-1.3.7/lib/rubygems/config_file.rb:28:in
    `<top (required)>'
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in
    `require'
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in
    `require'
    from
    /tmp/install_rubygems.wX4fqo5x78/rubygems-1.3.7/lib/rubygems/gem_runner.rb:8:in
    `<top (required)>'
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in
    `require'
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in
    `require'
    from setup.rb:25:in `<main>'


    Le mercredi 8 août 2012 18:53:30 UTC+2, Juan Sierra Pons a écrit :
    Hi

    Yesterday I had the same problem. I solved it using this link:

    http://docs.puppetlabs.com/dashboard/manual/1.2/bootstrapping.html#installing-dependencies
    Install the RubyGems package system with the script provided.

    Hope it helps.

    Best regards
    On Aug 8, 2012 5:59 PM, "Deimos Fr" wrote:

    Hi,

    I've got an issue on installing Puppet Dashboard on Debian wheezy.
    When I
    launch the db:migrate, I've got an error :
    rake RAILS_ENV=production db:migrate --trace
    NOTE: Gem.source_index is deprecated, use Specification. It will be
    removed on or after 2011-11-01.
    Gem.source_index called from
    /usr/share/puppet-dashboard/vendor/rails/railties/lib/rails/gem_dependency.rb:21.
    NOTE: Gem::SourceIndex#initialize is deprecated with no replacement.
    It
    will be removed on or after 2011-11-01.
    Gem::SourceIndex#initialize called from
    /usr/share/puppet-dashboard/vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:100.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use
    Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/lib/ruby/1.9.1/rubygems/source_index.rb:91.
    rake aborted!
    cannot load such file -- ftools
    /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    /usr/share/puppet-dashboard/vendor/rails/activesupport/lib/active_support/dependencies.rb:182:in
    `block in require'
    /usr/share/puppet-dashboard/vendor/rails/activesupport/lib/active_support/dependencies.rb:547:in
    `new_constants_in'
    /usr/share/puppet-dashboard/vendor/rails/activesupport/lib/active_support/dependencies.rb:182:in
    `require'
    /usr/share/puppet-dashboard/lib/tasks/plugins.rake:2:in `<top
    (required)>'
    /usr/share/puppet-dashboard/vendor/rails/activesupport/lib/active_support/dependencies.rb:171:in
    `load'
    /usr/share/puppet-dashboard/vendor/rails/activesupport/lib/active_support/dependencies.rb:171:in
    `block in load_with_new_constant_marking'
    /usr/share/puppet-dashboard/vendor/rails/activesupport/lib/active_support/dependencies.rb:547:in
    `new_constants_in'
    /usr/share/puppet-dashboard/vendor/rails/activesupport/lib/active_support/dependencies.rb:171:in
    `load_with_new_constant_marking'
    /usr/share/puppet-dashboard/vendor/rails/railties/lib/tasks/rails.rb:14:in
    `block in <top (required)>'
    /usr/share/puppet-dashboard/vendor/rails/railties/lib/tasks/rails.rb:14:in
    `each'
    /usr/share/puppet-dashboard/vendor/rails/railties/lib/tasks/rails.rb:14:in
    `<top (required)>'
    /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    /usr/share/puppet-dashboard/Rakefile:11:in `<top (required)>'
    /usr/lib/ruby/vendor_ruby/rake/rake_module.rb:25:in `load'
    /usr/lib/ruby/vendor_ruby/rake/rake_module.rb:25:in `load_rakefile'
    /usr/lib/ruby/vendor_ruby/rake/application.rb:501:in
    `raw_load_rakefile'
    /usr/lib/ruby/vendor_ruby/rake/application.rb:82:in `block in
    load_rakefile'
    /usr/lib/ruby/vendor_ruby/rake/application.rb:133:in
    `standard_exception_handling'
    /usr/lib/ruby/vendor_ruby/rake/application.rb:81:in `load_rakefile'
    /usr/lib/ruby/vendor_ruby/rake/application.rb:65:in `block in run'
    /usr/lib/ruby/vendor_ruby/rake/application.rb:133:in
    `standard_exception_handling'
    /usr/lib/ruby/vendor_ruby/rake/application.rb:63:in `run'
    /usr/bin/rake:27:in `<main>'

    It looks like a ruby version problem. On version 1.8 ftools exists,
    but
    not on 1.9.1 (the standard on Debian wheezy). Does someone has an
    idea ?
    I've searched on the web, but didn't find something relevant.

    Thanks in advance

    --
    You received this message because you are subscribed to the Google
    Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/UjclRqRVMCcJ.
    To post to this group, send email to puppet...@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users...@googlegroups.com.

    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/S0dIFMCurekJ.

    To post to this group, send email to puppet...@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users...@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    Hi

    Did you update the alternatives? as stated in point number 3 [1]

    update-alternatives --install /usr/bin/gem gem /usr/bin/gem1.8 1

    It seems you are still using the 1.9.1 ruby version instead of the
    1.8.1 recently installed

    [1]
    http://docs.puppetlabs.com/dashboard/manual/1.2/bootstrapping.html#installing-dependencies

    Best regards

    --------------------------------------------------------------------------------------

    Juan Sierra Pons ju...@elsotanillo.net
    Linux User Registered: #257202 http://www.elsotanillo.net
    GPG key = 0xA110F4FE
    Key Fingerprint = DF53 7415 0936 244E 9B00 6E66 E934 3406 A110 F4FE
    --------------------------------------------------------------------------------------
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/Q-Yyl_UD-KsJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedAug 8, '12 at 4:29p
activeAug 13, '12 at 10:07a
posts6
users2
websitepuppetlabs.com

2 users in discussion

Deimos Fr: 4 posts Juan Sierra Pons: 2 posts

People

Translate

site design / logo © 2022 Grokbase