FAQ
This is my first time to install puppet and it's quite frustrating to me.
  If anyone can help me out that would be great.

My current installation failed with the below error:

** /opt/puppet/bin/erb -T - './erb/send_cert_request.rb.erb' >
'/opt/puppet/bin/send_cert_request.rb'
** chmod a+rx /opt/puppet/bin/send_cert_request.rb
** /opt/puppet/bin/erb -T - './erb/receive_signed_cert.rb.erb' >
'/opt/puppet/bin/receive_signed_cert.rb'
** chmod a+rx /opt/puppet/bin/receive_signed_cert.rb
** chown -R pe-puppet:pe-puppet /var/opt/lib/pe-puppet/
/var/opt/lib/pe-puppetmaster/ /var/log/pe-puppet/
** /opt/puppet/bin/puppet agent --configprint certname --color=false
hadoop53
** printf "START=true\nDAEMON_OPTS=''\n" > /etc/default/pe-puppet-agent
** service pe-puppet-agent start
pe-puppet-agent: unrecognized service

I am stuck now and have no idea what to do.

Here are the steps I took to see this error.
1. First time install. Got host not found error. I am using a simple host
name hadoop53.
2. I added hadoop53 to my /etc/hosts file.
3. Uninstall mysql-server because I don't know the random password
generated by puppet
4. uninstall puppet
5. Reinstall and got the error

Thanks!

Chang

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/oA4OLYmdV3kJ.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Christopher Wood at Aug 7, 2012 at 12:34 am
    Any particular reason that "apt-get install puppet" doesn't work for you?
    On Mon, Aug 06, 2012 at 05:21:25PM -0700, alike wrote:
    This is my first time to install puppet and it's quite frustrating to me.
    If anyone can help me out that would be great.
    My current installation failed with the below error:
    ** /opt/puppet/bin/erb -T - './erb/send_cert_request.rb.erb' >
    '/opt/puppet/bin/send_cert_request.rb'
    ** chmod a+rx /opt/puppet/bin/send_cert_request.rb
    ** /opt/puppet/bin/erb -T - './erb/receive_signed_cert.rb.erb' >
    '/opt/puppet/bin/receive_signed_cert.rb'
    ** chmod a+rx /opt/puppet/bin/receive_signed_cert.rb
    ** chown -R pe-puppet:pe-puppet /var/opt/lib/pe-puppet/
    /var/opt/lib/pe-puppetmaster/ /var/log/pe-puppet/
    ** /opt/puppet/bin/puppet agent --configprint certname --color=false
    hadoop53
    ** printf "START=true\nDAEMON_OPTS=''\n" > /etc/default/pe-puppet-agent
    ** service pe-puppet-agent start
    pe-puppet-agent: unrecognized service
    I am stuck now and have no idea what to do.
    Here are the steps I took to see this error.
    1. First time install.  Got host not found error.  I am using a simple
    host name hadoop53.
    2. I added hadoop53 to my /etc/hosts file.
    3. Uninstall mysql-server because I don't know the random password
    generated by puppet
    4. uninstall puppet
    5. Reinstall and got the error
    Thanks!
    Chang

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    [1]https://groups.google.com/d/msg/puppet-users/-/oA4OLYmdV3kJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.

    References

    Visible links
    1. https://groups.google.com/d/msg/puppet-users/-/oA4OLYmdV3kJ

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Michael Stahnke at Aug 7, 2012 at 12:56 am

    On Mon, Aug 6, 2012 at 5:21 PM, alike wrote:
    This is my first time to install puppet and it's quite frustrating to me.
    If anyone can help me out that would be great.

    My current installation failed with the below error:

    ** /opt/puppet/bin/erb -T - './erb/send_cert_request.rb.erb' >
    '/opt/puppet/bin/send_cert_request.rb'
    ** chmod a+rx /opt/puppet/bin/send_cert_request.rb
    ** /opt/puppet/bin/erb -T - './erb/receive_signed_cert.rb.erb' >
    '/opt/puppet/bin/receive_signed_cert.rb'
    ** chmod a+rx /opt/puppet/bin/receive_signed_cert.rb
    ** chown -R pe-puppet:pe-puppet /var/opt/lib/pe-puppet/
    /var/opt/lib/pe-puppetmaster/ /var/log/pe-puppet/
    ** /opt/puppet/bin/puppet agent --configprint certname --color=false
    hadoop53
    ** printf "START=true\nDAEMON_OPTS=''\n" > /etc/default/pe-puppet-agent
    ** service pe-puppet-agent start
    pe-puppet-agent: unrecognized service

    I am stuck now and have no idea what to do.

    Here are the steps I took to see this error.
    1. First time install. Got host not found error. I am using a simple host
    name hadoop53.
    2. I added hadoop53 to my /etc/hosts file.
    3. Uninstall mysql-server because I don't know the random password generated
    by puppet
    4. uninstall puppet
    5. Reinstall and got the error

    Thanks!

    Chang
    There is a pe-users list that might be more helpful for this specific
    issue. Feel free to post your issue there as well.
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/oA4OLYmdV3kJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Denmat at Aug 7, 2012 at 8:22 am
    Hi,

    When you do the install, there should be an answers file generated in the current directory. Check that for passwords (from memory).

    In your current case I would uninstall, remove mysqld-server, remove /var/lib/mysql and /opt/puppet and /etc/puppetlabs (this is assuming nothing else used the db).

    Then try your install again. Check the answers file.

    See how that goes.
    Den


    On 07/08/2012, at 10:56, Michael Stahnke wrote:
    On Mon, Aug 6, 2012 at 5:21 PM, alike wrote:
    This is my first time to install puppet and it's quite frustrating to me.
    If anyone can help me out that would be great.

    My current installation failed with the below error:

    ** /opt/puppet/bin/erb -T - './erb/send_cert_request.rb.erb' >
    '/opt/puppet/bin/send_cert_request.rb'
    ** chmod a+rx /opt/puppet/bin/send_cert_request.rb
    ** /opt/puppet/bin/erb -T - './erb/receive_signed_cert.rb.erb' >
    '/opt/puppet/bin/receive_signed_cert.rb'
    ** chmod a+rx /opt/puppet/bin/receive_signed_cert.rb
    ** chown -R pe-puppet:pe-puppet /var/opt/lib/pe-puppet/
    /var/opt/lib/pe-puppetmaster/ /var/log/pe-puppet/
    ** /opt/puppet/bin/puppet agent --configprint certname --color=false
    hadoop53
    ** printf "START=true\nDAEMON_OPTS=''\n" > /etc/default/pe-puppet-agent
    ** service pe-puppet-agent start
    pe-puppet-agent: unrecognized service

    I am stuck now and have no idea what to do.

    Here are the steps I took to see this error.
    1. First time install. Got host not found error. I am using a simple host
    name hadoop53.
    2. I added hadoop53 to my /etc/hosts file.
    3. Uninstall mysql-server because I don't know the random password generated
    by puppet
    4. uninstall puppet
    5. Reinstall and got the error

    Thanks!

    Chang
    There is a pe-users list that might be more helpful for this specific
    issue. Feel free to post your issue there as well.
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/oA4OLYmdV3kJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Alike at Aug 7, 2012 at 5:13 pm
    I consulted finch & justinstoller from IRC and they said something evil
    with dpkg and my machine is in a state of un-reinstallable. justinstoller
    suggested me restore my machine to the previous state, but I don't have a
    easy way to do that.

    So I am giving up now and trying "apt-get install puppet". The
    installation is much easier and it's working now.
    On Tuesday, August 7, 2012 1:23:06 AM UTC-7, denmat wrote:

    Hi,

    When you do the install, there should be an answers file generated in the
    current directory. Check that for passwords (from memory).

    In your current case I would uninstall, remove mysqld-server, remove
    /var/lib/mysql and /opt/puppet and /etc/puppetlabs (this is assuming
    nothing else used the db).

    Then try your install again. Check the answers file.

    See how that goes.
    Den


    On 07/08/2012, at 10:56, Michael Stahnke wrote:
    On Mon, Aug 6, 2012 at 5:21 PM, alike wrote:
    This is my first time to install puppet and it's quite frustrating to
    me.
    If anyone can help me out that would be great.

    My current installation failed with the below error:

    ** /opt/puppet/bin/erb -T - './erb/send_cert_request.rb.erb' >
    '/opt/puppet/bin/send_cert_request.rb'
    ** chmod a+rx /opt/puppet/bin/send_cert_request.rb
    ** /opt/puppet/bin/erb -T - './erb/receive_signed_cert.rb.erb' >
    '/opt/puppet/bin/receive_signed_cert.rb'
    ** chmod a+rx /opt/puppet/bin/receive_signed_cert.rb
    ** chown -R pe-puppet:pe-puppet /var/opt/lib/pe-puppet/
    /var/opt/lib/pe-puppetmaster/ /var/log/pe-puppet/
    ** /opt/puppet/bin/puppet agent --configprint certname --color=false
    hadoop53
    ** printf "START=true\nDAEMON_OPTS=''\n" > /etc/default/pe-puppet-agent
    ** service pe-puppet-agent start
    pe-puppet-agent: unrecognized service

    I am stuck now and have no idea what to do.

    Here are the steps I took to see this error.
    1. First time install. Got host not found error. I am using a simple
    host
    name hadoop53.
    2. I added hadoop53 to my /etc/hosts file.
    3. Uninstall mysql-server because I don't know the random password
    generated
    by puppet
    4. uninstall puppet
    5. Reinstall and got the error

    Thanks!

    Chang
    There is a pe-users list that might be more helpful for this specific
    issue. Feel free to post your issue there as well.
    --
    You received this message because you are subscribed to the Google
    Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/oA4OLYmdV3kJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google
    Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/FP6Xk9fNVCEJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Martin Narkiewicz at Jun 18, 2013 at 8:31 pm
    I know this post is 1 year old, but I was having a problem just like this
    and this was the first result on google. I'm just posting my experience in
    hopes that it might help someone else.
    I am using puppet enterprise 2.8.1 and installing the agents on a mix of
    Ubuntu 10.04 & 12.04 machines. The agents needed to be re-installed and
    whenever I tried I kept getting this "pe-puppet-agent: unrecognized
    service" message in the install log.

    My solution to re-installing the agent is to run the
    'puppet-enterprise-uninstaller' script and run 'apt-get purge
    pe-puppet-agent' a combination of the allowed me to install the puppet
    agent successfully. However, the order of the two actions was different
    between the two versions. In 10.04, the purge command needs to be run
    before the uninstall script, otherwise it will fail.
    On Monday, August 6, 2012 5:21:25 PM UTC-7, alike wrote:

    This is my first time to install puppet and it's quite frustrating to me.
    If anyone can help me out that would be great.

    My current installation failed with the below error:

    ** /opt/puppet/bin/erb -T - './erb/send_cert_request.rb.erb' >
    '/opt/puppet/bin/send_cert_request.rb'
    ** chmod a+rx /opt/puppet/bin/send_cert_request.rb
    ** /opt/puppet/bin/erb -T - './erb/receive_signed_cert.rb.erb' >
    '/opt/puppet/bin/receive_signed_cert.rb'
    ** chmod a+rx /opt/puppet/bin/receive_signed_cert.rb
    ** chown -R pe-puppet:pe-puppet /var/opt/lib/pe-puppet/
    /var/opt/lib/pe-puppetmaster/ /var/log/pe-puppet/
    ** /opt/puppet/bin/puppet agent --configprint certname --color=false
    hadoop53
    ** printf "START=true\nDAEMON_OPTS=''\n" > /etc/default/pe-puppet-agent
    ** service pe-puppet-agent start
    pe-puppet-agent: unrecognized service

    I am stuck now and have no idea what to do.

    Here are the steps I took to see this error.
    1. First time install. Got host not found error. I am using a simple
    host name hadoop53.
    2. I added hadoop53 to my /etc/hosts file.
    3. Uninstall mysql-server because I don't know the random password
    generated by puppet
    4. uninstall puppet
    5. Reinstall and got the error

    Thanks!

    Chang
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedAug 7, '12 at 12:22a
activeJun 18, '13 at 8:31p
posts6
users5
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase