FAQ
There's been at least one other report of something like this, but that was
a little while ago and changes to the module have been made recently.

Basically I can create a database, set the root password, but not do
anything else:

node 'puppetclient.tomtest.com' {
class { 'mysql::server':
service_name => 'mysql',
config_hash => { 'root_password' => 'mymysqlrootpass', },
package_name => 'MySQL-server',
}
mysql::db { 'testdb':
user => 'testdb',
password => 'testdb',
host => 'localhost',
grant => ['ALL'],
}
}

Installs mysql, correctly sets the root password then stops. The DB is
never created and no errors are issued.

Can anyone help me debug this issue?, I've not gone down the custom
resources route myself yet, so I'm not sure how I go about working out
where the problem is.

Cheers,

Tom.

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/O-N6g5jMiRgJ.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Walter Heck at Jul 31, 2012 at 2:00 pm
    In these cases you would start by checking a run of puppetd -t -d -v
    to see if it shows up there. If not, then look carefully if the
    resource is really included on that node. If it is, there should be a
    hint on what is happening..
    On Tue, Jul 31, 2012 at 9:19 PM, tom s wrote:
    There's been at least one other report of something like this, but that was
    a little while ago and changes to the module have been made recently.

    Basically I can create a database, set the root password, but not do
    anything else:

    node 'puppetclient.tomtest.com' {
    class { 'mysql::server':
    service_name => 'mysql',
    config_hash => { 'root_password' => 'mymysqlrootpass', },
    package_name => 'MySQL-server',
    }
    mysql::db { 'testdb':
    user => 'testdb',
    password => 'testdb',
    host => 'localhost',
    grant => ['ALL'],
    }
    }

    Installs mysql, correctly sets the root password then stops. The DB is
    never created and no errors are issued.

    Can anyone help me debug this issue?, I've not gone down the custom
    resources route myself yet, so I'm not sure how I go about working out where
    the problem is.

    Cheers,

    Tom.

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/O-N6g5jMiRgJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.


    --
    Walter Heck

    --
    Check out my startup: Puppet training and consulting @ http://www.olindata.com
    Follow @olindata on Twitter and/or 'Like' our Facebook page at
    http://www.facebook.com/olindata

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Tom s at Jul 31, 2012 at 2:26 pm
    hmmm, it shows up, but doesn't seem to do anything about it:

    debug:
    /Stage[main]//Node[puppetclient.tomtest.com]/Mysql::Db[testdb]/Database_grant[testdb@localhost/testdb]/require:
    requires Database_user[testdb@localhost]
    debug: /Stage[main]/Mysql::Server/Service[mysqld]/require: requires
    Package[mysql-server]
    debug: /Stage[main]/Mysql::Config/File[/etc/mysql]/notify: subscribes to
    Exec[mysqld-restart]
    debug: /Stage[main]/Mysql::Config/File[/etc/mysql/conf.d]/notify:
    subscribes to Exec[mysqld-restart]
    debug: /Stage[main]/Mysql::Config/File[/etc/my.cnf]/notify: subscribes to
    Exec[mysqld-restart]
    debug: /Stage[main]/Mysql::Config/Exec[set_mysql_rootpw]/require: requires
    File[/etc/mysql/conf.d]
    debug: /Stage[main]/Mysql::Config/Exec[set_mysql_rootpw]/notify: subscribes
    to Exec[mysqld-restart]
    debug: /Stage[main]/Mysql::Config/File[/root/.my.cnf]/require: requires
    Exec[set_mysql_rootpw]
    debug: /Stage[main]/Mysql::Config/File[/root/.my.cnf]/notify: subscribes to
    Exec[mysqld-restart]
    debug:
    /Stage[main]//Node[puppetclient.tomtest.com]/Mysql::Db[testdb]/Database[testdb]/require:
    requires Class[Mysql::Server]
    debug: /Stage[main]/Mysql::Server/before: requires Class[Mysql::Config]
    debug:
    /Stage[main]//Node[puppetclient.tomtest.com]/Mysql::Db[testdb]/Database_user[testdb@localhost]/require:
    requires Database[testdb]
    debug: /Stage[main]/Mysql::Config/File[/etc/mysql/conf.d]: Autorequiring
    File[/etc/mysql]
    debug: Service[mysqld](provider=redhat): Executing 'ps -ef'
    debug: Service[mysqld](provider=redhat): PID is 6770
    debug: Puppet::Type::Service::ProviderRedhat: Executing '/sbin/chkconfig
    mysql'
    debug: Exec[set_mysql_rootpw](provider=posix): Executing check 'mysqladmin
    -u root -pmymysqlrootpass status > /dev/null'
    debug: Executing 'mysqladmin -u root -pmymysqlrootpass status > /dev/null'

    On Tuesday, 31 July 2012 14:59:53 UTC+1, Walter Heck wrote:

    In these cases you would start by checking a run of puppetd -t -d -v
    to see if it shows up there. If not, then look carefully if the
    resource is really included on that node. If it is, there should be a
    hint on what is happening..
    On Tue, Jul 31, 2012 at 9:19 PM, tom s <> wrote:
    There's been at least one other report of something like this, but that was
    a little while ago and changes to the module have been made recently.

    Basically I can create a database, set the root password, but not do
    anything else:

    node 'puppetclient.tomtest.com' {
    class { 'mysql::server':
    service_name => 'mysql',
    config_hash => { 'root_password' => 'mymysqlrootpass', },
    package_name => 'MySQL-server',
    }
    mysql::db { 'testdb':
    user => 'testdb',
    password => 'testdb',
    host => 'localhost',
    grant => ['ALL'],
    }
    }

    Installs mysql, correctly sets the root password then stops. The DB is
    never created and no errors are issued.

    Can anyone help me debug this issue?, I've not gone down the custom
    resources route myself yet, so I'm not sure how I go about working out where
    the problem is.

    Cheers,

    Tom.

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/O-N6g5jMiRgJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.


    --
    Walter Heck

    --
    Check out my startup: Puppet training and consulting @
    http://www.olindata.com
    Follow @olindata on Twitter and/or 'Like' our Facebook page at
    http://www.facebook.com/olindata
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/ou9dzjMZbV0J.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Tom s at Aug 2, 2012 at 9:32 am
    Ok, so it turns out this module has a dependancy on pluginsync being on.


    On Tuesday, 31 July 2012 15:26:49 UTC+1, tom s wrote:

    hmmm, it shows up, but doesn't seem to do anything about it:

    debug: /Stage[main]//Node[puppetclient.tomtest.com]/Mysql::Db[testdb]/Database_grant[testdb@localhost/testdb]/require:
    requires Database_user[testdb@localhost]
    debug: /Stage[main]/Mysql::Server/Service[mysqld]/require: requires
    Package[mysql-server]
    debug: /Stage[main]/Mysql::Config/File[/etc/mysql]/notify: subscribes to
    Exec[mysqld-restart]
    debug: /Stage[main]/Mysql::Config/File[/etc/mysql/conf.d]/notify:
    subscribes to Exec[mysqld-restart]
    debug: /Stage[main]/Mysql::Config/File[/etc/my.cnf]/notify: subscribes to
    Exec[mysqld-restart]
    debug: /Stage[main]/Mysql::Config/Exec[set_mysql_rootpw]/require: requires
    File[/etc/mysql/conf.d]
    debug: /Stage[main]/Mysql::Config/Exec[set_mysql_rootpw]/notify:
    subscribes to Exec[mysqld-restart]
    debug: /Stage[main]/Mysql::Config/File[/root/.my.cnf]/require: requires
    Exec[set_mysql_rootpw]
    debug: /Stage[main]/Mysql::Config/File[/root/.my.cnf]/notify: subscribes
    to Exec[mysqld-restart]
    debug: /Stage[main]//Node[puppetclient.tomtest.com]/Mysql::Db[testdb]/Database[testdb]/require:
    requires Class[Mysql::Server]
    debug: /Stage[main]/Mysql::Server/before: requires Class[Mysql::Config]
    debug: /Stage[main]//Node[puppetclient.tomtest.com]/Mysql::Db[testdb]/Database_user[testdb@localhost]/require:
    requires Database[testdb]
    debug: /Stage[main]/Mysql::Config/File[/etc/mysql/conf.d]: Autorequiring
    File[/etc/mysql]
    debug: Service[mysqld](provider=redhat): Executing 'ps -ef'
    debug: Service[mysqld](provider=redhat): PID is 6770
    debug: Puppet::Type::Service::ProviderRedhat: Executing '/sbin/chkconfig
    mysql'
    debug: Exec[set_mysql_rootpw](provider=posix): Executing check 'mysqladmin
    -u root -pmymysqlrootpass status > /dev/null'
    debug: Executing 'mysqladmin -u root -pmymysqlrootpass status > /dev/null'

    On Tuesday, 31 July 2012 14:59:53 UTC+1, Walter Heck wrote:

    In these cases you would start by checking a run of puppetd -t -d -v
    to see if it shows up there. If not, then look carefully if the
    resource is really included on that node. If it is, there should be a
    hint on what is happening..
    On Tue, Jul 31, 2012 at 9:19 PM, tom s <> wrote:
    There's been at least one other report of something like this, but that was
    a little while ago and changes to the module have been made recently.

    Basically I can create a database, set the root password, but not do
    anything else:

    node 'puppetclient.tomtest.com' {
    class { 'mysql::server':
    service_name => 'mysql',
    config_hash => { 'root_password' => 'mymysqlrootpass', },
    package_name => 'MySQL-server',
    }
    mysql::db { 'testdb':
    user => 'testdb',
    password => 'testdb',
    host => 'localhost',
    grant => ['ALL'],
    }
    }

    Installs mysql, correctly sets the root password then stops. The DB is
    never created and no errors are issued.

    Can anyone help me debug this issue?, I've not gone down the custom
    resources route myself yet, so I'm not sure how I go about working out where
    the problem is.

    Cheers,

    Tom.

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/O-N6g5jMiRgJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.


    --
    Walter Heck

    --
    Check out my startup: Puppet training and consulting @
    http://www.olindata.com
    Follow @olindata on Twitter and/or 'Like' our Facebook page at
    http://www.facebook.com/olindata
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/GN2Neaickm4J.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedJul 31, '12 at 1:33p
activeAug 2, '12 at 9:32a
posts4
users2
websitepuppetlabs.com

2 users in discussion

Tom s: 3 posts Walter Heck: 1 post

People

Translate

site design / logo © 2022 Grokbase