FAQ
1.2.10 is a maintenance release of Puppet Dashboard.
It includes contributions from Will Hopper and Moses Mendoza.
Thanks to Aaron Patterson for the security content in commit
e17269f.

This release is available for download at:
https://downloads.puppetlabs.com/dashboard/puppet-dashboard-1.2.10.tar.gz

Debian packages are available at
https://apt.puppetlabs.com

RPM packages are available at
https://yum.puppetlabs.com

See the Verifying Puppet Download section at:
http://projects.puppetlabs.com/projects/puppet/wiki/Downloading_Puppet

Please report feedback via the Puppet Labs Redmine site, using an
affected version of 1.2.10:
http://projects.puppetlabs.com/projects/dashboard

Documentation is available at:
http://docs.puppetlabs.com/dashboard/index.html

1.2.10 Security Fixes/Highlights
===
*Patch puppet-dashboard for CVE-2012-2660

This commit adds a patch to actionpack to address
CVE-2012-2660, unsafe query generation vulnerability. This
patch is taken from Aaron Patterson on the rails security list:
https://groups.google.com/forum/?fromgroups#!topic/rubyonrails-security/8SA-M3as7A8

*(#11849) Add rake task to install cron job to clean up database reports

This commit adds a rake task to install a monthly cron
job to clean up old database reports, as suggested in official
Puppet Labs documentation. This allows users to easily install
the optional cron job while not risking undesired data loss for
those who do not wish to have the job installed by default.

1.2.10 Changelog
===
Will Hopper (1)
5de691f (#11849) Add rake task to install cron job to clean up database reports
Moses Mendoza (3)
07c75a3 cleanup on puppet-dashboard spec file
b70344d create certs directory with installation
d9b7eeb Install a default settings.yml file with database.yml
e17269f Patch puppet-dashboard for CVE-2012-2660

Search Discussions

  • Stefan Heijmans at Jul 13, 2012 at 6:50 am
    Op vrijdag 13 juli 2012 02:05:29 UTC+2 schreef Jo het volgende:
    Where is the documentation for this feature? How do I invoke it?

    The maintaining page still just says to create a cron job.
    the maintaining page also mentions;

    If you run ‘rake reports:prune’ without any arguments, it will display
    further usage instructions.

    Just installed in in our sandbox and it shows;

    rake reports:prune
    EXAMPLE:
    # Prune records upto 1 month old:
    rake reports:prune upto=1 unit=mon

    UNITS:
    Valid units of time are: mon,yr,day,min,wk,hr

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/-2VsNh8ZsS0J.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Stefan Heijmans at Jul 13, 2012 at 7:05 am
    Op vrijdag 13 juli 2012 08:50:07 UTC+2 schreef Stefan Heijmans het
    volgende:

    the maintaining page also mentions;

    If you run ‘rake reports:prune’ without any arguments, it will display
    further usage instructions.
    my bad, that's not the one.

    # rake cron:cleanup
    ln -sf
    /usr/share/puppet-dashboard/examples/puppet-dashboard.cleanup_reports.cron
    /etc/cron.monthly/puppet-dashboard.cleanup_reports.cron
    It creates a link from the source to the /etc/cron.monthly.
    One issue, if you have puppet-dashboard installed in a different location
    the source is not there.
    # more /etc/cron.monthly/puppet-dashboard.cleanup_reports.cron
    /etc/cron.monthly/puppet-dashboard.cleanup_reports.cron: No such file or
    directory
    # ll
    /usr/share/puppet-dashboard/examples/puppet-dashboard.cleanup_reports.cron
    ls:
    /usr/share/puppet-dashboard/examples/puppet-dashboard.cleanup_reports.cron:
    No such file or directory
    # ll /opt/puppet-dashboard/examples/puppet-dashboard.cleanup_reports.cron
    -rwxr-xr-x 1 puppet-dashboard puppet-dashboard 597 Jul 12 20:50
    /opt/puppet-dashboard/examples/puppet-dashboard.cleanup_reports.cron
    #

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/NfidyMAbUNsJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Antidot SAS at Jul 13, 2012 at 9:16 am
    HI I trying to upgrade for debian squeeze:

    (Reading database ... 66401 files and directories currently installed.)
    Preparing to replace librack-ruby 1.1.0-4 (using
    .../librack-ruby_1.1.0-4_all.deb) ...
    Unpacking replacement librack-ruby ...
    Setting up puppet-dashboard (1.2.10-1puppetlabs1) ...
    Starting Puppet Dashboard:Not starting Puppet Dashboard, disabled via
    /etc/default/puppet-dashboard ... (warning).
    .
    Starting Puppet Dashboard Workers:NOTE: Gem.source_index is deprecated, use
    Specification. It will be removed on or after 2011-11-01.
    Gem.source_index called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/gem_dependency.rb:21.
    NOTE: Gem::SourceIndex#initialize is deprecated with no replacement. It
    will be removed on or after 2011-11-01.
    Gem::SourceIndex#initialize called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:100.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
    It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/local/lib/site_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
    It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/local/lib/site_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
    It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/local/lib/site_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
    It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/local/lib/site_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
    It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/local/lib/site_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
    It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/local/lib/site_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
    It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/local/lib/site_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
    It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/local/lib/site_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
    It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/local/lib/site_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
    It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/local/lib/site_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
    It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/local/lib/site_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
    It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/local/lib/site_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
    It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/local/lib/site_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
    It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/local/lib/site_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
    It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/local/lib/site_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
    It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/local/lib/site_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
    It will be removed on or after 2011-11-01.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
    It will be removed on or after 2011-11-01.

    [39/104900]
    Gem::SourceIndex#add_spec called from
    /usr/local/lib/site_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem.source_index is deprecated, use Specification. It will be removed
    on or after 2011-11-01.
    Gem.source_index called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/gem_dependency.rb:78.
    NOTE: Gem::SourceIndex#each is deprecated with no replacement. It will be
    removed on or after 2011-11-01.
    Gem::SourceIndex#each called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:123.
    NOTE: Gem::Specification#installation_path is deprecated, use base_dir. It
    will be removed on or after 2011-10-01.
    Gem::Specification#installation_path called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:93.
    NOTE: Gem.source_index is deprecated, use Specification. It will be removed
    on or after 2011-11-01.
    Gem.source_index called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/gem_dependency.rb:78.
    NOTE: Gem::SourceIndex#each is deprecated with no replacement. It will be
    removed on or after 2011-11-01.
    Gem::SourceIndex#each called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:123.
    NOTE: Gem::Specification#installation_path is deprecated, use base_dir. It
    will be removed on or after 2011-10-01.
    Gem::Specification#installation_path called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:93.
    NOTE: Gem.source_index is deprecated, use Specification. It will be removed
    on or after 2011-11-01.
    Gem.source_index called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/gem_dependency.rb:78.
    NOTE: Gem::SourceIndex#each is deprecated with no replacement. It will be
    removed on or after 2011-11-01.
    Gem::SourceIndex#each called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:123.
    NOTE: Gem::Specification#installation_path is deprecated, use base_dir. It
    will be removed on or after 2011-10-01.
    Gem::Specification#installation_path called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:93.
    NOTE: Gem.source_index is deprecated, use Specification. It will be removed
    on or after 2011-11-01.
    Gem.source_index called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/gem_dependency.rb:78.
    NOTE: Gem::SourceIndex#each is deprecated with no replacement. It will be
    removed on or after 2011-11-01.
    Gem::SourceIndex#each called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:123.
    NOTE: Gem::Specification#installation_path is deprecated, use base_dir. It
    will be removed on or after 2011-10-01.
    Gem::Specification#installation_path called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:93.
    NOTE: Gem.source_index is deprecated, use Specification. It will be removed
    on or after 2011-11-01.
    Gem.source_index called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/gem_dependency.rb:78.
    NOTE: Gem::SourceIndex#each is deprecated with no replacement. It will be
    removed on or after 2011-11-01.
    Gem::SourceIndex#each called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:123.
    NOTE: Gem::Specification#installation_path is deprecated, use base_dir. It
    will be removed on or after 2011-10-01.
    Gem::Specification#installation_path called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:93.
    NOTE: Gem::Specification#installation_path is deprecated, use base_dir. It
    will be removed on or after 2011-10-01.
    Gem::Specification#installation_path called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:93.
    NOTE: Gem::Specification#installation_path is deprecated, use base_dir. It
    will be removed on or after 2011-10-01.
    Gem::Specification#installation_path called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:93.
    NOTE: Gem::Specification#installation_path is deprecated, use base_dir. It
    will be removed on or after 2011-10-01.
    Gem::Specification#installation_path called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:93.
    NOTE: Gem::Specification#installation_path is deprecated, use base_dir. It
    will be removed on or after 2011-10-01.
    Gem::Specification#installation_path called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:93.
    NOTE: Gem::Specification#installation_path is deprecated, use base_dir. It
    will be removed on or after 2011-10-01.
    Gem::Specification#installation_path called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:93.
    NOTE: Gem::Specification#installation_path is deprecated, use base_dir. It
    will be removed on or after 2011-10-01.

    Gem::Specification#installation_path called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:93.
    NOTE: Gem::Specification#installation_path is deprecated, use base_dir. It
    will be removed on or after 2011-10-01.
    Gem::Specification#installation_path called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:93.
    NOTE: Gem::Specification#installation_path is deprecated, use base_dir. It
    will be removed on or after 2011-10-01.
    Gem::Specification#installation_path called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:93.
    NOTE: Gem::Specification#installation_path is deprecated, use base_dir. It
    will be removed on or after 2011-10-01.
    Gem::Specification#installation_path called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:93.
    NOTE: Gem::Specification#installation_path is deprecated, use base_dir. It
    will be removed on or after 2011-10-01.
    Gem::Specification#installation_path called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:93.
    NOTE: Gem::Specification#installation_path is deprecated, use base_dir. It
    will be removed on or after 2011-10-01.
    Gem::Specification#installation_path called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:93.
    NOTE: Gem::Specification#installation_path is deprecated, use base_dir. It
    will be removed on or after 2011-10-01.
    Gem::Specification#installation_path called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:93.
    /usr/share/puppet-dashboard/lib/settings_reader.rb:61:in `validate':
    'daily_run_history_length' must be >= 1 (ArgumentError)
    from /usr/share/puppet-dashboard/lib/settings_reader.rb:45:in `read'
    from
    /usr/share/puppet-dashboard/config/initializers/00_settings_reader_init.rb:3
    from
    /usr/share/puppet-dashboard/vendor/rails/activesupport/lib/active_support/dependencies.rb:173:in
    `load_without_new_constant_marking'
    from
    /usr/share/puppet-dashboard/vendor/rails/activesupport/lib/active_support/dependencies.rb:173:in
    `load'
    from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/initializer.rb:622:in
    `load_application_initializers'
    from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/initializer.rb:621:in
    `each'
    from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/initializer.rb:621:in
    `load_application_initializers'
    from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/initializer.rb:176:in
    `process'
    from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/initializer.rb:113:in
    `send'
    from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/initializer.rb:113:in
    `run'
    from /usr/share/puppet-dashboard/config/environment.rb:14
    from /usr/share/puppet-dashboard/script/delayed_job:3:in `require'
    from /usr/share/puppet-dashboard/script/delayed_job:3
    puppet-dashboard-workers is not running.: failed!
    invoke-rc.d: initscript puppet-dashboard-workers, action "start" failed.
    dpkg: error processing puppet-dashboard (--configure):
    subprocess installed post-installation script returned error exit status 1
    configured to not write apport reports
    Setting up librack-ruby (1.1.0-4) ...
    Errors were encountered while processing:
    puppet-dashboard



    /usr/share/puppet-dashboard # gem list

    *** LOCAL GEMS ***

    rack (1.1.2)


    Any idea?


    Regards,
    JM

    On Fri, Jul 13, 2012 at 9:05 AM, Stefan Heijmans wrote:


    Op vrijdag 13 juli 2012 08:50:07 UTC+2 schreef Stefan Heijmans het
    volgende:
    the maintaining page also mentions;

    If you run ‘rake reports:prune’ without any arguments, it will display
    further usage instructions.
    my bad, that's not the one.

    # rake cron:cleanup
    ln -sf
    /usr/share/puppet-dashboard/examples/puppet-dashboard.cleanup_reports.cron
    /etc/cron.monthly/puppet-dashboard.cleanup_reports.cron
    It creates a link from the source to the /etc/cron.monthly.
    One issue, if you have puppet-dashboard installed in a different location
    the source is not there.
    # more /etc/cron.monthly/puppet-dashboard.cleanup_reports.cron
    /etc/cron.monthly/puppet-dashboard.cleanup_reports.cron: No such file or
    directory
    # ll
    /usr/share/puppet-dashboard/examples/puppet-dashboard.cleanup_reports.cron
    ls:
    /usr/share/puppet-dashboard/examples/puppet-dashboard.cleanup_reports.cron:
    No such file or directory
    # ll /opt/puppet-dashboard/examples/puppet-dashboard.cleanup_reports.cron
    -rwxr-xr-x 1 puppet-dashboard puppet-dashboard 597 Jul 12 20:50
    /opt/puppet-dashboard/examples/puppet-dashboard.cleanup_reports.cron
    #

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/NfidyMAbUNsJ.

    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Antidot SAS at Jul 13, 2012 at 9:29 am
    Oh by the way version 1.2.9-1 works like a charm.



    On Fri, Jul 13, 2012 at 11:16 AM, Antidot SAS wrote:

    HI I trying to upgrade for debian squeeze:

    (Reading database ... 66401 files and directories currently installed.)
    Preparing to replace librack-ruby 1.1.0-4 (using
    .../librack-ruby_1.1.0-4_all.deb) ...
    Unpacking replacement librack-ruby ...
    Setting up puppet-dashboard (1.2.10-1puppetlabs1) ...
    Starting Puppet Dashboard:Not starting Puppet Dashboard, disabled via
    /etc/default/puppet-dashboard ... (warning).
    .
    Starting Puppet Dashboard Workers:NOTE: Gem.source_index is deprecated,
    use Specification. It will be removed on or after 2011-11-01.
    Gem.source_index called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/gem_dependency.rb:21.
    NOTE: Gem::SourceIndex#initialize is deprecated with no replacement. It
    will be removed on or after 2011-11-01.
    Gem::SourceIndex#initialize called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:100.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
    It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/local/lib/site_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
    It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/local/lib/site_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
    It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/local/lib/site_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
    It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/local/lib/site_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
    It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/local/lib/site_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
    It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/local/lib/site_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
    It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/local/lib/site_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
    It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/local/lib/site_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
    It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/local/lib/site_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
    It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/local/lib/site_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
    It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/local/lib/site_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
    It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/local/lib/site_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
    It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/local/lib/site_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
    It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/local/lib/site_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
    It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/local/lib/site_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
    It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from
    /usr/local/lib/site_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
    It will be removed on or after 2011-11-01.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
    It will be removed on or after 2011-11-01.

    [39/104900]
    Gem::SourceIndex#add_spec called from
    /usr/local/lib/site_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem.source_index is deprecated, use Specification. It will be
    removed on or after 2011-11-01.
    Gem.source_index called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/gem_dependency.rb:78.
    NOTE: Gem::SourceIndex#each is deprecated with no replacement. It will be
    removed on or after 2011-11-01.
    Gem::SourceIndex#each called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:123.
    NOTE: Gem::Specification#installation_path is deprecated, use base_dir. It
    will be removed on or after 2011-10-01.
    Gem::Specification#installation_path called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:93.
    NOTE: Gem.source_index is deprecated, use Specification. It will be
    removed on or after 2011-11-01.
    Gem.source_index called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/gem_dependency.rb:78.
    NOTE: Gem::SourceIndex#each is deprecated with no replacement. It will be
    removed on or after 2011-11-01.
    Gem::SourceIndex#each called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:123.
    NOTE: Gem::Specification#installation_path is deprecated, use base_dir. It
    will be removed on or after 2011-10-01.
    Gem::Specification#installation_path called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:93.
    NOTE: Gem.source_index is deprecated, use Specification. It will be
    removed on or after 2011-11-01.
    Gem.source_index called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/gem_dependency.rb:78.
    NOTE: Gem::SourceIndex#each is deprecated with no replacement. It will be
    removed on or after 2011-11-01.
    Gem::SourceIndex#each called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:123.
    NOTE: Gem::Specification#installation_path is deprecated, use base_dir. It
    will be removed on or after 2011-10-01.
    Gem::Specification#installation_path called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:93.
    NOTE: Gem.source_index is deprecated, use Specification. It will be
    removed on or after 2011-11-01.
    Gem.source_index called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/gem_dependency.rb:78.
    NOTE: Gem::SourceIndex#each is deprecated with no replacement. It will be
    removed on or after 2011-11-01.
    Gem::SourceIndex#each called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:123.
    NOTE: Gem::Specification#installation_path is deprecated, use base_dir. It
    will be removed on or after 2011-10-01.
    Gem::Specification#installation_path called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:93.
    NOTE: Gem.source_index is deprecated, use Specification. It will be
    removed on or after 2011-11-01.
    Gem.source_index called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/gem_dependency.rb:78.
    NOTE: Gem::SourceIndex#each is deprecated with no replacement. It will be
    removed on or after 2011-11-01.
    Gem::SourceIndex#each called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:123.
    NOTE: Gem::Specification#installation_path is deprecated, use base_dir. It
    will be removed on or after 2011-10-01.
    Gem::Specification#installation_path called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:93.
    NOTE: Gem::Specification#installation_path is deprecated, use base_dir. It
    will be removed on or after 2011-10-01.
    Gem::Specification#installation_path called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:93.
    NOTE: Gem::Specification#installation_path is deprecated, use base_dir. It
    will be removed on or after 2011-10-01.
    Gem::Specification#installation_path called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:93.
    NOTE: Gem::Specification#installation_path is deprecated, use base_dir. It
    will be removed on or after 2011-10-01.
    Gem::Specification#installation_path called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:93.
    NOTE: Gem::Specification#installation_path is deprecated, use base_dir. It
    will be removed on or after 2011-10-01.
    Gem::Specification#installation_path called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:93.
    NOTE: Gem::Specification#installation_path is deprecated, use base_dir. It
    will be removed on or after 2011-10-01.
    Gem::Specification#installation_path called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:93.
    NOTE: Gem::Specification#installation_path is deprecated, use base_dir. It
    will be removed on or after 2011-10-01.

    Gem::Specification#installation_path called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:93.
    NOTE: Gem::Specification#installation_path is deprecated, use base_dir. It
    will be removed on or after 2011-10-01.
    Gem::Specification#installation_path called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:93.
    NOTE: Gem::Specification#installation_path is deprecated, use base_dir. It
    will be removed on or after 2011-10-01.
    Gem::Specification#installation_path called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:93.
    NOTE: Gem::Specification#installation_path is deprecated, use base_dir. It
    will be removed on or after 2011-10-01.
    Gem::Specification#installation_path called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:93.
    NOTE: Gem::Specification#installation_path is deprecated, use base_dir. It
    will be removed on or after 2011-10-01.
    Gem::Specification#installation_path called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:93.
    NOTE: Gem::Specification#installation_path is deprecated, use base_dir. It
    will be removed on or after 2011-10-01.
    Gem::Specification#installation_path called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:93.
    NOTE: Gem::Specification#installation_path is deprecated, use base_dir. It
    will be removed on or after 2011-10-01.
    Gem::Specification#installation_path called from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:93.
    /usr/share/puppet-dashboard/lib/settings_reader.rb:61:in `validate':
    'daily_run_history_length' must be >= 1 (ArgumentError)
    from /usr/share/puppet-dashboard/lib/settings_reader.rb:45:in
    `read'
    from
    /usr/share/puppet-dashboard/config/initializers/00_settings_reader_init.rb:3
    from
    /usr/share/puppet-dashboard/vendor/rails/activesupport/lib/active_support/dependencies.rb:173:in
    `load_without_new_constant_marking'
    from
    /usr/share/puppet-dashboard/vendor/rails/activesupport/lib/active_support/dependencies.rb:173:in
    `load'
    from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/initializer.rb:622:in
    `load_application_initializers'
    from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/initializer.rb:621:in
    `each'
    from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/initializer.rb:621:in
    `load_application_initializers'
    from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/initializer.rb:176:in
    `process'
    from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/initializer.rb:113:in
    `send'
    from
    /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/initializer.rb:113:in
    `run'
    from /usr/share/puppet-dashboard/config/environment.rb:14
    from /usr/share/puppet-dashboard/script/delayed_job:3:in `require'
    from /usr/share/puppet-dashboard/script/delayed_job:3
    puppet-dashboard-workers is not running.: failed!
    invoke-rc.d: initscript puppet-dashboard-workers, action "start" failed.
    dpkg: error processing puppet-dashboard (--configure):
    subprocess installed post-installation script returned error exit status 1
    configured to not write apport reports
    Setting up librack-ruby (1.1.0-4) ...
    Errors were encountered while processing:
    puppet-dashboard



    /usr/share/puppet-dashboard # gem list

    *** LOCAL GEMS ***

    rack (1.1.2)


    Any idea?


    Regards,
    JM

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • William Hopper at Jul 13, 2012 at 6:19 pm
    Jo,

    To invoke the new rake task, run `rake cron:cleanup` in /usr/share/puppet-dashboard.
    The example script that is installed can be viewed in /usr/share/puppet-dashboard/examples.

    I will be submitting a pull request to the puppet-docs project shortly to update the
    dashboard documentation.

    Thanks,

    -Will

    On Jul 13, 2012, at 9:36 AM, Jo Rhett wrote:

    On Jul 12, 2012, at 11:50 PM, Stefan Heijmans wrote:
    the maintaining page also mentions;
    If you run ‘rake reports:prune’ without any arguments, it will display further usage instructions.

    Just installed in in our sandbox and it shows;

    rake reports:prune
    EXAMPLE:
    # Prune records upto 1 month old:
    rake reports:prune upto=1 unit=mon

    UNITS:
    Valid units of time are: mon,yr,day,min,wk,hr
    Hm, yes. What does that have to do with my question about the new rake job to install a cron script?

    --
    Jo Rhett
    Net Consonance : net philanthropy to improve open source and internet projects.




    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • William Hopper at Jul 13, 2012 at 9:35 pm
    All,

    New puppet-dashboard 1.2.10 deb packages are available on apt.puppetlabs.com
    that should resolve the issue of the missing configuration file.

    The package version is 1.2.10-1puppetlabs2.

    Thanks for your patience while we worked this fix out. Please let us know if you encounter any issues.

    Thanks,
    Will
  • Stefan Heijmans at Jul 13, 2012 at 7:28 pm
    Op vrijdag 13 juli 2012 18:36:41 UTC+2 schreef Jo het volgende:

    Hm, yes. What does that have to do with my question about the new rake job
    to install a cron script?

    absolutely nothing, as stated in my 2nd post about it :)

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/kotzCbdij7YJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedJul 12, '12 at 11:12p
activeJul 13, '12 at 9:35p
posts8
users3
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase