FAQ
I'm trying to install dashboard.

I'm using:

Ubuntu 12.04 LTS (32bit),
Puppet 2.7.17.
ruby 1.8.7 (2011-06-30 patchlevel 352) [i686-linux]
rubygems 1.8.15

When I run the db:migrate task, I get the following:

root@puppet-master-local:/usr/share/puppet-dashboard# rake
RAILS_ENV=production db:migrate --trace
NOTE: Gem.source_index is deprecated, use Specification. It will be removed
on or after 2011-11-01.
Gem.source_index called from
/usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/gem_dependency.rb:21.
NOTE: Gem::SourceIndex#initialize is deprecated with no replacement. It
will be removed on or after 2011-11-01.
Gem::SourceIndex#initialize called from
/usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:100.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from
/usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from
/usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from
/usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from
/usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from
/usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from
/usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from
/usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from
/usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from
/usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from
/usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from
/usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from
/usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from
/usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from
/usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from
/usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from
/usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from
/usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec.
It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from
/usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
rake aborted!
no such file to load -- rdoc/task
/usr/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:36:in
`gem_original_require'
/usr/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:36:in `require'
/usr/share/puppet-dashboard/Rakefile:9
/usr/lib/ruby/vendor_ruby/rake/rake_module.rb:25:in `load'
/usr/lib/ruby/vendor_ruby/rake/rake_module.rb:25:in `load_rakefile'
/usr/lib/ruby/vendor_ruby/rake/application.rb:501:in `raw_load_rakefile'
/usr/lib/ruby/vendor_ruby/rake/application.rb:82:in `load_rakefile'
/usr/lib/ruby/vendor_ruby/rake/application.rb:133:in
`standard_exception_handling'
/usr/lib/ruby/vendor_ruby/rake/application.rb:81:in `load_rakefile'
/usr/lib/ruby/vendor_ruby/rake/application.rb:65:in `run'
/usr/lib/ruby/vendor_ruby/rake/application.rb:133:in
`standard_exception_handling'
/usr/lib/ruby/vendor_ruby/rake/application.rb:63:in `run'
/usr/bin/rake:27

I don't know if I am missing it in all the text, but I am not even sure
what file it is that it can't load.

Did I miss a step? Trying to follow
http://docs.puppetlabs.com/dashboard/manual/1.2/bootstrapping.html

Thanks.

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/lNqEOks-TaUJ.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Ramin K at Jul 10, 2012 at 10:09 pm

    On 7/10/2012 1:14 PM, llowder@oreillyauto.com wrote:
    I'm trying to install dashboard.

    I'm using:

    Ubuntu 12.04 LTS (32bit),
    Puppet 2.7.17.
    ruby 1.8.7 (2011-06-30 patchlevel 352) [i686-linux]
    rubygems 1.8.15 <snip>
    Did I miss a step? Trying to follow
    http://docs.puppetlabs.com/dashboard/manual/1.2/bootstrapping.html
    You might be missing a mysql gem, that's an easy step to miss.

    Ramin

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Craig White at Jul 10, 2012 at 11:48 pm

    On Jul 10, 2012, at 1:14 PM, llowder@oreillyauto.com wrote:

    I'm trying to install dashboard.

    I'm using:

    Ubuntu 12.04 LTS (32bit),
    Puppet 2.7.17.
    ruby 1.8.7 (2011-06-30 patchlevel 352) [i686-linux]
    rubygems 1.8.15

    When I run the db:migrate task, I get the following:

    root@puppet-master-local:/usr/share/puppet-dashboard# rake RAILS_ENV=production db:migrate --trace
    NOTE: Gem.source_index is deprecated, use Specification. It will be removed on or after 2011-11-01.
    Gem.source_index called from /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/gem_dependency.rb:21.
    NOTE: Gem::SourceIndex#initialize is deprecated with no replacement. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#initialize called from /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:100.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from /usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from /usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from /usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from /usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from /usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from /usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from /usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from /usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from /usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from /usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from /usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from /usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from /usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from /usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from /usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from /usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from /usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
    NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
    Gem::SourceIndex#add_spec called from /usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
    rake aborted!
    no such file to load -- rdoc/task
    /usr/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:36:in `gem_original_require'
    /usr/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:36:in `require'
    /usr/share/puppet-dashboard/Rakefile:9
    /usr/lib/ruby/vendor_ruby/rake/rake_module.rb:25:in `load'
    /usr/lib/ruby/vendor_ruby/rake/rake_module.rb:25:in `load_rakefile'
    /usr/lib/ruby/vendor_ruby/rake/application.rb:501:in `raw_load_rakefile'
    /usr/lib/ruby/vendor_ruby/rake/application.rb:82:in `load_rakefile'
    /usr/lib/ruby/vendor_ruby/rake/application.rb:133:in `standard_exception_handling'
    /usr/lib/ruby/vendor_ruby/rake/application.rb:81:in `load_rakefile'
    /usr/lib/ruby/vendor_ruby/rake/application.rb:65:in `run'
    /usr/lib/ruby/vendor_ruby/rake/application.rb:133:in `standard_exception_handling'
    /usr/lib/ruby/vendor_ruby/rake/application.rb:63:in `run'
    /usr/bin/rake:27

    I don't know if I am missing it in all the text, but I am not even sure what file it is that it can't load.

    Did I miss a step? Trying to follow http://docs.puppetlabs.com/dashboard/manual/1.2/bootstrapping.html
    ----
    I think you might want to run an earlier version of rubygems...

    gem install system -v "1.4.2"

    if I recall correctly (or 1.5.1)

    Craig

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Llowder at Jul 11, 2012 at 1:52 pm
    Comments inline.
    On Tuesday, July 10, 2012 6:48:28 PM UTC-5, Craig White wrote:

    On Jul 10, 2012, at 1:14 PM, llowder wrote:

    I'm trying to install dashboard.

    I'm using:

    Ubuntu 12.04 LTS (32bit),
    Puppet 2.7.17.
    ruby 1.8.7 (2011-06-30 patchlevel 352) [i686-linux]
    rubygems 1.8.15

    When I run the db:migrate task, I get the following: <snip>
    I don't know if I am missing it in all the text, but I am not even sure
    what file it is that it can't load.
    Did I miss a step? Trying to follow
    http://docs.puppetlabs.com/dashboard/manual/1.2/bootstrapping.html
    ----
    I think you might want to run an earlier version of rubygems...

    gem install system -v "1.4.2"

    if I recall correctly (or 1.5.1)
    This command did not work. However, I ran the script from the dashboard
    site and downgraded to gems 1.3.7, and this has allowed me to proceed.

    I am, however, not very happy about having to use such an old version.

    The other change I mad was to install the (latest) rdoc gem.
    Craig
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/hlpi8qEj1MgJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • ForumUser at Apr 2, 2013 at 11:19 am
    Hi,

    I am facing similar problem about 'rake aborted'. Can you write which
    script (from dashboard site) did you run to
    solve this issues ?
    On Wednesday, 11 July 2012 14:52:47 UTC+1, llowder wrote:

    Comments inline.
    On Tuesday, July 10, 2012 6:48:28 PM UTC-5, Craig White wrote:

    On Jul 10, 2012, at 1:14 PM, llowder wrote:

    I'm trying to install dashboard.

    I'm using:

    Ubuntu 12.04 LTS (32bit),
    Puppet 2.7.17.
    ruby 1.8.7 (2011-06-30 patchlevel 352) [i686-linux]
    rubygems 1.8.15

    When I run the db:migrate task, I get the following: <snip>
    I don't know if I am missing it in all the text, but I am not even sure
    what file it is that it can't load.
    Did I miss a step? Trying to follow
    http://docs.puppetlabs.com/dashboard/manual/1.2/bootstrapping.html
    ----
    I think you might want to run an earlier version of rubygems...

    gem install system -v "1.4.2"

    if I recall correctly (or 1.5.1)
    This command did not work. However, I ran the script from the dashboard
    site and downgraded to gems 1.3.7, and this has allowed me to proceed.

    I am, however, not very happy about having to use such an old version.

    The other change I mad was to install the (latest) rdoc gem.
    Craig
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedJul 10, '12 at 8:14p
activeApr 2, '13 at 11:19a
posts5
users4
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase