FAQ
I am running dashboard on centos 6.2, with autosign.conf configured with *.

I installed puppet on a new node, which can get catalog, but it does
not show up in dashboard.

Can someone explain it is normal, and how I can make it appear in
dashboard automatically?

Thanks.

Hai Tao

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Corey Hammerton at Jul 10, 2012 at 6:23 pm
    Can your puppetmaster talk to your puppet-dashboard?

    Because new nodes should by default automatically appear on the dashboard,
    they have for me.
    On Tuesday, July 10, 2012 1:45:16 PM UTC-4, Hai wrote:

    I am running dashboard on centos 6.2, with autosign.conf configured with
    *.

    I installed puppet on a new node, which can get catalog, but it does
    not show up in dashboard.

    Can someone explain it is normal, and how I can make it appear in
    dashboard automatically?

    Thanks.

    Hai Tao
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/aTtx2v2LlJkJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Hai Tao at Jul 10, 2012 at 6:25 pm
    I have 6 nodes now, and only 3 shows up in dashboard. How can I check
    if the puppetmaster can talk to puppet-dashboard?

    also what does the dashboard-worker do? does it have to be running?

    On Tue, Jul 10, 2012 at 11:23 AM, Corey Hammerton
    wrote:
    Can your puppetmaster talk to your puppet-dashboard?

    Because new nodes should by default automatically appear on the dashboard,
    they have for me.

    On Tuesday, July 10, 2012 1:45:16 PM UTC-4, Hai wrote:

    I am running dashboard on centos 6.2, with autosign.conf configured with
    *.

    I installed puppet on a new node, which can get catalog, but it does
    not show up in dashboard.

    Can someone explain it is normal, and how I can make it appear in
    dashboard automatically?

    Thanks.

    Hai Tao
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/aTtx2v2LlJkJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.


    --
    Hai Tao

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Corey Hammerton at Jul 10, 2012 at 8:53 pm
    the dashboard-worker is the process that takes the report, parses it and
    inserts it into the DB.

    It MUST be running.

    When was the last report from any of you're appearing nodes from?
    On Tuesday, July 10, 2012 2:25:27 PM UTC-4, Hai wrote:

    I have 6 nodes now, and only 3 shows up in dashboard. How can I check
    if the puppetmaster can talk to puppet-dashboard?

    also what does the dashboard-worker do? does it have to be running?

    On Tue, Jul 10, 2012 at 11:23 AM, Corey Hammerton
    wrote:
    Can your puppetmaster talk to your puppet-dashboard?

    Because new nodes should by default automatically appear on the
    dashboard,
    they have for me.

    On Tuesday, July 10, 2012 1:45:16 PM UTC-4, Hai wrote:

    I am running dashboard on centos 6.2, with autosign.conf configured
    with
    *.

    I installed puppet on a new node, which can get catalog, but it does
    not show up in dashboard.

    Can someone explain it is normal, and how I can make it appear in
    dashboard automatically?

    Thanks.

    Hai Tao
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/aTtx2v2LlJkJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.


    --
    Hai Tao
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/7coY6P5kX2EJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Hai Tao at Jul 10, 2012 at 9:07 pm
    I am using apache and passenger, instead of webrick. Do I still need
    to run the dashboard-worker dameon?

    another quesiton is as puppetmasterd is not running for my apache set
    up, how can I make changes take effect when I change the puppet.conf
    content?

    Thanks.

    On Tue, Jul 10, 2012 at 1:53 PM, Corey Hammerton
    wrote:
    the dashboard-worker is the process that takes the report, parses it and
    inserts it into the DB.

    It MUST be running.

    When was the last report from any of you're appearing nodes from?

    On Tuesday, July 10, 2012 2:25:27 PM UTC-4, Hai wrote:

    I have 6 nodes now, and only 3 shows up in dashboard. How can I check
    if the puppetmaster can talk to puppet-dashboard?

    also what does the dashboard-worker do? does it have to be running?

    On Tue, Jul 10, 2012 at 11:23 AM, Corey Hammerton
    wrote:
    Can your puppetmaster talk to your puppet-dashboard?

    Because new nodes should by default automatically appear on the
    dashboard,
    they have for me.

    On Tuesday, July 10, 2012 1:45:16 PM UTC-4, Hai wrote:

    I am running dashboard on centos 6.2, with autosign.conf configured
    with
    *.

    I installed puppet on a new node, which can get catalog, but it does
    not show up in dashboard.

    Can someone explain it is normal, and how I can make it appear in
    dashboard automatically?

    Thanks.

    Hai Tao
    --
    You received this message because you are subscribed to the Google
    Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/aTtx2v2LlJkJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.


    --
    Hai Tao
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/7coY6P5kX2EJ.

    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.


    --
    Hai Tao

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Jo Rhett at Jul 10, 2012 at 9:19 pm

    On Jul 10, 2012, at 2:07 PM, Hai Tao wrote:
    I am using apache and passenger, instead of webrick. Do I still need
    to run the dashboard-worker dameon? Yes.
    another quesiton is as puppetmasterd is not running for my apache set
    up, how can I make changes take effect when I change the puppet.conf
    content?
    Restart passenger. (ie restart apache)

    --
    Jo Rhett
    Net Consonance : net philanthropy to improve open source and internet projects.



    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Hai Tao at Jul 10, 2012 at 9:42 pm
    I like to set up the dashboard to be using apache also by follow this
    procedures below. After that, do I still need to run workers?

    Serving Dashboard With Passenger and Apache
    First, you’ll need to ensure that Apache 2.2 and Phusion Passenger are
    installed. The Passenger website has installation instructions, but
    it’s quite possible that your OS vendor has already packaged
    Passenger, which can make for a much easier install.

    Once Passenger is enabled, copy Dashboard’s example vhost from
    ext/passenger/dashboard-vhost.conf into Apache’s sites-enabled
    directory and edit it to match your Dashboard installation. Passenger
    runs Rails apps in the production environment by default, so you won’t
    need to explicitly set the environment (with the RailsEnv directive in
    the vhost configuration) unless you plan to run it in development
    mode. The parts of the file you’ll need to edit are:

    ♦The port on which to serve Dashboard. This defaults to 80, but if you
    want to serve it on Puppet’s preferred port of 3000, you’ll need to
    change the opening tag of the vhost definition block to <VirtualHost
    *:3000> and insert a Listen 3000 directive above it.
    ♦The subdomain you’ll be serving Dashboard from, which is generally
    just the fully-qualified domain name of this machine. Put this in the
    ServerName directive.
    ♦The location of Dashboard’s public directory, which should go in both
    the DocumentRoot directive and the <Directory> block opening tag.
    ♦Your preferred log file locations, which go in the ErrorLog and
    CustomLog directives.
    ♦The paths to Passenger, mod_passenger, and Ruby. But before you tweak
    these, scan the rest of Apache’s config files: if you installed
    Passenger from a vendor package, it probably already inserted a global
    config file to make sure it’s loaded, in which case you can safely
    comment out the first three lines of this vhost config. Otherwise,
    point the LoadModule, PassengerRoot, and PassengerRuby directives at
    the top of the file to the correct files and directories.
    If you prefer to roll your own vhost config, see the Passenger user’s
    guide and note that:

    ♦The DocumentRoot should point to Dashboard’s public directory, which
    needs to allow all access and have the MultiViews option turned off.
    ♦Passenger will need either the per-server RailsAutoDetect directive
    set to On (which is its default state), or a RailsBaseURI directive in
    the vhost definition.
    Once Dashboard’s vhost config is properly configured, simply restart
    Apache and test that Puppet can communicate with Dashboard, as
    described above.


    --------------------------------------------------------------------------------

    On Tue, Jul 10, 2012 at 2:19 PM, Jo Rhett wrote:
    On Jul 10, 2012, at 2:07 PM, Hai Tao wrote:

    I am using apache and passenger, instead of webrick. Do I still need
    to run the dashboard-worker dameon?


    Yes.

    another quesiton is as puppetmasterd is not running for my apache set
    up, how can I make changes take effect when I change the puppet.conf
    content?


    Restart passenger. (ie restart apache)

    --
    Jo Rhett
    Net Consonance : net philanthropy to improve open source and internet
    projects.



    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.


    --
    Hai Tao

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedJul 10, '12 at 5:45p
activeJul 10, '12 at 9:42p
posts7
users3
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase