FAQ
So I'm trying to exec something, but during the exec a screen will show up
that I need to "q" out of to finish it. Specifically speaking, I'm trying
to exec: rvm --force install 1.8.7

How do I do this with Puppet?

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/qHlqpgqUE3AJ.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Jcbollinger at Jul 5, 2012 at 3:37 pm

    On Wednesday, July 4, 2012 6:01:02 PM UTC-5, Benjamin Lei wrote:
    So I'm trying to exec something, but during the exec a screen will show up
    that I need to "q" out of to finish it. Specifically speaking, I'm trying
    to exec: rvm --force install 1.8.7

    Ideally, there would be a command-line option to suppress the screen or
    provide the needed answer automatically. Most command-line based
    installers have such a thing in order to make them scriptable. If rvm
    doesn't provide that option then you might be able to pipe in the needed
    input: 'echo q | rvm --force install 1.8.7'. In that case make sure the
    Exec uses the 'sh' provider.


    John

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/cxRiu-1lCIAJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Benjamin Lei at Jul 6, 2012 at 1:43 am
    I see; thanks. I'll try that later.
    The next thing I'm trying to do is:
    rvm use 1.8.7 --default

    The command executes successfully, but when I SSH back into my server the
    version is still its old one. What might be going wrong?
    On Thursday, July 5, 2012 8:37:28 AM UTC-7, jcbollinger wrote:


    On Wednesday, July 4, 2012 6:01:02 PM UTC-5, Benjamin Lei wrote:

    So I'm trying to exec something, but during the exec a screen will show
    up that I need to "q" out of to finish it. Specifically speaking, I'm
    trying to exec: rvm --force install 1.8.7

    Ideally, there would be a command-line option to suppress the screen or
    provide the needed answer automatically. Most command-line based
    installers have such a thing in order to make them scriptable. If rvm
    doesn't provide that option then you might be able to pipe in the needed
    input: 'echo q | rvm --force install 1.8.7'. In that case make sure the
    Exec uses the 'sh' provider.


    John
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/qfdLLnvdw8cJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Brian Gupta at Jul 6, 2012 at 1:49 am

    On Thu, Jul 5, 2012 at 9:43 PM, Benjamin Lei wrote:
    I see; thanks. I'll try that later.
    The next thing I'm trying to do is:
    rvm use 1.8.7 --default

    The command executes successfully, but when I SSH back into my server the
    version is still its old one. What might be going wrong?
    On Thursday, July 5, 2012 8:37:28 AM UTC-7, jcbollinger wrote:


    On Wednesday, July 4, 2012 6:01:02 PM UTC-5, Benjamin Lei wrote:

    So I'm trying to exec something, but during the exec a screen will show
    up that I need to "q" out of to finish it. Specifically speaking, I'm trying
    to exec: rvm --force install 1.8.7

    Ideally, there would be a command-line option to suppress the screen or
    provide the needed answer automatically. Most command-line based installers
    have such a thing in order to make them scriptable. If rvm doesn't provide
    that option then you might be able to pipe in the needed input: 'echo q |
    rvm --force install 1.8.7'. In that case make sure the Exec uses the 'sh'
    provider.
    Does this help?:
    http://unknown-xengineer.blogspot.com/2012/06/workaround-for-unattended-rvm.html

    John
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/qfdLLnvdw8cJ.

    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Benjamin Lei at Jul 6, 2012 at 2:52 am
    No that did not work. It worked when I ran it myself, but when puppet ran
    it the previous Ruby version I had was not replaced.
    On Thursday, July 5, 2012 6:48:58 PM UTC-7, Brian Gupta wrote:
    On Thu, Jul 5, 2012 at 9:43 PM, Benjamin Lei wrote:
    I see; thanks. I'll try that later.
    The next thing I'm trying to do is:
    rvm use 1.8.7 --default

    The command executes successfully, but when I SSH back into my server the
    version is still its old one. What might be going wrong?
    On Thursday, July 5, 2012 8:37:28 AM UTC-7, jcbollinger wrote:


    On Wednesday, July 4, 2012 6:01:02 PM UTC-5, Benjamin Lei wrote:

    So I'm trying to exec something, but during the exec a screen will
    show
    up that I need to "q" out of to finish it. Specifically speaking, I'm
    trying
    to exec: rvm --force install 1.8.7

    Ideally, there would be a command-line option to suppress the screen or
    provide the needed answer automatically. Most command-line based
    installers
    have such a thing in order to make them scriptable. If rvm doesn't
    provide
    that option then you might be able to pipe in the needed input: 'echo q
    rvm --force install 1.8.7'. In that case make sure the Exec uses the
    'sh'
    provider.
    Does this help?:

    http://unknown-xengineer.blogspot.com/2012/06/workaround-for-unattended-rvm.html

    John
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/qfdLLnvdw8cJ.

    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/qHLHVTOSYMUJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedJul 4, '12 at 11:01p
activeJul 6, '12 at 2:52a
posts5
users3
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase