FAQ
Please help me. I've been dealing with this for a week.

I have two clean installs agent and master on ubuntu/
apt-get install puppetmaster
apt-get install puppet

I signed my agent. My wait was 30 seconds, and 30 seconds later it tries to
connecct, but instead it said hostname not match.

On my agent:
/etc/puppet/ssl/certs# ls
ca.pem box.pem

On my master:
/etc/puppet/ssl/certs# ls
ca.pem master.pem


I know I can compare certifactes with openssl x509 -text -in
/etc/puppet/ssl/certs/<name>, but I have no idea what to compare.
Please help me. I've googled many helps already...
I autogenerated puppet.conf on master machine: "/usr/sbin/puppetmasterd
--genconfig > /etc/puppet/puppet.conf"
I think it's missing the certname part. Minimally, what should be present?


Thanks.

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/CpueR3FFqM0J.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Tas at Jul 2, 2012 at 5:20 pm
    okay. it looks like by uncommenting "server = puppet" from the auto conf
    file, it stops complaining about hostname not match.

    However, new error comes up:
    /etc/puppet/ssl/certs# puppet agent --server puppet --waitforce 30 --test
    sh: getcwd() failed: No such file or directory
    sh: getcwd() failed: No such file or directory
    /usr/lib/ruby/1.8/facter/util/resolution.rb:46: warning: Insecure world
    writable dir /etc/condor in PATH, mode 040777
    /usr/lib/ruby/1.8/puppet/defaults.rb:67: warning: Insecure world writable
    dir /etc/condor in PATH, mode 040777
    sh: getcwd() failed: No such file or directory
    sh: getcwd() failed: No such file or directory
    sh: getcwd() failed: No such file or directory
    sh: getcwd() failed: No such file or directory
    sh: getcwd() failed: No such file or directory
    sh: getcwd() failed: No such file or directory
    sh: getcwd() failed: No such file or directory
    info: Creating a new SSL key for box
    warning: peer certificate won't be verified in this SSL session
    info: Caching certificate for ca
    warning: peer certificate won't be verified in this SSL session
    warning: peer certificate won't be verified in this SSL session
    info: Creating a new SSL certificate request for box
    info: Certificate Request fingerprint (md5):
    warning: peer certificate won't be verified in this SSL session
    warning: peer certificate won't be verified in this SSL session
    warning: peer certificate won't be verified in this SSL session
    warning: peer certificate won't be verified in this SSL session
    info: Caching certificate for box
    sh: getcwd() failed: No such file or directory
    sh: getcwd() failed: No such file or directory
    err: Could not run Puppet configuration client: Could not retrieve local
    facts: No such file or directory - getcwd


    That;s because I commented out
    factdest = /var/lib/puppet/facts/

    But if I uncomment, I can't start puppetmaster again
    tc/init.d/puppetmaster start
    * Starting puppet
    master
    Could not prepare for execution: Got 1 failure(s) while initializing:
    change from directory to file failed: Could not set 'file on ensure: Is a
    directory - /var/lib/puppet/facts [fails]

    On Monday, July 2, 2012 12:40:16 PM UTC-4, dns wrote:

    Please help me. I've been dealing with this for a week.

    I have two clean installs agent and master on ubuntu/
    apt-get install puppetmaster
    apt-get install puppet

    I signed my agent. My wait was 30 seconds, and 30 seconds later it tries
    to connecct, but instead it said hostname not match.

    On my agent:
    /etc/puppet/ssl/certs# ls
    ca.pem box.pem

    On my master:
    /etc/puppet/ssl/certs# ls
    ca.pem master.pem


    I know I can compare certifactes with openssl x509 -text -in
    /etc/puppet/ssl/certs/<name>, but I have no idea what to compare.
    Please help me. I've googled many helps already...
    I autogenerated puppet.conf on master machine: "/usr/sbin/puppetmasterd
    --genconfig > /etc/puppet/puppet.conf"
    I think it's missing the certname part. Minimally, what should be present?


    Thanks.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/xfhzUfM7ThQJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Denmat at Jul 2, 2012 at 10:01 pm
    Hi,

    Make sure the puppet user can change perms on that directory.

    Also, if still having trouble, paste your version number and puppet.confs.

    Cheers
    Den
    On 03/07/2012, at 3:20, tas wrote:

    okay. it looks like by uncommenting "server = puppet" from the auto conf file, it stops complaining about hostname not match.

    However, new error comes up:
    /etc/puppet/ssl/certs# puppet agent --server puppet --waitforce 30 --test
    sh: getcwd() failed: No such file or directory
    sh: getcwd() failed: No such file or directory
    /usr/lib/ruby/1.8/facter/util/resolution.rb:46: warning: Insecure world writable dir /etc/condor in PATH, mode 040777
    /usr/lib/ruby/1.8/puppet/defaults.rb:67: warning: Insecure world writable dir /etc/condor in PATH, mode 040777
    sh: getcwd() failed: No such file or directory
    sh: getcwd() failed: No such file or directory
    sh: getcwd() failed: No such file or directory
    sh: getcwd() failed: No such file or directory
    sh: getcwd() failed: No such file or directory
    sh: getcwd() failed: No such file or directory
    sh: getcwd() failed: No such file or directory
    info: Creating a new SSL key for box
    warning: peer certificate won't be verified in this SSL session
    info: Caching certificate for ca
    warning: peer certificate won't be verified in this SSL session
    warning: peer certificate won't be verified in this SSL session
    info: Creating a new SSL certificate request for box
    info: Certificate Request fingerprint (md5):
    warning: peer certificate won't be verified in this SSL session
    warning: peer certificate won't be verified in this SSL session
    warning: peer certificate won't be verified in this SSL session
    warning: peer certificate won't be verified in this SSL session
    info: Caching certificate for box
    sh: getcwd() failed: No such file or directory
    sh: getcwd() failed: No such file or directory
    err: Could not run Puppet configuration client: Could not retrieve local facts: No such file or directory - getcwd


    That;s because I commented out
    factdest = /var/lib/puppet/facts/

    But if I uncomment, I can't start puppetmaster again
    tc/init.d/puppetmaster start
    * Starting puppet master Could not prepare for execution: Got 1 failure(s) while initializing: change from directory to file failed: Could not set 'file on ensure: Is a directory - /var/lib/puppet/facts [fails]


    On Monday, July 2, 2012 12:40:16 PM UTC-4, dns wrote:
    Please help me. I've been dealing with this for a week.

    I have two clean installs agent and master on ubuntu/
    apt-get install puppetmaster
    apt-get install puppet

    I signed my agent. My wait was 30 seconds, and 30 seconds later it tries to connecct, but instead it said hostname not match.

    On my agent:
    /etc/puppet/ssl/certs# ls
    ca.pem box.pem

    On my master:
    /etc/puppet/ssl/certs# ls
    ca.pem master.pem


    I know I can compare certifactes with openssl x509 -text -in /etc/puppet/ssl/certs/<name>, but I have no idea what to compare.
    Please help me. I've googled many helps already...
    I autogenerated puppet.conf on master machine: "/usr/sbin/puppetmasterd --genconfig > /etc/puppet/puppet.conf"
    I think it's missing the certname part. Minimally, what should be present?


    Thanks.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/xfhzUfM7ThQJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedJul 2, '12 at 4:40p
activeJul 2, '12 at 10:01p
posts3
users3
websitepuppetlabs.com

3 users in discussion

Denmat: 1 post Tas: 1 post Dns: 1 post

People

Translate

site design / logo © 2022 Grokbase