FAQ
Team,

I am trying to setup new Puppet master server on Centos 5.4. I am getting
the below error which running yum install puppet-server

puppet-2.7.17-1.el5.noarch from puppetlabs has depsolving problems
--> Missing Dependency: ruby-shadow is needed by package
puppet-2.7.17-1.el5.noarch (puppetlabs)
puppet-2.7.17-1.el5.noarch from puppetlabs has depsolving problems
--> Missing Dependency: ruby-augeas is needed by package
puppet-2.7.17-1.el5.noarch (puppetlabs)
Error: Missing Dependency: ruby-augeas is needed by package
puppet-2.7.17-1.el5.noarch (puppetlabs)
Error: Missing Dependency: ruby-shadow is needed by package
puppet-2.7.17-1.el5.noarch (puppetlabs)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest

I am using the below puppet respository

[puppetlabs]
name=Puppet Labs Packages
baseurl=http://yum.puppetlabs.com/el/$releasever/products/$basearch/
enabled=1
gpgcheck=1
gpgkey=http://yum.puppetlabs.com/RPM-GPG-KEY-puppetlabs

Also my Current ruby version is as below

ruby 1.8.5 (2006-08-25) [i386-linux]


Thanks,
Munna

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Denmat at Jun 25, 2012 at 7:38 am
    Hi Munna,

    You can find those packages in the EPEL repository.

    See http://fedoraproject.org/wiki/EPEL.

    Den
    On 25/06/2012, at 17:34, Munna S wrote:

    Team,

    I am trying to setup new Puppet master server on Centos 5.4. I am getting the below error which running yum install puppet-server

    puppet-2.7.17-1.el5.noarch from puppetlabs has depsolving problems
    --> Missing Dependency: ruby-shadow is needed by package puppet-2.7.17-1.el5.noarch (puppetlabs)
    puppet-2.7.17-1.el5.noarch from puppetlabs has depsolving problems
    --> Missing Dependency: ruby-augeas is needed by package puppet-2.7.17-1.el5.noarch (puppetlabs)
    Error: Missing Dependency: ruby-augeas is needed by package puppet-2.7.17-1.el5.noarch (puppetlabs)
    Error: Missing Dependency: ruby-shadow is needed by package puppet-2.7.17-1.el5.noarch (puppetlabs)
    You could try using --skip-broken to work around the problem
    You could try running: package-cleanup --problems
    package-cleanup --dupes
    rpm -Va --nofiles --nodigest

    I am using the below puppet respository

    [puppetlabs]
    name=Puppet Labs Packages
    baseurl=http://yum.puppetlabs.com/el/$releasever/products/$basearch/
    enabled=1
    gpgcheck=1
    gpgkey=http://yum.puppetlabs.com/RPM-GPG-KEY-puppetlabs

    Also my Current ruby version is as below

    ruby 1.8.5 (2006-08-25) [i386-linux]


    Thanks,
    Munna
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Munna S at Jun 25, 2012 at 7:44 am
    Hello Den,

    I just used below puppetlabs repo and i was able to install puppet server
    along with the dependency.

    rpm -ivh
    http://yum.puppetlabs.com/el/5/products/i386/puppetlabs-release-5-1.noarch.rpm

    Thanks for quick help

    Thanks,
    Munna
    On Mon, Jun 25, 2012 at 1:08 PM, Denmat wrote:

    Hi Munna,

    You can find those packages in the EPEL repository.

    See http://fedoraproject.org/wiki/EPEL.

    Den

    On 25/06/2012, at 17:34, Munna S wrote:

    Team,

    I am trying to setup new Puppet master server on Centos 5.4. I am getting
    the below error which running yum install puppet-server

    puppet-2.7.17-1.el5.noarch from puppetlabs has depsolving problems
    --> Missing Dependency: ruby-shadow is needed by package
    puppet-2.7.17-1.el5.noarch (puppetlabs)
    puppet-2.7.17-1.el5.noarch from puppetlabs has depsolving problems
    --> Missing Dependency: ruby-augeas is needed by package
    puppet-2.7.17-1.el5.noarch (puppetlabs)
    Error: Missing Dependency: ruby-augeas is needed by package
    puppet-2.7.17-1.el5.noarch (puppetlabs)
    Error: Missing Dependency: ruby-shadow is needed by package
    puppet-2.7.17-1.el5.noarch (puppetlabs)
    You could try using --skip-broken to work around the problem
    You could try running: package-cleanup --problems
    package-cleanup --dupes
    rpm -Va --nofiles --nodigest

    I am using the below puppet respository

    [puppetlabs]
    name=Puppet Labs Packages
    baseurl=http://yum.puppetlabs.com/el/$releasever/products/$basearch/
    enabled=1
    gpgcheck=1
    gpgkey=http://yum.puppetlabs.com/RPM-GPG-KEY-puppetlabs

    Also my Current ruby version is as below

    ruby 1.8.5 (2006-08-25) [i386-linux]


    Thanks,
    Munna

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedJun 25, '12 at 7:34a
activeJun 25, '12 at 7:44a
posts3
users2
websitepuppetlabs.com

2 users in discussion

Munna S: 2 posts Denmat: 1 post

People

Translate

site design / logo © 2022 Grokbase