FAQ
Old thread, but I ran into the same problem so figured I'll post my
solution here. In my case, I added more verbose logging which pointed me to
the missing "spool" directory. Running the following commands fixed it:

   mkdir -p /usr/share/puppet-dashboard/spool
   chown puppet-dashboard:puppet-dashboard spool

Regards,
James T.
On Monday, November 21, 2011 2:13:27 PM UTC+1, Galed Friedmann wrote:

Anybody? Any ideas?

Thanks again

On Sun, Nov 13, 2011 at 2:45 PM, Galed Friedmann <
galed.friedmann@onavo.com> wrote:
Hi all,
I've created a replication of my puppet environment in order to set it up
in a new location.
I've created an exact replication of my master server which is running
the puppet master, dashboard server, and mysql.

Everything is working fine except for the dashboard. The master is
configured to send reports to dashboard and indeed is sending them, but
looking at production.log in dashboard I see this:

Processing ReportsController#upload (for 127.0.0.1 at 2011-11-13
12:43:26) [POST]
Parameters: {"action"=>"upload", "controller"=>"reports"}
Completed in 1ms (View: 0, DB: 0) | 406 Not Acceptable [
http://localhost/reports/upload]

For every attempt of the master to send a report.
This is a working configuration so I guess I missed something when I
changed the setting of the new server, any idea what might be wrong here?

puppet master configuration:
[master]
storeconfigs = true
dbadapter = mysql
dbuser = ...
dbpassword = ...
dbserver = localhost
dbsocket = /var/run/mysqld/mysqld.sock

reports = store, http
reporturl = http://localhost:3000/reports/upload

Thanks!

--
You received this message because you are subscribed to the Google Groups
"Puppet Users" group.
To view this discussion on the web visit
https://groups.google.com/d/msg/puppet-users/-/mGPKjqlxWY0J.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to
puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at
http://groups.google.com/group/puppet-users?hl=en.
--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/EG58eV8AwFEJ.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Will Turnage at Sep 17, 2013 at 7:51 pm
    I ran into the same issue, and this resolved it. Thanks!
    On Thursday, June 21, 2012 8:04:13 AM UTC-5, James Tan wrote:

    Old thread, but I ran into the same problem so figured I'll post my
    solution here. In my case, I added more verbose logging which pointed me to
    the missing "spool" directory. Running the following commands fixed it:

    mkdir -p /usr/share/puppet-dashboard/spool
    chown puppet-dashboard:puppet-dashboard spool

    Regards,
    James T.
    On Monday, November 21, 2011 2:13:27 PM UTC+1, Galed Friedmann wrote:

    Anybody? Any ideas?

    Thanks again

    On Sun, Nov 13, 2011 at 2:45 PM, Galed Friedmann <galed.f...@onavo.com<javascript:>
    wrote:
    Hi all,
    I've created a replication of my puppet environment in order to set it
    up in a new location.
    I've created an exact replication of my master server which is running
    the puppet master, dashboard server, and mysql.

    Everything is working fine except for the dashboard. The master is
    configured to send reports to dashboard and indeed is sending them, but
    looking at production.log in dashboard I see this:

    Processing ReportsController#upload (for 127.0.0.1 at 2011-11-13
    12:43:26) [POST]
    Parameters: {"action"=>"upload", "controller"=>"reports"}
    Completed in 1ms (View: 0, DB: 0) | 406 Not Acceptable [
    http://localhost/reports/upload]

    For every attempt of the master to send a report.
    This is a working configuration so I guess I missed something when I
    changed the setting of the new server, any idea what might be wrong here?

    puppet master configuration:
    [master]
    storeconfigs = true
    dbadapter = mysql
    dbuser = ...
    dbpassword = ...
    dbserver = localhost
    dbsocket = /var/run/mysqld/mysqld.sock

    reports = store, http
    reporturl = http://localhost:3000/reports/upload

    Thanks!

    --
    You received this message because you are subscribed to the Google
    Groups "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/mGPKjqlxWY0J.
    To post to this group, send email to puppet...@googlegroups.com<javascript:>
    .
    To unsubscribe from this group, send email to
    puppet-users...@googlegroups.com <javascript:>.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedJun 21, '12 at 1:04p
activeSep 17, '13 at 7:51p
posts2
users2
websitepuppetlabs.com

2 users in discussion

Will Turnage: 1 post James Tan: 1 post

People

Translate

site design / logo © 2022 Grokbase