FAQ
Mohamed,

Did you get anywhere with this? I'm running into the exact same issue.

-greg
On Wednesday, November 23, 2011 7:29:34 PM UTC-6, Jacob Helwig wrote:
On 2011-11-23 15:53 , Mohamed Lrhazi wrote:
Thanks Jacob....Did that answer my TypeError as well?
No, a stack trace would help for that.

--
Jacob Helwig
http://about.me/jhelwig
Mohamed.
On Wed, Nov 23, 2011 at 5:28 PM, Jacob Helwig wrote:
On 2011-11-23 13:02 , Mohamed Lrhazi wrote:
am trying this:

scheduled_task { 'Puppet Run':
ensure => present,
enabled => true,
command => 'C:\\ruby187\\bin\\puppet.bat',
arguments => 'agent --verbose --logdest C:\\Temp\puppet.log',
trigger => {
schedule => daily,
#every => 2 # Defaults to 1
#start_date => '2011-08-31', # Defaults to 'today'
start_time => '16:00', # Must be specified
}
}

And getting this error:

err: /Stage[main]/Gu_splunk/Scheduled_task[Puppet Run]/ensure: change
from absent to present failed: Could not set 'present on ensure:
TypeError at /etc/puppet/
environments/windows/modules/gu_splunk/manifests/init.pp:84
--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/cIrGZR2XNjYJ.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Josh Cooper at Jun 21, 2012 at 4:53 pm
    Hi Greg,

    I believe this is issue https://projects.puppetlabs.com/issues/13008, which
    I have fixed in my topic branch and is awaiting to be merged into 2.7.x. It
    would be great if you could try it out and let me know how it goes.

    Josh
    On Thu, Jun 21, 2012 at 9:00 AM, Greg Swift wrote:

    Mohamed,

    Did you get anywhere with this? I'm running into the exact same issue.

    -greg

    On Wednesday, November 23, 2011 7:29:34 PM UTC-6, Jacob Helwig wrote:
    On 2011-11-23 15:53 , Mohamed Lrhazi wrote:
    Thanks Jacob....Did that answer my TypeError as well?
    No, a stack trace would help for that.

    --
    Jacob Helwig
    http://about.me/jhelwig
    Mohamed.
    On Wed, Nov 23, 2011 at 5:28 PM, Jacob Helwig wrote:
    On 2011-11-23 13:02 , Mohamed Lrhazi wrote:
    am trying this:

    scheduled_task { 'Puppet Run':
    ensure => present,
    enabled => true,
    command => 'C:\\ruby187\\bin\\puppet.bat'**,
    arguments => 'agent --verbose --logdest C:\\Temp\puppet.log',
    trigger => {
    schedule => daily,
    #every => 2 # Defaults to 1
    #start_date => '2011-08-31', # Defaults to 'today'
    start_time => '16:00', # Must be specified
    }
    }

    And getting this error:

    err: /Stage[main]/Gu_splunk/**Scheduled_task[Puppet Run]/ensure:
    change
    from absent to present failed: Could not set 'present on ensure:
    TypeError at /etc/puppet/
    environments/windows/modules/**gu_splunk/manifests/init.pp:84
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/cIrGZR2XNjYJ.

    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.


    --
    Josh Cooper
    Developer, Puppet Labs

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Greg Swift at Jun 21, 2012 at 5:46 pm
    I believe you are correct. I removed the arguments key/value pair and it
    ran fine. I'm patching in your changes to try it with the arguments option.

    thank you very much
    On Thursday, June 21, 2012 11:53:40 AM UTC-5, Josh Cooper wrote:

    Hi Greg,

    I believe this is issue https://projects.puppetlabs.com/issues/13008,
    which I have fixed in my topic branch and is awaiting to be merged into
    2.7.x. It would be great if you could try it out and let me know how it
    goes.

    Josh
    On Thu, Jun 21, 2012 at 9:00 AM, Greg Swift wrote:

    Mohamed,

    Did you get anywhere with this? I'm running into the exact same issue.

    -greg

    On Wednesday, November 23, 2011 7:29:34 PM UTC-6, Jacob Helwig wrote:
    On 2011-11-23 15:53 , Mohamed Lrhazi wrote:
    Thanks Jacob....Did that answer my TypeError as well?
    No, a stack trace would help for that.

    --
    Jacob Helwig
    http://about.me/jhelwig
    Mohamed.
    On Wed, Nov 23, 2011 at 5:28 PM, Jacob Helwig wrote:
    On 2011-11-23 13:02 , Mohamed Lrhazi wrote:
    am trying this:

    scheduled_task { 'Puppet Run':
    ensure => present,
    enabled => true,
    command => 'C:\\ruby187\\bin\\puppet.bat'**,
    arguments => 'agent --verbose --logdest C:\\Temp\puppet.log',
    trigger => {
    schedule => daily,
    #every => 2 # Defaults to 1
    #start_date => '2011-08-31', # Defaults to 'today'
    start_time => '16:00', # Must be specified
    }
    }

    And getting this error:

    err: /Stage[main]/Gu_splunk/**Scheduled_task[Puppet Run]/ensure:
    change
    from absent to present failed: Could not set 'present on ensure:
    TypeError at /etc/puppet/
    environments/windows/modules/**gu_splunk/manifests/init.pp:84
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/cIrGZR2XNjYJ.

    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.


    --
    Josh Cooper
    Developer, Puppet Labs
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/tvfDSlvUQ4UJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Greg Swift at Jun 21, 2012 at 5:57 pm
    So.. now I'm getting your error instead of mine.
    On Thursday, June 21, 2012 12:46:08 PM UTC-5, Greg Swift wrote:

    I believe you are correct. I removed the arguments key/value pair and it
    ran fine. I'm patching in your changes to try it with the arguments option.

    thank you very much
    On Thursday, June 21, 2012 11:53:40 AM UTC-5, Josh Cooper wrote:

    Hi Greg,

    I believe this is issue https://projects.puppetlabs.com/issues/13008,
    which I have fixed in my topic branch and is awaiting to be merged into
    2.7.x. It would be great if you could try it out and let me know how it
    goes.

    Josh
    On Thu, Jun 21, 2012 at 9:00 AM, Greg Swift wrote:

    Mohamed,

    Did you get anywhere with this? I'm running into the exact same issue.

    -greg

    On Wednesday, November 23, 2011 7:29:34 PM UTC-6, Jacob Helwig wrote:
    On 2011-11-23 15:53 , Mohamed Lrhazi wrote:
    Thanks Jacob....Did that answer my TypeError as well?
    No, a stack trace would help for that.

    --
    Jacob Helwig
    http://about.me/jhelwig
    Mohamed.
    On Wed, Nov 23, 2011 at 5:28 PM, Jacob Helwig wrote:
    On 2011-11-23 13:02 , Mohamed Lrhazi wrote:
    am trying this:

    scheduled_task { 'Puppet Run':
    ensure => present,
    enabled => true,
    command => 'C:\\ruby187\\bin\\puppet.bat'**,
    arguments => 'agent --verbose --logdest
    C:\\Temp\puppet.log',
    trigger => {
    schedule => daily,
    #every => 2 # Defaults to 1
    #start_date => '2011-08-31', # Defaults to 'today'
    start_time => '16:00', # Must be specified
    }
    }

    And getting this error:

    err: /Stage[main]/Gu_splunk/**Scheduled_task[Puppet Run]/ensure:
    change
    from absent to present failed: Could not set 'present on ensure:
    TypeError at /etc/puppet/
    environments/windows/modules/**gu_splunk/manifests/init.pp:84
    --
    You received this message because you are subscribed to the Google
    Groups "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/cIrGZR2XNjYJ.

    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.


    --
    Josh Cooper
    Developer, Puppet Labs
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/CG9Sa5hf2jYJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Josh Cooper at Jun 21, 2012 at 6:15 pm
    Can you try running with --trace and --debug, and adding the stack trace to the ticket?
    On Jun 21, 2012, at 10:57 AM, Greg Swift wrote:

    So.. now I'm getting your error instead of mine.

    On Thursday, June 21, 2012 12:46:08 PM UTC-5, Greg Swift wrote:
    I believe you are correct. I removed the arguments key/value pair and it ran fine. I'm patching in your changes to try it with the arguments option.

    thank you very much

    On Thursday, June 21, 2012 11:53:40 AM UTC-5, Josh Cooper wrote:
    Hi Greg,

    I believe this is issue https://projects.puppetlabs.com/issues/13008, which I have fixed in my topic branch and is awaiting to be merged into 2.7.x. It would be great if you could try it out and let me know how it goes.

    Josh

    On Thu, Jun 21, 2012 at 9:00 AM, Greg Swift wrote:
    Mohamed,

    Did you get anywhere with this? I'm running into the exact same issue.

    -greg


    On Wednesday, November 23, 2011 7:29:34 PM UTC-6, Jacob Helwig wrote:
    On 2011-11-23 15:53 , Mohamed Lrhazi wrote:
    Thanks Jacob....Did that answer my TypeError as well?
    No, a stack trace would help for that.

    --
    Jacob Helwig
    http://about.me/jhelwig
    Mohamed.
    On Wed, Nov 23, 2011 at 5:28 PM, Jacob Helwig wrote:
    On 2011-11-23 13:02 , Mohamed Lrhazi wrote:
    am trying this:

    scheduled_task { 'Puppet Run':
    ensure => present,
    enabled => true,
    command => 'C:\\ruby187\\bin\\puppet.bat',
    arguments => 'agent --verbose --logdest C:\\Temp\puppet.log',
    trigger => {
    schedule => daily,
    #every => 2 # Defaults to 1
    #start_date => '2011-08-31', # Defaults to 'today'
    start_time => '16:00', # Must be specified
    }
    }

    And getting this error:

    err: /Stage[main]/Gu_splunk/Scheduled_task[Puppet Run]/ensure: change
    from absent to present failed: Could not set 'present on ensure:
    TypeError at /etc/puppet/
    environments/windows/modules/gu_splunk/manifests/init.pp:84
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/cIrGZR2XNjYJ.

    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.



    --
    Josh Cooper
    Developer, Puppet Labs

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/CG9Sa5hf2jYJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Greg Swift at Jun 21, 2012 at 8:02 pm
    first thing in the morning.
    On Thursday, June 21, 2012 1:15:09 PM UTC-5, Josh Cooper wrote:

    Can you try running with --trace and --debug, and adding the stack trace
    to the ticket?

    On Jun 21, 2012, at 10:57 AM, Greg Swift wrote:

    So.. now I'm getting your error instead of mine.
    On Thursday, June 21, 2012 12:46:08 PM UTC-5, Greg Swift wrote:

    I believe you are correct. I removed the arguments key/value pair and it
    ran fine. I'm patching in your changes to try it with the arguments option.

    thank you very much
    On Thursday, June 21, 2012 11:53:40 AM UTC-5, Josh Cooper wrote:

    Hi Greg,

    I believe this is issue https://projects.puppetlabs.com/issues/13008,
    which I have fixed in my topic branch and is awaiting to be merged into
    2.7.x. It would be great if you could try it out and let me know how it
    goes.

    Josh
    On Thu, Jun 21, 2012 at 9:00 AM, Greg Swift wrote:

    Mohamed,

    Did you get anywhere with this? I'm running into the exact same issue.

    -greg

    On Wednesday, November 23, 2011 7:29:34 PM UTC-6, Jacob Helwig wrote:
    On 2011-11-23 15:53 , Mohamed Lrhazi wrote:
    Thanks Jacob....Did that answer my TypeError as well?
    No, a stack trace would help for that.

    --
    Jacob Helwig
    http://about.me/jhelwig
    Mohamed.
    On Wed, Nov 23, 2011 at 5:28 PM, Jacob Helwig wrote:
    On 2011-11-23 13:02 , Mohamed Lrhazi wrote:
    am trying this:

    scheduled_task { 'Puppet Run':
    ensure => present,
    enabled => true,
    command => 'C:\\ruby187\\bin\\puppet.bat'**,
    arguments => 'agent --verbose --logdest
    C:\\Temp\puppet.log',
    trigger => {
    schedule => daily,
    #every => 2 # Defaults to 1
    #start_date => '2011-08-31', # Defaults to 'today'
    start_time => '16:00', # Must be specified
    }
    }

    And getting this error:

    err: /Stage[main]/Gu_splunk/**Scheduled_task[Puppet Run]/ensure:
    change
    from absent to present failed: Could not set 'present on ensure:
    TypeError at /etc/puppet/
    environments/windows/modules/**gu_splunk/manifests/init.pp:84
    --
    You received this message because you are subscribed to the Google
    Groups "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/cIrGZR2XNjYJ.

    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.


    --
    Josh Cooper
    Developer, Puppet Labs

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/CG9Sa5hf2jYJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/wXTf4vSzI1MJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Greg Swift at Jun 22, 2012 at 7:20 pm
    attached to the ticket. I won't be able to work on this for about a week
    though.. other priority just came up. But let me know and when I can get
    back on it I will.
    On Thursday, June 21, 2012 3:02:38 PM UTC-5, Greg Swift wrote:

    first thing in the morning.
    On Thursday, June 21, 2012 1:15:09 PM UTC-5, Josh Cooper wrote:

    Can you try running with --trace and --debug, and adding the stack trace
    to the ticket?

    On Jun 21, 2012, at 10:57 AM, Greg Swift wrote:

    So.. now I'm getting your error instead of mine.
    On Thursday, June 21, 2012 12:46:08 PM UTC-5, Greg Swift wrote:

    I believe you are correct. I removed the arguments key/value pair and
    it ran fine. I'm patching in your changes to try it with the arguments
    option.

    thank you very much
    On Thursday, June 21, 2012 11:53:40 AM UTC-5, Josh Cooper wrote:

    Hi Greg,

    I believe this is issue https://projects.puppetlabs.com/issues/13008,
    which I have fixed in my topic branch and is awaiting to be merged into
    2.7.x. It would be great if you could try it out and let me know how it
    goes.

    Josh
    On Thu, Jun 21, 2012 at 9:00 AM, Greg Swift wrote:

    Mohamed,

    Did you get anywhere with this? I'm running into the exact same issue.

    -greg

    On Wednesday, November 23, 2011 7:29:34 PM UTC-6, Jacob Helwig wrote:
    On 2011-11-23 15:53 , Mohamed Lrhazi wrote:
    Thanks Jacob....Did that answer my TypeError as well?
    No, a stack trace would help for that.

    --
    Jacob Helwig
    http://about.me/jhelwig
    Mohamed.
    On Wed, Nov 23, 2011 at 5:28 PM, Jacob Helwig wrote:
    On 2011-11-23 13:02 , Mohamed Lrhazi wrote:
    am trying this:

    scheduled_task { 'Puppet Run':
    ensure => present,
    enabled => true,
    command => 'C:\\ruby187\\bin\\puppet.bat'**,
    arguments => 'agent --verbose --logdest
    C:\\Temp\puppet.log',
    trigger => {
    schedule => daily,
    #every => 2 # Defaults to 1
    #start_date => '2011-08-31', # Defaults to 'today'
    start_time => '16:00', # Must be specified
    }
    }

    And getting this error:

    err: /Stage[main]/Gu_splunk/**Scheduled_task[Puppet Run]/ensure:
    change
    from absent to present failed: Could not set 'present on ensure:
    TypeError at /etc/puppet/
    environments/windows/modules/**gu_splunk/manifests/init.pp:84
    --
    You received this message because you are subscribed to the Google
    Groups "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/cIrGZR2XNjYJ.

    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.


    --
    Josh Cooper
    Developer, Puppet Labs

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/CG9Sa5hf2jYJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/Gs01u9mrFhEJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Josh Cooper at Jun 22, 2012 at 7:23 pm
    Thanks Greg. Can you attach the manifest you are using (with the
    arguments) to the ticket?
    On Fri, Jun 22, 2012 at 12:20 PM, Greg Swift wrote:
    attached to the ticket.  I won't be able to work on this for about a week
    though.. other priority just came up.  But let me know and when I can get
    back on it I will.

    On Thursday, June 21, 2012 3:02:38 PM UTC-5, Greg Swift wrote:

    first thing in the morning.
    On Thursday, June 21, 2012 1:15:09 PM UTC-5, Josh Cooper wrote:

    Can you try running with --trace and --debug, and adding the stack trace
    to the ticket?

    On Jun 21, 2012, at 10:57 AM, Greg Swift  wrote:

    So.. now I'm getting your error instead of mine.
    On Thursday, June 21, 2012 12:46:08 PM UTC-5, Greg Swift wrote:

    I believe you are correct.  I removed the arguments key/value pair and
    it ran fine.  I'm patching in your changes to try it with the arguments
    option.

    thank you very much
    On Thursday, June 21, 2012 11:53:40 AM UTC-5, Josh Cooper wrote:

    Hi Greg,

    I believe this is issue https://projects.puppetlabs.com/issues/13008,
    which I have fixed in my topic branch and is awaiting to be merged into
    2.7.x. It would be great if you could try it out and let me know how it
    goes.

    Josh
    On Thu, Jun 21, 2012 at 9:00 AM, Greg Swift wrote:

    Mohamed,

    Did you get anywhere with this?  I'm running into the exact same
    issue.

    -greg

    On Wednesday, November 23, 2011 7:29:34 PM UTC-6, Jacob Helwig wrote:
    On 2011-11-23 15:53 , Mohamed Lrhazi wrote:
    Thanks Jacob....Did that answer my TypeError  as well?
    No, a stack trace would help for that.

    --
    Jacob Helwig
    http://about.me/jhelwig
    Mohamed.
    On Wed, Nov 23, 2011 at 5:28 PM, Jacob Helwig wrote:
    On 2011-11-23 13:02 , Mohamed Lrhazi wrote:
    am trying this:

    scheduled_task { 'Puppet Run':
    ensure    => present,
    enabled   => true,
    command   => 'C:\\ruby187\\bin\\puppet.bat',
    arguments => 'agent --verbose --logdest
    C:\\Temp\puppet.log',
    trigger   => {
    schedule   => daily,
    #every      => 2             # Defaults to 1
    #start_date => '2011-08-31', # Defaults to 'today'
    start_time => '16:00',      # Must be specified
    }
    }

    And getting this error:

    err: /Stage[main]/Gu_splunk/Scheduled_task[Puppet Run]/ensure:
    change
    from absent to present failed: Could not set 'present on ensure:
    TypeError at /etc/puppet/
    environments/windows/modules/gu_splunk/manifests/init.pp:84
    --
    You received this message because you are subscribed to the Google
    Groups "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/cIrGZR2XNjYJ.

    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.



    --
    Josh Cooper
    Developer, Puppet Labs
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/CG9Sa5hf2jYJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/Gs01u9mrFhEJ.

    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.


    --
    Josh Cooper
    Developer, Puppet Labs

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Greg Swift at Jul 5, 2012 at 2:08 pm
    the manifest is now attached to the ticket
    On Friday, June 22, 2012 2:23:31 PM UTC-5, Josh Cooper wrote:

    Thanks Greg. Can you attach the manifest you are using (with the
    arguments) to the ticket?
    On Fri, Jun 22, 2012 at 12:20 PM, Greg Swift wrote:
    attached to the ticket. I won't be able to work on this for about a week
    though.. other priority just came up. But let me know and when I can get
    back on it I will.

    On Thursday, June 21, 2012 3:02:38 PM UTC-5, Greg Swift wrote:

    first thing in the morning.
    On Thursday, June 21, 2012 1:15:09 PM UTC-5, Josh Cooper wrote:

    Can you try running with --trace and --debug, and adding the stack
    trace
    to the ticket?

    On Jun 21, 2012, at 10:57 AM, Greg Swift wrote:

    So.. now I'm getting your error instead of mine.
    On Thursday, June 21, 2012 12:46:08 PM UTC-5, Greg Swift wrote:

    I believe you are correct. I removed the arguments key/value pair
    and
    it ran fine. I'm patching in your changes to try it with the
    arguments
    option.

    thank you very much
    On Thursday, June 21, 2012 11:53:40 AM UTC-5, Josh Cooper wrote:

    Hi Greg,

    I believe this is issue https://projects.puppetlabs.com/issues/13008,
    which I have fixed in my topic branch and is awaiting to be merged
    into
    2.7.x. It would be great if you could try it out and let me know how
    it
    goes.

    Josh
    On Thu, Jun 21, 2012 at 9:00 AM, Greg Swift wrote:

    Mohamed,

    Did you get anywhere with this? I'm running into the exact same
    issue.

    -greg


    On Wednesday, November 23, 2011 7:29:34 PM UTC-6, Jacob Helwig
    wrote:
    On 2011-11-23 15:53 , Mohamed Lrhazi wrote:
    Thanks Jacob....Did that answer my TypeError as well?
    No, a stack trace would help for that.

    --
    Jacob Helwig
    http://about.me/jhelwig
    Mohamed.
    On Wed, Nov 23, 2011 at 5:28 PM, Jacob Helwig wrote:
    On 2011-11-23 13:02 , Mohamed Lrhazi wrote:
    am trying this:

    scheduled_task { 'Puppet Run':
    ensure => present,
    enabled => true,
    command => 'C:\\ruby187\\bin\\puppet.bat',
    arguments => 'agent --verbose --logdest
    C:\\Temp\puppet.log',
    trigger => {
    schedule => daily,
    #every => 2 # Defaults to 1
    #start_date => '2011-08-31', # Defaults to 'today'
    start_time => '16:00', # Must be specified
    }
    }

    And getting this error:

    err: /Stage[main]/Gu_splunk/Scheduled_task[Puppet Run]/ensure:
    change
    from absent to present failed: Could not set 'present on
    ensure:
    TypeError at /etc/puppet/
    environments/windows/modules/gu_splunk/manifests/init.pp:84
    --
    You received this message because you are subscribed to the Google
    Groups "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/cIrGZR2XNjYJ.

    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.



    --
    Josh Cooper
    Developer, Puppet Labs
    --
    You received this message because you are subscribed to the Google
    Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/CG9Sa5hf2jYJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/Gs01u9mrFhEJ.

    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.


    --
    Josh Cooper
    Developer, Puppet Labs
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/BJ-kUP8TRH8J.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedJun 21, '12 at 4:05p
activeJul 5, '12 at 2:08p
posts9
users2
websitepuppetlabs.com

2 users in discussion

Greg Swift: 6 posts Josh Cooper: 3 posts

People

Translate

site design / logo © 2022 Grokbase