FAQ
If your hosts do not appear to be reporting, and you're seeing some
background tasks pending (top left in the puppet dashboard web gui), then
you probably need to start the "delayed_job" tasks on your puppet dashboard
server in order to process the reports. Run this:

*env RAILS_ENV=production /usr/share/puppet-dashboard/script/delayed_job -p
dashboard -n 4 -m start*

where -n 4 refers to the number of cores.

I added this line to /etc/init.d/puppet-dashboard so it gets fired after
dashboard starts, and so I don't forget to run it. Not sure if this is the
best method, but it works for me.

See
http://docs.puppetlabs.com/dashboard/manual/1.2/bootstrapping.html#starting-and-managing-delayed-job-workers.
On Thursday, January 13, 2011 9:10:11 AM UTC-5, (unknown) wrote:

Patrick,



This is what I have setup in the puppet.conf files on the master and
client. Both servers are running puppet 2.6.4



On the Master in /etc/puppet/puppet.conf



[master]

reports = http, store

reporturl = http://fedorahost.ocfl.net:3000/reports

node_terminus = exec

external_nodes = /etc/puppet/bin/external_node



in external_node I have changed the localhost default to:



BASE = “http://fedorahost.ocfl.net:3000”



On the client in /etc/puppet/puppet.conf



[agent]

report = true



Thanks for your help. I hope you see something I might have done wrong.



Mike







*From:* puppet-users@googlegroups.com [mailto:
puppet-users@googlegroups.com] *On Behalf Of *Patrick
*Sent:* Wednesday, January 12, 2011 5:02 PM
*To:* puppet-users@googlegroups.com
*Subject:* Re: [Puppet Users] Send Reports to Puppet Dashboard





On Jan 12, 2011, at 11:37 AM, wrote:



Hi Daniel,



I have already done the setup which you mention below. I followed the
puppet-dashboard configuration guide to the tee,

which is why I’m surprised that this feature is not working. I have
verified that the puppet.conf entries on the client and

master are correct. I’m wondering if this problem is a bug? Thanks for
your help.



At this point, I don't think you're going to get much help unless you post
a lot more from your puppet.conf files. For instance, we should be seeing
section names. At this point, you're saying you did everything right, but
evidently something isn't right so that doesn't help us much.

--
You received this message because you are subscribed to the Google Groups
"Puppet Users" group.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to
puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at
http://groups.google.com/group/puppet-users?hl=en.

_____________________________________________________________________
PLEASE NOTE: Florida has a very broad public records law (F. S. 119).
All e-mails to and from County Officials are kept as a public record.
Your e-mail communications, including your e-mail address may be
disclosed to the public and media at any time.


On Thursday, January 13, 2011 9:10:11 AM UTC-5, (unknown) wrote:

Patrick,



This is what I have setup in the puppet.conf files on the master and
client. Both servers are running puppet 2.6.4



On the Master in /etc/puppet/puppet.conf



[master]

reports = http, store

reporturl = http://fedorahost.ocfl.net:3000/reports

node_terminus = exec

external_nodes = /etc/puppet/bin/external_node



in external_node I have changed the localhost default to:



BASE = “http://fedorahost.ocfl.net:3000”



On the client in /etc/puppet/puppet.conf



[agent]

report = true



Thanks for your help. I hope you see something I might have done wrong.



Mike







*From:* puppet-users@googlegroups.com [mailto:
puppet-users@googlegroups.com] *On Behalf Of *Patrick
*Sent:* Wednesday, January 12, 2011 5:02 PM
*To:* puppet-users@googlegroups.com
*Subject:* Re: [Puppet Users] Send Reports to Puppet Dashboard





On Jan 12, 2011, at 11:37 AM, wrote:



Hi Daniel,



I have already done the setup which you mention below. I followed the
puppet-dashboard configuration guide to the tee,

which is why I’m surprised that this feature is not working. I have
verified that the puppet.conf entries on the client and

master are correct. I’m wondering if this problem is a bug? Thanks for
your help.



At this point, I don't think you're going to get much help unless you post
a lot more from your puppet.conf files. For instance, we should be seeing
section names. At this point, you're saying you did everything right, but
evidently something isn't right so that doesn't help us much.

--
You received this message because you are subscribed to the Google Groups
"Puppet Users" group.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to
puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at
http://groups.google.com/group/puppet-users?hl=en.

_____________________________________________________________________
PLEASE NOTE: Florida has a very broad public records law (F. S. 119).
All e-mails to and from County Officials are kept as a public record.
Your e-mail communications, including your e-mail address may be
disclosed to the public and media at any time.


On Thursday, January 13, 2011 9:10:11 AM UTC-5, (unknown) wrote:

Patrick,



This is what I have setup in the puppet.conf files on the master and
client. Both servers are running puppet 2.6.4



On the Master in /etc/puppet/puppet.conf



[master]

reports = http, store

reporturl = http://fedorahost.ocfl.net:3000/reports

node_terminus = exec

external_nodes = /etc/puppet/bin/external_node



in external_node I have changed the localhost default to:



BASE = “http://fedorahost.ocfl.net:3000”



On the client in /etc/puppet/puppet.conf



[agent]

report = true



Thanks for your help. I hope you see something I might have done wrong.



Mike







*From:* puppet-users@googlegroups.com [mailto:
puppet-users@googlegroups.com] *On Behalf Of *Patrick
*Sent:* Wednesday, January 12, 2011 5:02 PM
*To:* puppet-users@googlegroups.com
*Subject:* Re: [Puppet Users] Send Reports to Puppet Dashboard





On Jan 12, 2011, at 11:37 AM, wrote:



Hi Daniel,



I have already done the setup which you mention below. I followed the
puppet-dashboard configuration guide to the tee,

which is why I’m surprised that this feature is not working. I have
verified that the puppet.conf entries on the client and

master are correct. I’m wondering if this problem is a bug? Thanks for
your help.



At this point, I don't think you're going to get much help unless you post
a lot more from your puppet.conf files. For instance, we should be seeing
section names. At this point, you're saying you did everything right, but
evidently something isn't right so that doesn't help us much.

--
You received this message because you are subscribed to the Google Groups
"Puppet Users" group.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to
puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at
http://groups.google.com/group/puppet-users?hl=en.

_____________________________________________________________________
PLEASE NOTE: Florida has a very broad public records law (F. S. 119).
All e-mails to and from County Officials are kept as a public record.
Your e-mail communications, including your e-mail address may be
disclosed to the public and media at any time.
--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/tErtkInULnsJ.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedJun 20, '12 at 2:58p
activeJun 20, '12 at 2:58p
posts1
users1
websitepuppetlabs.com

1 user in discussion

Banjer: 1 post

People

Translate

site design / logo © 2022 Grokbase