FAQ
Updated to puppet 2.7.16 and Facter 1.6.10 and I am seeing errors on all my
10.6 and 10.7 machines -

err: Could not create resources for managing Puppet's files and directories
in sections [:main, :agent, :ssl]: undefined method `strip' for
#<StringIO:0x1022ab1a8>
info: Retrieving plugin
err: Could not run Puppet configuration client: Could not retrieve local
facts: undefined method `strip' for #<StringIO:0x101f069a8>

My previously installed versions were 2.7.14 and 1.6.6. Anyone seeing
anything similar to this? I haven't made any other changes to my
deployment.

Thanks!


--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/1-4NW5QrSFYJ.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedJun 20, '12 at 9:25a
activeJun 20, '12 at 9:25a
posts1
users1
websitepuppetlabs.com

1 user in discussion

R.yeo: 1 post

People

Translate

site design / logo © 2022 Grokbase