FAQ
Hi All,

I'm trying to get a feel for the puppetlabs-openstack module by
deploying the openstack::all class using the example in the readme.
Puppet master using puppet 2.7.14 on Debian Squeeze, client node
2.7.11 on Ubuntu 12.04. Using module and dependencies from the forge.

I get this:

err: Could not retrieve catalog from remote server: Error 400 on
SERVER: Puppet::Parser::AST::Resource failed with error ArgumentError:
Invalid resource type keystone_tenant at
/etc/puppet/environments/jon_test/modules/keystone/manifests/roles/admin.pp:43
on node <foo>

I tried replacing the puppet forge version of keystone with latest
github and got same error. I'm deeply puzzled by this as I know
people are using this, but likewise can't think what I could have done
to cause an error there and google claims never to have seen the
phrase "Invalid resource type keystone_tenant".

Any suggestions?

Thanks,
-Jon

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedJun 19, '12 at 3:04p
activeJun 19, '12 at 3:04p
posts1
users1
websitepuppetlabs.com

1 user in discussion

Jonathan Proulx: 1 post

People

Translate

site design / logo © 2022 Grokbase