FAQ
Hi,

I'm also having this issue running puppet-2.7.16 & puppet-dashboard-1.2.9
on CentOS 6.2. Has there been any solution to this yet besides running
redundant vhosts?

In either case, can you please post your apache vhost configuration files?
On Monday, April 11, 2011 12:55:10 PM UTC-4, Mohamed wrote:

I did not find any reference.... I just added a second apache virtual
server to do http on port 80.
On Mon, Apr 11, 2011 at 12:14 PM, Patrick wrote:
Bump. Anyone know the answer? Can puppet use https to post reports?
I'm having trouble sending reports using https too, although I haven't yet
found anything useful in the logs.
On Mar 21, 2011, at 9:41 PM, Mohamed Lrhazi wrote:

I enabled debug log level in apache virtual and it seems like
puppetmaster is trying to speak http, instead of https.
Is https not supported for posting reports?

[Tue Mar 22 00:39:43 2011] [debug] ssl_engine_io.c(1819): OpenSSL:
read 11/11 bytes from BIO#2b225d284100 [mem: 2b225d2f9650] (BIO dump
follows)
[Tue Mar 22 00:39:43 2011] [debug] ssl_engine_io.c(1766):
+-------------------------------------------------------------------------+
[Tue Mar 22 00:39:43 2011] [debug] ssl_engine_io.c(1791): | 0000: 50
4f 53 54 20 2f 72 65-70 6f 72 POST /repor |
[Tue Mar 22 00:39:43 2011] [debug] ssl_engine_io.c(1797):
+-------------------------------------------------------------------------+
[Tue Mar 22 00:39:43 2011] [debug] ssl_engine_kernel.c(1838): OpenSSL:
Exit: error in SSLv2/v3 read client hello A
[Tue Mar 22 00:39:43 2011] [info] [client 141.161.245.113] SSL
handshake failed: HTTP spoken on HTTPS port; trying to send HTML error
page
[Tue Mar 22 00:39:43 2011] [info] SSL Library Error: 336027804
error:1407609C:SSL routines:SSL23_GET_CLIENT_HELLO:http request
speaking HTTP to HTTPS port!?


On Tue, Mar 22, 2011 at 12:28 AM, Mohamed Lrhazi wrote:
If I run the dash-board directly, with built-in web-server, on default
port, and remove the reporturl , reports are posted successfully!

Any idea what I am missing for a behind apache/Phusion setup?

Thanks a lot.
Mohamed.
On Mon, Mar 21, 2011 at 7:12 PM, Mohamed Lrhazi wrote:
[master]
reports = log, store, http
reporturl = https://puppet-test.uis.example.com/reports/upload

am running dashboar in the same host as puppetmaster, which is
puppet-test, both behind apache/phusion.

reports fail and master logs:

Report http failed: wrong status line: "<!DOCTYPE HTML PUBLIC
\"-//IETF//DTD HTML 2.0//EN\">"

How can I furthe rdebug this? am using dashboard for a github checkout
and puppet 2.6.3


Thanks a lot.
Mohamed.
--
You received this message because you are subscribed to the Google
Groups "Puppet Users" group.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to
puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at
http://groups.google.com/group/puppet-users?hl=en.
--
You received this message because you are subscribed to the Google
Groups "Puppet Users" group.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to
puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at
http://groups.google.com/group/puppet-users?hl=en.
--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/wwnktt7LihAJ.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Jo Rhett at Jun 16, 2012 at 12:45 am
    Michael, I would configure report delivery via http and user access via https. Simple "Allow" rules for your host netblocks plus a rewrite to https based on the browser-agent would meet your needs. It WFM ;-)
    On Jun 15, 2012, at 9:28 AM, Michael Altfield wrote:
    I'm also having this issue running puppet-2.7.16 & puppet-dashboard-1.2.9 on CentOS 6.2. Has there been any solution to this yet besides running redundant vhosts?

    In either case, can you please post your apache vhost configuration files?

    On Monday, April 11, 2011 12:55:10 PM UTC-4, Mohamed wrote:
    I did not find any reference.... I just added a second apache virtual
    server to do http on port 80.
    On Mon, Apr 11, 2011 at 12:14 PM, Patrick wrote:
    Bump. Anyone know the answer? Can puppet use https to post reports? I'm having trouble sending reports using https too, although I haven't yet found anything useful in the logs.
    On Mar 21, 2011, at 9:41 PM, Mohamed Lrhazi wrote:

    I enabled debug log level in apache virtual and it seems like
    puppetmaster is trying to speak http, instead of https.
    Is https not supported for posting reports?

    [Tue Mar 22 00:39:43 2011] [debug] ssl_engine_io.c(1819): OpenSSL:
    read 11/11 bytes from BIO#2b225d284100 [mem: 2b225d2f9650] (BIO dump
    follows)
    [Tue Mar 22 00:39:43 2011] [debug] ssl_engine_io.c(1766):
    +-------------------------------------------------------------------------+
    [Tue Mar 22 00:39:43 2011] [debug] ssl_engine_io.c(1791): | 0000: 50
    4f 53 54 20 2f 72 65-70 6f 72 POST /repor |
    [Tue Mar 22 00:39:43 2011] [debug] ssl_engine_io.c(1797):
    +-------------------------------------------------------------------------+
    [Tue Mar 22 00:39:43 2011] [debug] ssl_engine_kernel.c(1838): OpenSSL:
    Exit: error in SSLv2/v3 read client hello A
    [Tue Mar 22 00:39:43 2011] [info] [client 141.161.245.113] SSL
    handshake failed: HTTP spoken on HTTPS port; trying to send HTML error
    page
    [Tue Mar 22 00:39:43 2011] [info] SSL Library Error: 336027804
    error:1407609C:SSL routines:SSL23_GET_CLIENT_HELLO:http request
    speaking HTTP to HTTPS port!?


    On Tue, Mar 22, 2011 at 12:28 AM, Mohamed Lrhazi wrote:
    If I run the dash-board directly, with built-in web-server, on default
    port, and remove the reporturl , reports are posted successfully!

    Any idea what I am missing for a behind apache/Phusion setup?

    Thanks a lot.
    Mohamed.
    On Mon, Mar 21, 2011 at 7:12 PM, Mohamed Lrhazi wrote:
    [master]
    reports = log, store, http
    reporturl = https://puppet-test.uis.example.com/reports/upload

    am running dashboar in the same host as puppetmaster, which is
    puppet-test, both behind apache/phusion.

    reports fail and master logs:

    Report http failed: wrong status line: "<!DOCTYPE HTML PUBLIC
    \"-//IETF//DTD HTML 2.0//EN\">"

    How can I furthe rdebug this? am using dashboard for a github checkout
    and puppet 2.6.3


    Thanks a lot.
    Mohamed.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/wwnktt7LihAJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
    --
    Jo Rhett
    Net Consonance : net philanthropy to improve open source and internet projects.



    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedJun 15, '12 at 4:28p
activeJun 16, '12 at 12:45a
posts2
users2
websitepuppetlabs.com

2 users in discussion

Jo Rhett: 1 post Michael Altfield: 1 post

People

Translate

site design / logo © 2022 Grokbase