FAQ
Sometimes "facter --yaml" doesn't list all the values specified on the
command line. I can't find rhyme nor reason why. Here's a demo to
show what I mean:

# facter --version
1.5.7

# facter --yaml fqdn macaddress lsbdistcodename
---
fqdn: my.host.name.example.com
lsbdistcodename: squeeze
macaddress: "00:00:00:00:00:00"

We had been using the above command for a while to extract values for
a shell script. However we recently discovered that when we have a
Linux box who's primary NIC is "br123" (a bridge device) that the
macaddress fact shows up as "all zeros" like above. (I consider this a
bug but... that's not the point). Luckily macaddress_eth0 shows the
real MAC address no matter what. Therefore, we made the simple code
change to use the macaddress_eth0 fact instead. However now facter
goes silent on most of the values:

# facter --yaml fqdn macaddress_eth0 lsbdistcodename
---
fqdn: my.host.name.example.com
macaddress_eth0:
lsbdistcodename:

This seems to be just related to facts on the command line. If I do a
plain "facter --yaml" I see all the values as expected. See?

# facter --yaml | egrep '^ (fqdn|macaddress_eth0|lsbdistcodename|macaddress):'
lsbdistcodename: squeeze
macaddress_eth0: 00:12:a6:07:13:92
macaddress: "00:00:00:00:00:00"
fqdn: my.host.name.example.com


Is this a bug or a feature? Is there a workaround?

Thanks in advance,
Tom

P.S. macaddress and fqdn changed for obvious reasons.

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Nan Liu at Jun 14, 2012 at 4:32 pm

    On Thu, Jun 14, 2012 at 8:27 AM, Tom Limoncelli wrote:
    Sometimes "facter --yaml" doesn't list all the values specified on the
    command line.  I can't find rhyme nor reason why.  Here's a demo to
    show what I mean:

    # facter --version
    1.5.7

    # facter --yaml fqdn macaddress lsbdistcodename
    ---
    fqdn: my.host.name.example.com
    lsbdistcodename: squeeze
    macaddress: "00:00:00:00:00:00"

    We had been using the above command for a while to extract values for
    a shell script.  However we recently discovered that when we have a
    Linux box who's primary NIC is "br123" (a bridge device) that the
    macaddress fact shows up as "all zeros" like above. (I consider this a
    bug but... that's not the point).  Luckily macaddress_eth0 shows the
    real MAC address no matter what.  Therefore, we made the simple code
    change to use the macaddress_eth0 fact instead.  However now facter
    goes silent on most of the values:

    # facter --yaml fqdn macaddress_eth0 lsbdistcodename
    ---
    fqdn: my.host.name.example.com
    macaddress_eth0:
    lsbdistcodename:

    This seems to be just related to facts on the command line.  If I do a
    plain "facter --yaml" I see all the values as expected.    See?

    # facter --yaml | egrep '^  (fqdn|macaddress_eth0|lsbdistcodename|macaddress):'
    lsbdistcodename: squeeze
    macaddress_eth0: 00:12:a6:07:13:92
    macaddress: "00:00:00:00:00:00"
    fqdn: my.host.name.example.com


    Is this a bug or a feature?  Is there a workaround?
    I'm think it's a bug fixed in facter 1.5.8.

    Nan

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedJun 14, '12 at 3:27p
activeJun 14, '12 at 4:32p
posts2
users2
websitepuppetlabs.com

2 users in discussion

Nan Liu: 1 post Tom Limoncelli: 1 post

People

Translate

site design / logo © 2022 Grokbase