FAQ
Hey guys,

Relatively new to Puppet and I'm trying to setup tagmail to send all emails
to me: at one point I'll filter that down to errors and whatnot (based on
tags) but for now I just want to get it working.

Master Puppet server is setup with Passengers, all works well:

/etc/puppet/puppet.conf
[main]
# The Puppet log directory.
# The default value is '$vardir/log'.
logdir = /var/log/puppet

# Where Puppet PID files are kept.
# The default value is '$vardir/run'.
rundir = /var/run/puppet

# Where SSL certificates are kept.
# The default value is '$confdir/ssl'.
ssldir = /etc/puppet/ssl

[agent]
# The file in which puppetd stores a list of the classes
# associated with the retrieved configuratiion. Can be loaded in
# the separate ``puppet`` executable using the ``--loadclasses``
# option.
# The default value is '$confdir/classes.txt'.
classfile = $vardir/classes.txt

# Where puppetd caches the local configuration. An
# extension indicating the cache format is added automatically.
# The default value is '$confdir/localconfig'.
localconfig = $vardir/localconfig

# Turn on Reporting
report = true

[master]
reports = tagmail
ssl_client_header = SSL_CLIENT_S_DN
ssl_client_verify_header = SSL_CLIENT_VERIFY

And my /etc/puppet/tagmail.conf:
all: my@email.com

On the slave, I have this setup in my puppet.conf:
[main]
# The Puppet log directory.
# The default value is '$vardir/log'.
logdir = /var/log/puppet

# Where Puppet PID files are kept.
# The default value is '$vardir/run'.
rundir = /var/run/puppet

# Where SSL certificates are kept.
# The default value is '$confdir/ssl'.
ssldir = $vardir/ssl

# Stuff
server = puppet

[agent]
# The file in which puppetd stores a list of the classes
# associated with the retrieved configuratiion. Can be loaded in
# the separate ``puppet`` executable using the ``--loadclasses``
# option.
# The default value is '$confdir/classes.txt'.
classfile = $vardir/classes.txt

# Where puppetd caches the local configuration. An
# extension indicating the cache format is added automatically.
# The default value is '$confdir/localconfig'.
localconfig = $vardir/localconfig

# Enable Reporting
report = true



The reporting seems to work fine, my /var/lib/puppet/reports directory is
populated every time the agent is run. But I never receive an email, and
I've checked the /var/log/maillog (no event occurs).

I'm sure I'm missing something stupid here -- been banging my head on it
for awhile. Any idea?

Thanks,

Jason

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/i1l6ylp8XXsJ.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Darin Perusich at Jun 12, 2012 at 6:58 pm
    Add tagmail to reports in puppet.conf on the server.

    --
    Later,
    Darin

    On Tue, Jun 12, 2012 at 2:49 PM, Jason Knudsen wrote:
    Hey guys,

    Relatively new to Puppet and I'm trying to setup tagmail to send all emails
    to me: at one point I'll filter that down to errors and whatnot (based on
    tags) but for now I just want to get it working.

    Master Puppet server is setup with Passengers, all works well:

    /etc/puppet/puppet.conf
    [main]
    # The Puppet log directory.
    # The default value is '$vardir/log'.
    logdir = /var/log/puppet

    # Where Puppet PID files are kept.
    # The default value is '$vardir/run'.
    rundir = /var/run/puppet

    # Where SSL certificates are kept.
    # The default value is '$confdir/ssl'.
    ssldir = /etc/puppet/ssl

    [agent]
    # The file in which puppetd stores a list of the classes
    # associated with the retrieved configuratiion.  Can be loaded in
    # the separate ``puppet`` executable using the ``--loadclasses``
    # option.
    # The default value is '$confdir/classes.txt'.
    classfile = $vardir/classes.txt

    # Where puppetd caches the local configuration.  An
    # extension indicating the cache format is added automatically.
    # The default value is '$confdir/localconfig'.
    localconfig = $vardir/localconfig

    # Turn on Reporting
    report = true

    [master]
    reports = tagmail
    ssl_client_header = SSL_CLIENT_S_DN
    ssl_client_verify_header = SSL_CLIENT_VERIFY

    And my /etc/puppet/tagmail.conf:
    all: my@email.com

    On the slave, I have this setup in my puppet.conf:
    [main]
    # The Puppet log directory.
    # The default value is '$vardir/log'.
    logdir = /var/log/puppet

    # Where Puppet PID files are kept.
    # The default value is '$vardir/run'.
    rundir = /var/run/puppet

    # Where SSL certificates are kept.
    # The default value is '$confdir/ssl'.
    ssldir = $vardir/ssl

    # Stuff
    server = puppet

    [agent]
    # The file in which puppetd stores a list of the classes
    # associated with the retrieved configuratiion.  Can be loaded in
    # the separate ``puppet`` executable using the ``--loadclasses``
    # option.
    # The default value is '$confdir/classes.txt'.
    classfile = $vardir/classes.txt

    # Where puppetd caches the local configuration.  An
    # extension indicating the cache format is added automatically.
    # The default value is '$confdir/localconfig'.
    localconfig = $vardir/localconfig

    # Enable Reporting
    report = true



    The reporting seems to work fine, my /var/lib/puppet/reports directory is
    populated every time the agent is run. But I never receive an email, and
    I've checked the /var/log/maillog (no event occurs).

    I'm sure I'm missing something stupid here -- been banging my head on it for
    awhile. Any idea?

    Thanks,

    Jason

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/i1l6ylp8XXsJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Jason Knudsen at Jun 12, 2012 at 7:04 pm
    Hey Darin,

    Appreicate the quick response. It's there, in /etc/puppet/puppet.conf on
    the master:

    [master]
    reports = tagmail
    ssl_client_header = SSL_CLIENT_S_DN
    ssl_client_verify_header = SSL_CLIENT_VERIFY
    On Tuesday, June 12, 2012 2:58:50 PM UTC-4, Darin Perusich wrote:

    Add tagmail to reports in puppet.conf on the server.

    --
    Later,
    Darin

    On Tue, Jun 12, 2012 at 2:49 PM, Jason Knudsen wrote:
    Hey guys,

    Relatively new to Puppet and I'm trying to setup tagmail to send all emails
    to me: at one point I'll filter that down to errors and whatnot (based on
    tags) but for now I just want to get it working.

    Master Puppet server is setup with Passengers, all works well:

    /etc/puppet/puppet.conf
    [main]
    # The Puppet log directory.
    # The default value is '$vardir/log'.
    logdir = /var/log/puppet

    # Where Puppet PID files are kept.
    # The default value is '$vardir/run'.
    rundir = /var/run/puppet

    # Where SSL certificates are kept.
    # The default value is '$confdir/ssl'.
    ssldir = /etc/puppet/ssl

    [agent]
    # The file in which puppetd stores a list of the classes
    # associated with the retrieved configuratiion. Can be loaded in
    # the separate ``puppet`` executable using the ``--loadclasses``
    # option.
    # The default value is '$confdir/classes.txt'.
    classfile = $vardir/classes.txt

    # Where puppetd caches the local configuration. An
    # extension indicating the cache format is added automatically.
    # The default value is '$confdir/localconfig'.
    localconfig = $vardir/localconfig

    # Turn on Reporting
    report = true

    [master]
    reports = tagmail
    ssl_client_header = SSL_CLIENT_S_DN
    ssl_client_verify_header = SSL_CLIENT_VERIFY

    And my /etc/puppet/tagmail.conf:
    all: my@email.com

    On the slave, I have this setup in my puppet.conf:
    [main]
    # The Puppet log directory.
    # The default value is '$vardir/log'.
    logdir = /var/log/puppet

    # Where Puppet PID files are kept.
    # The default value is '$vardir/run'.
    rundir = /var/run/puppet

    # Where SSL certificates are kept.
    # The default value is '$confdir/ssl'.
    ssldir = $vardir/ssl

    # Stuff
    server = puppet

    [agent]
    # The file in which puppetd stores a list of the classes
    # associated with the retrieved configuratiion. Can be loaded in
    # the separate ``puppet`` executable using the ``--loadclasses``
    # option.
    # The default value is '$confdir/classes.txt'.
    classfile = $vardir/classes.txt

    # Where puppetd caches the local configuration. An
    # extension indicating the cache format is added automatically.
    # The default value is '$confdir/localconfig'.
    localconfig = $vardir/localconfig

    # Enable Reporting
    report = true



    The reporting seems to work fine, my /var/lib/puppet/reports directory is
    populated every time the agent is run. But I never receive an email, and
    I've checked the /var/log/maillog (no event occurs).

    I'm sure I'm missing something stupid here -- been banging my head on it for
    awhile. Any idea?

    Thanks,

    Jason

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/i1l6ylp8XXsJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/cjCwkXhAIJsJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Jo Rhett at Jun 12, 2012 at 7:44 pm
    Quick test: can you send mail from this system at all? I've seen this kind of problem on CentOS when postfix was installed but not set up to be 'mta' in alternatives for instance. This meant that /usr/sbin/sendmail went nowhere...
    On Jun 12, 2012, at 11:49 AM, Jason Knudsen wrote:
    Relatively new to Puppet and I'm trying to setup tagmail to send all emails to me: at one point I'll filter that down to errors and whatnot (based on tags) but for now I just want to get it working.

    Master Puppet server is setup with Passengers, all works well:

    /etc/puppet/puppet.conf
    [main]
    # The Puppet log directory.
    # The default value is '$vardir/log'.
    logdir = /var/log/puppet

    # Where Puppet PID files are kept.
    # The default value is '$vardir/run'.
    rundir = /var/run/puppet

    # Where SSL certificates are kept.
    # The default value is '$confdir/ssl'.
    ssldir = /etc/puppet/ssl

    [agent]
    # The file in which puppetd stores a list of the classes
    # associated with the retrieved configuratiion. Can be loaded in
    # the separate ``puppet`` executable using the ``--loadclasses``
    # option.
    # The default value is '$confdir/classes.txt'.
    classfile = $vardir/classes.txt

    # Where puppetd caches the local configuration. An
    # extension indicating the cache format is added automatically.
    # The default value is '$confdir/localconfig'.
    localconfig = $vardir/localconfig

    # Turn on Reporting
    report = true

    [master]
    reports = tagmail
    ssl_client_header = SSL_CLIENT_S_DN
    ssl_client_verify_header = SSL_CLIENT_VERIFY

    And my /etc/puppet/tagmail.conf:
    all: my@email.com

    On the slave, I have this setup in my puppet.conf:
    [main]
    # The Puppet log directory.
    # The default value is '$vardir/log'.
    logdir = /var/log/puppet

    # Where Puppet PID files are kept.
    # The default value is '$vardir/run'.
    rundir = /var/run/puppet

    # Where SSL certificates are kept.
    # The default value is '$confdir/ssl'.
    ssldir = $vardir/ssl

    # Stuff
    server = puppet

    [agent]
    # The file in which puppetd stores a list of the classes
    # associated with the retrieved configuratiion. Can be loaded in
    # the separate ``puppet`` executable using the ``--loadclasses``
    # option.
    # The default value is '$confdir/classes.txt'.
    classfile = $vardir/classes.txt

    # Where puppetd caches the local configuration. An
    # extension indicating the cache format is added automatically.
    # The default value is '$confdir/localconfig'.
    localconfig = $vardir/localconfig

    # Enable Reporting
    report = true



    The reporting seems to work fine, my /var/lib/puppet/reports directory is populated every time the agent is run. But I never receive an email, and I've checked the /var/log/maillog (no event occurs).

    I'm sure I'm missing something stupid here -- been banging my head on it for awhile. Any idea?

    Thanks,

    Jason

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/i1l6ylp8XXsJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
    --
    Jo Rhett
    Net Consonance : net philanthropy to improve open source and internet projects.



    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Jason Knudsen at Jun 12, 2012 at 7:59 pm
    Yeah -- checked that already, sorry forgot to mention that. Setup with
    postfix and a relay. Running /usr/sbin/sendmail my@email.com gets delivered
    properly
    On Tuesday, June 12, 2012 3:43:48 PM UTC-4, Jo wrote:

    Quick test: can you send mail from this system at all? I've seen this
    kind of problem on CentOS when postfix was installed but not set up to be
    'mta' in alternatives for instance. This meant that /usr/sbin/sendmail went
    nowhere...

    On Jun 12, 2012, at 11:49 AM, Jason Knudsen wrote:

    Relatively new to Puppet and I'm trying to setup tagmail to send all
    emails to me: at one point I'll filter that down to errors and whatnot
    (based on tags) but for now I just want to get it working.

    Master Puppet server is setup with Passengers, all works well:

    /etc/puppet/puppet.conf
    [main]
    # The Puppet log directory.
    # The default value is '$vardir/log'.
    logdir = /var/log/puppet

    # Where Puppet PID files are kept.
    # The default value is '$vardir/run'.
    rundir = /var/run/puppet

    # Where SSL certificates are kept.
    # The default value is '$confdir/ssl'.
    ssldir = /etc/puppet/ssl

    [agent]
    # The file in which puppetd stores a list of the classes
    # associated with the retrieved configuratiion. Can be loaded in
    # the separate ``puppet`` executable using the ``--loadclasses``
    # option.
    # The default value is '$confdir/classes.txt'.
    classfile = $vardir/classes.txt

    # Where puppetd caches the local configuration. An
    # extension indicating the cache format is added automatically.
    # The default value is '$confdir/localconfig'.
    localconfig = $vardir/localconfig

    # Turn on Reporting
    report = true

    [master]
    reports = tagmail
    ssl_client_header = SSL_CLIENT_S_DN
    ssl_client_verify_header = SSL_CLIENT_VERIFY

    And my /etc/puppet/tagmail.conf:
    all: my@email.com

    On the slave, I have this setup in my puppet.conf:
    [main]
    # The Puppet log directory.
    # The default value is '$vardir/log'.
    logdir = /var/log/puppet

    # Where Puppet PID files are kept.
    # The default value is '$vardir/run'.
    rundir = /var/run/puppet

    # Where SSL certificates are kept.
    # The default value is '$confdir/ssl'.
    ssldir = $vardir/ssl

    # Stuff
    server = puppet

    [agent]
    # The file in which puppetd stores a list of the classes
    # associated with the retrieved configuratiion. Can be loaded in
    # the separate ``puppet`` executable using the ``--loadclasses``
    # option.
    # The default value is '$confdir/classes.txt'.
    classfile = $vardir/classes.txt

    # Where puppetd caches the local configuration. An
    # extension indicating the cache format is added automatically.
    # The default value is '$confdir/localconfig'.
    localconfig = $vardir/localconfig

    # Enable Reporting
    report = true



    The reporting seems to work fine, my /var/lib/puppet/reports directory is
    populated every time the agent is run. But I never receive an email, and
    I've checked the /var/log/maillog (no event occurs).

    I'm sure I'm missing something stupid here -- been banging my head on it
    for awhile. Any idea?

    Thanks,

    Jason

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/i1l6ylp8XXsJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.


    --
    Jo Rhett
    Net Consonance : net philanthropy to improve open source and internet
    projects.


    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/CBTYiu3MmJsJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Iain Sutton at Jun 14, 2012 at 10:49 pm
    Legacy perhaps, but we have:

    confdir = /etc/puppet
    tagmap = $confdir/tagmail.conf

    in puppet.conf's [master] section and our tagmails work.

    Cheers,

    Iain
    On 13 June 2012 05:59, Jason Knudsen wrote:

    Yeah -- checked that already, sorry forgot to mention that. Setup with
    postfix and a relay. Running /usr/sbin/sendmail my@email.com gets
    delivered properly

    On Tuesday, June 12, 2012 3:43:48 PM UTC-4, Jo wrote:

    Quick test: can you send mail from this system at all? I've seen this
    kind of problem on CentOS when postfix was installed but not set up to be
    'mta' in alternatives for instance. This meant that /usr/sbin/sendmail went
    nowhere...

    On Jun 12, 2012, at 11:49 AM, Jason Knudsen wrote:

    Relatively new to Puppet and I'm trying to setup tagmail to send all
    emails to me: at one point I'll filter that down to errors and whatnot
    (based on tags) but for now I just want to get it working.

    Master Puppet server is setup with Passengers, all works well:

    /etc/puppet/puppet.conf
    [main]
    # The Puppet log directory.
    # The default value is '$vardir/log'.
    logdir = /var/log/puppet

    # Where Puppet PID files are kept.
    # The default value is '$vardir/run'.
    rundir = /var/run/puppet

    # Where SSL certificates are kept.
    # The default value is '$confdir/ssl'.
    ssldir = /etc/puppet/ssl

    [agent]
    # The file in which puppetd stores a list of the classes
    # associated with the retrieved configuratiion. Can be loaded in
    # the separate ``puppet`` executable using the ``--loadclasses``
    # option.
    # The default value is '$confdir/classes.txt'.
    classfile = $vardir/classes.txt

    # Where puppetd caches the local configuration. An
    # extension indicating the cache format is added automatically.
    # The default value is '$confdir/localconfig'.
    localconfig = $vardir/localconfig

    # Turn on Reporting
    report = true

    [master]
    reports = tagmail
    ssl_client_header = SSL_CLIENT_S_DN
    ssl_client_verify_header = SSL_CLIENT_VERIFY

    And my /etc/puppet/tagmail.conf:
    all: my@email.com

    On the slave, I have this setup in my puppet.conf:
    [main]
    # The Puppet log directory.
    # The default value is '$vardir/log'.
    logdir = /var/log/puppet

    # Where Puppet PID files are kept.
    # The default value is '$vardir/run'.
    rundir = /var/run/puppet

    # Where SSL certificates are kept.
    # The default value is '$confdir/ssl'.
    ssldir = $vardir/ssl

    # Stuff
    server = puppet

    [agent]
    # The file in which puppetd stores a list of the classes
    # associated with the retrieved configuratiion. Can be loaded in
    # the separate ``puppet`` executable using the ``--loadclasses``
    # option.
    # The default value is '$confdir/classes.txt'.
    classfile = $vardir/classes.txt

    # Where puppetd caches the local configuration. An
    # extension indicating the cache format is added automatically.
    # The default value is '$confdir/localconfig'.
    localconfig = $vardir/localconfig

    # Enable Reporting
    report = true



    The reporting seems to work fine, my /var/lib/puppet/reports directory is
    populated every time the agent is run. But I never receive an email, and
    I've checked the /var/log/maillog (no event occurs).

    I'm sure I'm missing something stupid here -- been banging my head on it
    for awhile. Any idea?

    Thanks,

    Jason

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/**
    msg/puppet-users/-/**i1l6ylp8XXsJ<https://groups.google.com/d/msg/puppet-users/-/i1l6ylp8XXsJ>
    .
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@**
    googlegroups.com <puppet-users+unsubscribe@googlegroups.com>.
    For more options, visit this group at http://groups.google.com/**
    group/puppet-users?hl=en<http://groups.google.com/group/puppet-users?hl=en>
    .


    --
    Jo Rhett
    Net Consonance : net philanthropy to improve open source and internet
    projects.



    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/CBTYiu3MmJsJ.

    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Jason Knudsen at Jun 15, 2012 at 7:34 pm
    Finally got this working. I tried the below config, didn't help.... then
    actually rebooted the server itself, and hooray! Weird how these things
    work..

    Case closed!

    Thanks for all your help

    Jason
    On Thursday, June 14, 2012 6:48:57 PM UTC-4, nseagoon wrote:

    Legacy perhaps, but we have:

    confdir = /etc/puppet
    tagmap = $confdir/tagmail.conf

    in puppet.conf's [master] section and our tagmails work.

    Cheers,

    Iain
    On 13 June 2012 05:59, Jason Knudsen wrote:

    Yeah -- checked that already, sorry forgot to mention that. Setup with
    postfix and a relay. Running /usr/sbin/sendmail my@email.com gets
    delivered properly

    On Tuesday, June 12, 2012 3:43:48 PM UTC-4, Jo wrote:

    Quick test: can you send mail from this system at all? I've seen this
    kind of problem on CentOS when postfix was installed but not set up to be
    'mta' in alternatives for instance. This meant that /usr/sbin/sendmail went
    nowhere...

    On Jun 12, 2012, at 11:49 AM, Jason Knudsen wrote:

    Relatively new to Puppet and I'm trying to setup tagmail to send all
    emails to me: at one point I'll filter that down to errors and whatnot
    (based on tags) but for now I just want to get it working.

    Master Puppet server is setup with Passengers, all works well:

    /etc/puppet/puppet.conf
    [main]
    # The Puppet log directory.
    # The default value is '$vardir/log'.
    logdir = /var/log/puppet

    # Where Puppet PID files are kept.
    # The default value is '$vardir/run'.
    rundir = /var/run/puppet

    # Where SSL certificates are kept.
    # The default value is '$confdir/ssl'.
    ssldir = /etc/puppet/ssl

    [agent]
    # The file in which puppetd stores a list of the classes
    # associated with the retrieved configuratiion. Can be loaded in
    # the separate ``puppet`` executable using the ``--loadclasses``
    # option.
    # The default value is '$confdir/classes.txt'.
    classfile = $vardir/classes.txt

    # Where puppetd caches the local configuration. An
    # extension indicating the cache format is added automatically.
    # The default value is '$confdir/localconfig'.
    localconfig = $vardir/localconfig

    # Turn on Reporting
    report = true

    [master]
    reports = tagmail
    ssl_client_header = SSL_CLIENT_S_DN
    ssl_client_verify_header = SSL_CLIENT_VERIFY

    And my /etc/puppet/tagmail.conf:
    all: my@email.com

    On the slave, I have this setup in my puppet.conf:
    [main]
    # The Puppet log directory.
    # The default value is '$vardir/log'.
    logdir = /var/log/puppet

    # Where Puppet PID files are kept.
    # The default value is '$vardir/run'.
    rundir = /var/run/puppet

    # Where SSL certificates are kept.
    # The default value is '$confdir/ssl'.
    ssldir = $vardir/ssl

    # Stuff
    server = puppet

    [agent]
    # The file in which puppetd stores a list of the classes
    # associated with the retrieved configuratiion. Can be loaded in
    # the separate ``puppet`` executable using the ``--loadclasses``
    # option.
    # The default value is '$confdir/classes.txt'.
    classfile = $vardir/classes.txt

    # Where puppetd caches the local configuration. An
    # extension indicating the cache format is added automatically.
    # The default value is '$confdir/localconfig'.
    localconfig = $vardir/localconfig

    # Enable Reporting
    report = true



    The reporting seems to work fine, my /var/lib/puppet/reports directory
    is populated every time the agent is run. But I never receive an email, and
    I've checked the /var/log/maillog (no event occurs).

    I'm sure I'm missing something stupid here -- been banging my head on it
    for awhile. Any idea?

    Thanks,

    Jason

    --
    You received this message because you are subscribed to the Google
    Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/**
    msg/puppet-users/-/**i1l6ylp8XXsJ<https://groups.google.com/d/msg/puppet-users/-/i1l6ylp8XXsJ>
    .
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@*
    *googlegroups.com <puppet-users+unsubscribe@googlegroups.com>.
    For more options, visit this group at http://groups.google.com/**
    group/puppet-users?hl=en<http://groups.google.com/group/puppet-users?hl=en>
    .


    --
    Jo Rhett
    Net Consonance : net philanthropy to improve open source and internet
    projects.



    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/CBTYiu3MmJsJ.

    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/4jWdbj-JqYsJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedJun 12, '12 at 6:52p
activeJun 15, '12 at 7:34p
posts7
users4
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase