FAQ
Hi,

whenever i am starting puppet master after new installation it gives below
messages ..

/usr/lib/ruby/site_ruby/1.8/puppet/util/pidlock.rb:33:in `initialize':
Permission denied - /var/lib/puppet/run/master.pid (Errno::EACCES)
from /usr/lib/ruby/site_ruby/1.8/puppet/util/pidlock.rb:33:in `open'
from /usr/lib/ruby/site_ruby/1.8/puppet/util/pidlock.rb:33:in `lock'
from /usr/lib/ruby/site_ruby/1.8/puppet/daemon.rb:47:in `create_pidfile'
from /usr/lib/ruby/site_ruby/1.8/puppet/util.rb:39:in `synchronize_on'
from /usr/lib/ruby/1.8/sync.rb:229:in `synchronize'
from /usr/lib/ruby/site_ruby/1.8/puppet/util.rb:39:in `synchronize_on'
from /usr/lib/ruby/site_ruby/1.8/puppet/daemon.rb:46:in `create_pidfile'
from /usr/lib/ruby/site_ruby/1.8/puppet/daemon.rb:22:in `daemonize'
from /usr/lib/ruby/site_ruby/1.8/puppet/application/master.rb:105:in
`main'
from /usr/lib/ruby/site_ruby/1.8/puppet/application/master.rb:46:in
`run_command'
from /usr/lib/ruby/site_ruby/1.8/puppet/application.rb:304:in `run'
from /usr/lib/ruby/site_ruby/1.8/puppet/application.rb:410:in
`exit_on_fail'
from /usr/lib/ruby/site_ruby/1.8/puppet/application.rb:304:in `run'
from /usr/lib/ruby/site_ruby/1.8/puppet/util/command_line.rb:59:in
`execute'
from /usr/bin/puppet:4


can anyone suggest what are those , what is missing ? i have used default
puppet.conf file generated using command line with -genconfig option

Regards,
Dhaval

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Bernd Adamowicz at Jun 11, 2012 at 1:24 pm
    Obviously the user which is executing the Puppet start command is not allowed to access the directory '/var/lib/puppet/run/' or the file '/var/lib/puppet/run/pidlock.rb'. Are you starting the master as root? If not, you should. If the problem persists, check the access rights and permissions of the file/directory.

    Bernd

    /var/lib/puppet/run/
    -----Ursprüngliche Nachricht-----
    Von: puppet-users@googlegroups.com [mailto:puppet-
    users@googlegroups.com] Im Auftrag von Dhaval
    Gesendet: Montag, 11. Juni 2012 15:14
    An: puppet-users@googlegroups.com
    Betreff: [Puppet Users] Start puppet master

    Hi,

    whenever i am starting puppet master after new installation it gives
    below messages ..

    /usr/lib/ruby/site_ruby/1.8/puppet/util/pidlock.rb:33:in `initialize':
    Permission denied - /var/lib/puppet/run/master.pid (Errno::EACCES)
    from /usr/lib/ruby/site_ruby/1.8/puppet/util/pidlock.rb:33:in
    `open'
    from /usr/lib/ruby/site_ruby/1.8/puppet/util/pidlock.rb:33:in
    `lock'
    from /usr/lib/ruby/site_ruby/1.8/puppet/daemon.rb:47:in
    `create_pidfile'
    from /usr/lib/ruby/site_ruby/1.8/puppet/util.rb:39:in
    `synchronize_on'
    from /usr/lib/ruby/1.8/sync.rb:229:in `synchronize'
    from /usr/lib/ruby/site_ruby/1.8/puppet/util.rb:39:in
    `synchronize_on'
    from /usr/lib/ruby/site_ruby/1.8/puppet/daemon.rb:46:in
    `create_pidfile'
    from /usr/lib/ruby/site_ruby/1.8/puppet/daemon.rb:22:in
    `daemonize'
    from
    /usr/lib/ruby/site_ruby/1.8/puppet/application/master.rb:105:in
    `main'
    from
    /usr/lib/ruby/site_ruby/1.8/puppet/application/master.rb:46:in
    `run_command'
    from /usr/lib/ruby/site_ruby/1.8/puppet/application.rb:304:in
    `run'
    from /usr/lib/ruby/site_ruby/1.8/puppet/application.rb:410:in
    `exit_on_fail'
    from /usr/lib/ruby/site_ruby/1.8/puppet/application.rb:304:in
    `run'
    from
    /usr/lib/ruby/site_ruby/1.8/puppet/util/command_line.rb:59:in
    `execute'
    from /usr/bin/puppet:4


    can anyone suggest what are those , what is missing ? i have used
    default puppet.conf file generated using command line with -genconfig
    option

    Regards,
    Dhaval

    --
    You received this message because you are subscribed to the Google
    Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-
    users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Dhaval at Jun 11, 2012 at 2:23 pm
    Thanks Bernd,

    yes i am starting it with root and below are the permission for that directory.

    drwxr-xr-x 2 root root 4096 Jun 11 21:09 /var/lib/puppet/run/

    eventhough after doing 777 it's giving same messages.

    Regards,
    Dhaval



    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Dhaval at Jun 11, 2012 at 2:47 pm

    Dhaval <dhaval.joshi <at> nomura.com> writes:


    Thanks Bernd,

    yes i am starting it with root and below are the permission for that
    directory.
    drwxr-xr-x 2 root root 4096 Jun 11 21:09 /var/lib/puppet/run/

    eventhough after doing 777 it's giving same messages.

    Regards,
    Dhaval
    Ok it's resolved now, i have changed the above directory permission to
    puppet:puppet and started service with root, it works nicely now.


    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedJun 11, '12 at 1:14p
activeJun 11, '12 at 2:47p
posts4
users2
websitepuppetlabs.com

2 users in discussion

Dhaval: 3 posts Bernd Adamowicz: 1 post

People

Translate

site design / logo © 2022 Grokbase