FAQ
I am using puppet in standalone mode (puppet apply) to test manifests that
I also use in a client/server configuration.

I have everything working as far as files included in modules. I can
reference file source as "puppet:///modules/modulename/path/to/file".

However, some files are not part of a module, so for the client/server
portion, I just set up a share called files. However, references to these
files "puppet://files/path/to/files" don't work in standalone mode.

I understand that standalone mode (puppet apply) command can find the
module files because you tell it the path to look in (--modulepath
argument). Why is there no argument for adding file shares
(--fileserver=files:/path/to/files)? Is there another way to achieve this?

My workaround for now is to simply move the files to a module named files
and reference them as "puppet:///modules/files/path/to/file", but it seems
like there might be a better solution.

Thanks.

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/zatQ35einsgJ.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Scott Smerchek at Nov 21, 2012 at 8:04 pm
    I'm having this same problem. Is there a solution?
    On Thursday, May 24, 2012 11:37:12 AM UTC-5, btimby wrote:

    I am using puppet in standalone mode (puppet apply) to test manifests that
    I also use in a client/server configuration.

    I have everything working as far as files included in modules. I can
    reference file source as "puppet:///modules/modulename/path/to/file".

    However, some files are not part of a module, so for the client/server
    portion, I just set up a share called files. However, references to these
    files "puppet://files/path/to/files" don't work in standalone mode.

    I understand that standalone mode (puppet apply) command can find the
    module files because you tell it the path to look in (--modulepath
    argument). Why is there no argument for adding file shares
    (--fileserver=files:/path/to/files)? Is there another way to achieve this?

    My workaround for now is to simply move the files to a module named files
    and reference them as "puppet:///modules/files/path/to/file", but it seems
    like there might be a better solution.

    Thanks.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/vNR34Sd6QisJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Ryan Coleman at Nov 26, 2012 at 2:27 am

    On Wed, Nov 21, 2012 at 8:04 AM, Scott Smerchek wrote:

    I'm having this same problem. Is there a solution?

    This doc is a bit buried and hard to find but check out serving from custom
    mount points. That ought to solve your need.
    http://docs.puppetlabs.com/guides/file_serving.html#serving-files-from-custom-mount-points

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Scott Smerchek at Nov 27, 2012 at 9:17 pm
    I did stumble on that doc previously. And we do in fact have that working
    with our puppet master. However, that does not work with puppet standalone
    as far as I can tell.
    On Sunday, November 25, 2012 8:27:16 PM UTC-6, Ryan Coleman wrote:



    On Wed, Nov 21, 2012 at 8:04 AM, Scott Smerchek <scott.s...@gmail.com<javascript:>
    wrote:
    I'm having this same problem. Is there a solution?

    This doc is a bit buried and hard to find but check out serving from
    custom mount points. That ought to solve your need.
    http://docs.puppetlabs.com/guides/file_serving.html#serving-files-from-custom-mount-points
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/Wf4R8XTs4W8J.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Paul Tötterman at Nov 23, 2012 at 9:06 am

    My workaround for now is to simply move the files to a module named files
    and reference them as "puppet:///modules/files/path/to/file", but it seems
    like there might be a better solution.

    I don't know about better, but you can also use file:///... URIs in the
    source parameter.

    Cheers,
    Paul

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/C1qDjVbxRiwJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Brice Figureau at Nov 23, 2012 at 10:58 am

    On Thu, 2012-05-24 at 09:37 -0700, btimby wrote:
    I am using puppet in standalone mode (puppet apply) to test manifests
    that I also use in a client/server configuration.

    I have everything working as far as files included in modules. I can
    reference file source as "puppet:///modules/modulename/path/to/file".

    However, some files are not part of a module, so for the client/server
    portion, I just set up a share called files. However, references to
    these files "puppet://files/path/to/files" don't work in standalone
    mode.
    Because it tries to resolve a host called 'files' as the server where to
    get those files.
    Have you tried:
    puppet:///files/path/to/files
    (notice the ///)
    I understand that standalone mode (puppet apply) command can find the
    module files because you tell it the path to look in (--modulepath
    argument). Why is there no argument for adding file shares
    (--fileserver=files:/path/to/files)? Is there another way to achieve
    this?

    My workaround for now is to simply move the files to a module named
    files and reference them as "puppet:///modules/files/path/to/file",
    but it seems like there might be a better solution.
    You could also setup a puppetmaster only for the purpose of serving
    files to your servers, and use:
    puppet://fileserver.domain.com/files/path/to/file
    kind of url.

    It's still masterless for compilation purposes, but uses a master for
    file serving.
    --
    Brice Figureau
    Follow the latest Puppet Community evolutions on www.planetpuppet.org!

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedMay 24, '12 at 4:43p
activeNov 27, '12 at 9:17p
posts6
users5
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase