FAQ
Howdy,

our puppet master is hosting nagios at the same time. it happens that
the compilation of the catalog for the master during a puppet run
produces a timeout:

===
err: Could not retrieve catalog from remote server: execution expired
warning: Not using cache on failed catalog
err: Could not retrieve catalog; skipping run
===

If the whole nagios part is commented out for the master host puppet
runs fine. I think it is due to loads of stored configs that have to
be collected.

Easiest solution for me would be to increase the timeout on the
master. How and where can the timeout be changed? Are there other
options to speed up the compilation process?

Regards,
David

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Christopher Wood at May 16, 2012 at 1:56 pm

    On Wed, May 16, 2012 at 06:53:08AM -0700, de wrote:
    Howdy,

    our puppet master is hosting nagios at the same time. it happens that
    the compilation of the catalog for the master during a puppet run
    produces a timeout:

    ===
    err: Could not retrieve catalog from remote server: execution expired
    warning: Not using cache on failed catalog
    err: Could not retrieve catalog; skipping run
    ===

    If the whole nagios part is commented out for the master host puppet
    runs fine. I think it is due to loads of stored configs that have to
    be collected.

    Easiest solution for me would be to increase the timeout on the
    master. How and where can the timeout be changed? Are there other
    options to speed up the compilation process?
    Maybe I'm lazy but on our puppetmasters I have a cron job doing "puppet apply /etc/puppet/manifests/site.pp".
    Regards,
    David

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Adam Heinz at May 16, 2012 at 9:20 pm
    Maybe I'm lazy but on our puppetmasters I have a cron job doing "puppet apply /etc/puppet/manifests/site.pp".
    I don't think that works with storeconfigs.

    [root@puppet ~]# rpm -q puppet-server
    puppet-server-2.6.16-1.el6.noarch

    [root@puppet ~]# grep storeconfigs /etc/puppet/puppet.conf
    storeconfigs = true

    [root@puppet ~]# puppet apply /etc/puppet/manifests/site.pp
    warning: You cannot collect without storeconfigs being set on line 7
    in file /etc/puppet/modules/nagios/manifests/target.pp
    warning: You cannot collect without storeconfigs being set on line 14
    in file /etc/puppet/modules/nagios/manifests/target.pp
    ...

    I think the canonical form is more like:

    /usr/bin/puppet agent --no-daemonize --no-listen --onetime

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Nan Liu at May 16, 2012 at 10:43 pm

    On Wed, May 16, 2012 at 2:20 PM, Adam Heinz wrote:
    Maybe I'm lazy but on our puppetmasters I have a cron job doing "puppet apply /etc/puppet/manifests/site.pp".
    I don't think that works with storeconfigs.

    [root@puppet ~]# rpm -q puppet-server
    puppet-server-2.6.16-1.el6.noarch

    [root@puppet ~]# grep storeconfigs /etc/puppet/puppet.conf
    storeconfigs = true


    [root@puppet ~]# puppet apply /etc/puppet/manifests/site.pp
    warning: You cannot collect without storeconfigs being set on line 7
    in file /etc/puppet/modules/nagios/manifests/target.pp
    warning: You cannot collect without storeconfigs being set on line 14
    in file /etc/puppet/modules/nagios/manifests/target.pp
    ...
    You can use storeconfigs via puppet apply if you have the appropriate
    storeconfigs settings in section [main] rather than [master].

    Nan

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedMay 16, '12 at 1:54p
activeMay 16, '12 at 10:43p
posts4
users4
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase