FAQ
Hi everyone,


I am trying to introduce environment use in my puppet setup (Setup with
gem/version 2.7.9 on debian squeeze):
*1. On my master (Apache+passenger):*
*puppet.conf*

[main]
pluginsync = true
confdir = /etc/puppet
...
modulepath =
$confdir/environments/$environment/modules:$confdir/modules

[master]
storeconfigs = true
......

modulepath =
$confdir/environments/$environment/modules:$confdir/modules
reports = store, http, tagmail

*fileserver.conf:*

[modules]

allow *

*auth.conf:*

# inconditionnally allow access to all files services
# which means in practice that fileserver.conf will
# still be used
path /file
allow *



*2. On my slave:*
*puppet.conf:*
[main]

report = true
syslogfacility = daemon
pluginsync = true
confdir = /etc/puppet
templatedir = $confdir/templates
modulepath =
$confdir/environments/$environment/modules:$confdir/modules
# -- [ Environment ]--
environment = testing

*3. On my testing module:*
*/etc/puppet/environments/testing/modules/test/manifest/init.pp
*

file { 'test_file':

path => '/tmp/test',

source =>
"puppet:///${::environment}/${module_name}/sources.list.d/test.list",

}


And:
ls -al
/etc/puppet/environments/testing/modules/test/file/sources.list.d/test.list
-rw-r--r-- 1 root root 110 May 8
01:12 /etc/puppet/environments/testing/modules/test/file/sources.list.d/test.list

And when I try to run the module on the client I have the following error:
Tue May 08 02:32:12 +0200 2012 File[/tmp/test] (err): Could not evaluate:
Error 400 on SERVER: Not authorized to call find on
/file_metadata/testing/test/sources.list.d/test.list

I tried different stuff with fileserver and auth.conf but nothing worked,
so any idea would be helpfull :D. But surely I have missed something.


Regards,
JM

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Antidot SAS at May 9, 2012 at 11:02 am
    Hi everyone,


    Found the error... A bad directory name in the module directory: "file"
    instead of "files".


    Regards,
    JM
    On Tue, May 8, 2012 at 3:09 AM, Antidot SAS wrote:

    Hi everyone,


    I am trying to introduce environment use in my puppet setup (Setup with
    gem/version 2.7.9 on debian squeeze):
    *1. On my master (Apache+passenger):*
    *puppet.conf*

    [main]
    pluginsync = true
    confdir = /etc/puppet
    ...
    modulepath =
    $confdir/environments/$environment/modules:$confdir/modules

    [master]
    storeconfigs = true
    ......

    modulepath =
    $confdir/environments/$environment/modules:$confdir/modules
    reports = store, http, tagmail

    *fileserver.conf:*

    [modules]

    allow *

    *auth.conf:*

    # inconditionnally allow access to all files services
    # which means in practice that fileserver.conf will
    # still be used
    path /file
    allow *



    *2. On my slave:*
    *puppet.conf:*
    [main]

    report = true
    syslogfacility = daemon
    pluginsync = true
    confdir = /etc/puppet
    templatedir = $confdir/templates
    modulepath =
    $confdir/environments/$environment/modules:$confdir/modules
    # -- [ Environment ]--
    environment = testing

    *3. On my testing module:*
    */etc/puppet/environments/testing/modules/test/manifest/init.pp
    *

    file { 'test_file':

    path => '/tmp/test',

    source =>
    "puppet:///${::environment}/${module_name}/sources.list.d/test.list",

    }


    And:
    ls -al
    /etc/puppet/environments/testing/modules/test/file/sources.list.d/test.list
    -rw-r--r-- 1 root root 110 May 8
    01:12 /etc/puppet/environments/testing/modules/test/file/sources.list.d/test.list

    And when I try to run the module on the client I have the following error:
    Tue May 08 02:32:12 +0200 2012 File[/tmp/test] (err): Could not evaluate:
    Error 400 on SERVER: Not authorized to call find on
    /file_metadata/testing/test/sources.list.d/test.list

    I tried different stuff with fileserver and auth.conf but nothing worked,
    so any idea would be helpfull :D. But surely I have missed something.


    Regards,
    JM

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedMay 8, '12 at 1:09a
activeMay 9, '12 at 11:02a
posts2
users1
websitepuppetlabs.com

1 user in discussion

Antidot SAS: 2 posts

People

Translate

site design / logo © 2022 Grokbase